Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > General Support > Topic : Changing to PHP7 has no effect



Threaded Mode | Print  

 Changing to PHP7 has no effect, Changed to PHP 7 and restarted apache but still see it is running older versions (2 Replies, Read 1513 times)
blindacme
Group: Member
Post Group: Newbie
Posts: 1
Status:
I have just installed Ampps on mac OSx Sierra and I immediately changed the version of php to 7, restarted apache and tried setting up my laravel install.  When doing so I get an error that a package Im using requires php 7 or above so I ran a test in terminal
Code
php -v
and I see the below message:

PHP 5.6.30 (cli) (built: Feb  7 2017 16:06:52)
Copyright (c) 1997-2016 The PHP Group

I verified Apache and MySQL is running, PHP version is 7 as displayed in Ampp homepage box and already restarted apache.  Am I missing something?
IP: --   

Changing to PHP7 has no effect
DvdEnde
Group: Member
Post Group: Newbie
Posts: 1
Status:
Blindacme the version apache use is different from the version you use on a terminal or powershell box.

Your version:
PHP 5.6.30 (cli) (built: Feb  7 2017 16:06:52)
You see (cli)? This means Command Line Interface. Normally it should be the same version as the version apache use.

Maybe you have a native installation on your machine before you installed ampps? Like Mac comes with an apche installation. This can explain this situation.

I would advise to clean up because it can make you a lot of problems later.
Clean up means: yeah uninstall ampps. check for local apache installations, clean that up too (delete or uninstall, depends on the operating system) and then if you are sure there is no php, apache etc on you machine, install ampps again.

Please think of an backup of your development data.
IP: --   

Changing to PHP7 has no effect
Rishi_P
Group: AMPPS Team
Post Group: Working Member
Posts: 245
Status:
Hi Blindacme,

May be php-5.6.30 is your MAC OS php version, Mac OS comes with pre installed LAMP stack.

Please follow this guide to install laravel:
http://www.ampps.com/wiki/Installing_Laravel_Framework
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is June 29, 2017, 10:47 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.115