Softaculous http://www.softaculous.com/board/index.php? <![CDATA[Webuzo behind Firewall and One-to-One Nat]]> http://www.softaculous.com/board/index.php?tid=6332&tpg=1#p23228 ]]> Fri, 26 Dec 2014 23:25:45 GMT http://www.softaculous.com/board/index.php?tid=6332&tpg=1#p23228 <![CDATA[Webuzo behind Firewall and One-to-One Nat]]> http://www.softaculous.com/board/index.php?tid=6332&tpg=1#p23227 ]]> Fri, 26 Dec 2014 22:51:11 GMT http://www.softaculous.com/board/index.php?tid=6332&tpg=1#p23227 <![CDATA[Webuzo behind Firewall and One-to-One Nat]]> http://www.softaculous.com/board/index.php?tid=6332&tpg=1#p23226
To further investigate the problem, I uninstalled all Webuzo Apps and then re-installed Webuzo.  Things appeared to work as expected following the reinstall. The default website came up with the usual Webuzo placeholder page (good).  I was able to access the services page (good).  However, after I restarted apache, the default domain no longer worked.  I returned to the end user panel homepage and then attempted to click on services, and it would not respond.  In other words, if I reboot the server OR restart apache, something goes wrong.

I am thinking the problem is being caused by the server residing behind a NAT router and using one-to-one NAT to map one of our available public IP's from our block.  I am starting to think that either apache or webuzo is getting confused between the private IP on eth0 and the public IP that is mapped to it.

-=ROUTER (Cisco RV325)=-
- DHCP server on 192.168.2.1
- Public static IP 72.22.x.1 (used by DHCP clients)
- I have 10 sequential static public IP's available to my account to use/assign as I need.
- I use one-to-one NAT to assign static public IP's to servers behind the router.

-=UBUNTU SERVER RUNNING WEBUZO=-
- eth0 is on a static private IP 192.168.2.156 that it receives from the dhcp server on the Cisco router via MAC to IP binding.
- Public static IP 72.22.x.8 is mapped to the private IP above using one-to-one NAT on the Cisco router. In other words, public 72.22.x.8 routes to private 192.168.2.156.  All ports are open at the router.
- ns1.myhost.com and ns2.myhost.com (not actual domain, but used for illustration purposes) are setup with godaddy and pointing to 72.22.x.8, as they should.
- Hostname and FQDN are setup in ubuntu /etc/hosts file correctly I believe.

-=WEBUZO ADMIN CP>>SETTINGS>>NAMESERVERS=-
- Primary IP - I have tried using the one-to-one nat public IP (72.22.x.8) as well as the private IP (192.168.2.156).  My assumption is that the public IP (72.22.x.8) should be used here, but thought I'd try both, considering my difficulties.
- Primary Domain - I have myhost.com in this field.
- NS1/NS2 - I have ns1.myhost.com and ns2.myhost.com in these fields, respectively.


Any ideas? :)
]]>
Fri, 26 Dec 2014 22:03:17 GMT http://www.softaculous.com/board/index.php?tid=6332&tpg=1#p23226
<![CDATA[unable to run php files after installation]]> http://www.softaculous.com/board/index.php?tid=6334&tpg=1#p23225 Fri, 26 Dec 2014 15:08:23 GMT http://www.softaculous.com/board/index.php?tid=6334&tpg=1#p23225 <![CDATA[Everything works Fine until I ADD 1st VIRTUAL site.]]> http://www.softaculous.com/board/index.php?tid=6338&tpg=1#p23224 when i type "service apache restart" it says NO SUCH JOB]]> Fri, 26 Dec 2014 14:16:11 GMT http://www.softaculous.com/board/index.php?tid=6338&tpg=1#p23224 <![CDATA[unable to run php files after installation]]> http://www.softaculous.com/board/index.php?tid=6334&tpg=1#p23223 Fri, 26 Dec 2014 08:24:20 GMT http://www.softaculous.com/board/index.php?tid=6334&tpg=1#p23223 <![CDATA[AMPPS 2.7 launched]]> http://www.softaculous.com/board/index.php?tid=6327&tpg=1#p23222 Fri, 26 Dec 2014 08:10:17 GMT http://www.softaculous.com/board/index.php?tid=6327&tpg=1#p23222 <![CDATA[Interworx + Wordpress import issue]]> http://www.softaculous.com/board/index.php?tid=6324&tpg=1#p23221
Some Interworx servers do not point localhost to 127.0.0.1 by default.

I am not sure but I think you need to make some changes on your server to have localhost point to 127.0.0.1

Let us know if you face any issues.]]>
Fri, 26 Dec 2014 07:36:35 GMT http://www.softaculous.com/board/index.php?tid=6324&tpg=1#p23221
<![CDATA[Restore of Wordpress Error]]> http://www.softaculous.com/board/index.php?tid=6335&tpg=1#p23220
Can you please open a support ticket with the control panel login details so that we can check it asap :
https://www.softaculous.com/support/]]>
Fri, 26 Dec 2014 07:34:57 GMT http://www.softaculous.com/board/index.php?tid=6335&tpg=1#p23220
<![CDATA[Other websites like facebook/twitter not able to access my website]]> http://www.softaculous.com/board/index.php?tid=6336&tpg=1#p23219
Yes The domain is pointing to webuzo server IP as you can see, entering domain www.minaddress.info or the ip address 85.159.211.239/minaddress open the same page and work properly.
I restarted all services but no effect.

I think the issue is the way webuzo redirects the request for a domain name once it gets it through the ip because instead of showing correct website index, it is showing me webuzo error page "This page is generated by Softaculous Webuzo, a leading provided of software for the webhosting industry. You are seeing this page because you  have not uploaded the site content yet."
Please help.]]>
Fri, 26 Dec 2014 07:26:30 GMT http://www.softaculous.com/board/index.php?tid=6336&tpg=1#p23219