Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > General Support > Topic : Apache and mail problem



Threaded Mode | Print  

 Apache and mail problem, can't send mail in my development setup (6 Replies, Read 3483 times)
Randall
Group: Member
Post Group: Newbie
Posts: 9
Status:
I am using PHP Version : 5.3.8 and AMPPS Version : 1.2 to develop a new section of our website locally.  I can't seem to get my development setup to send email, where as our live site will send email.  I'm thinking there must be some Apache setting that will make this work, but I am very new to Apache and haven't a clue. I am using the same code as the live site and nothing will send.  The PHP on my local machine is a newer version.  Maybe this is the issue. I have fixed all of the deprecated ereg/eregi functions. Any ideas?  I would appreciate any help. Randall
IP: --   

Apache and mail problem
tidus
Group: AMPPS Team
Post Group: Super Member
Posts: 1123
Status:
Quote From : Randall December 26, 2011, 11:07 am
I am using PHP Version : 5.3.8 and AMPPS Version : 1.2 to develop a new section of our website locally.  I can't seem to get my development setup to send email, where as our live site will send email.  I'm thinking there must be some Apache setting that will make this work, but I am very new to Apache and haven't a clue. I am using the same code as the live site and nothing will send.  The PHP on my local machine is a newer version.  Maybe this is the issue. I have fixed all of the deprecated ereg/eregi functions. Any ideas?  I would appreciate any help. Randall
Hi,

You will have to configure a SMTP server. Since production server are configured by default you are able to send emails from live site.


-----------------------
Follow AMPPS on,
Twitter : https://twitter.com/AMPPS_Stack
Facebook :  http://www.facebook.com/softaculousampps
Google+ : https://plus.google.com/+AmppsStack
IP: --   

Apache and mail problem
Randall
Group: Member
Post Group: Newbie
Posts: 9
Status:
Thanks Tidus for the help. I made the follow settings in my php.ini file and restarted Apache.  [mail function]
; For Win32 only.
SMTP = smtp.go2sakso.orgsmtp_port = 25sendmail_from = dinansary@go2sakso.org It is still not working.  Is there something else I am missing? Thanks. Randall
IP: --   

Apache and mail problem
Josh
Group: Member
Post Group: Newbie
Posts: 7
Status:
You'll need to install a mail server like hMailServer.
IP: --   

Apache and mail problem
Randall
Group: Member
Post Group: Newbie
Posts: 9
Status:
thanks for the help!
IP: --   

Apache and mail problem
jarich44
Group: Member
Post Group: Newbie
Posts: 2
Status:
Just wondering is that ever going to be implemented??
IP: --   

Apache and mail problem
tidus
Group: AMPPS Team
Post Group: Super Member
Posts: 1123
Status:
Hi,

Implementation has not been started yet but it is in our to-do list.

-----------------------
Follow AMPPS on,
Twitter : https://twitter.com/AMPPS_Stack
Facebook :  http://www.facebook.com/softaculousampps
Google+ : https://plus.google.com/+AmppsStack
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is October 20, 2014, 9:43 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.327