Softaculous for Plesk Linux and ISP System http://www.softaculous.com/board/index.php?tid=305 <![CDATA[Softaculous for Plesk Linux and ISP System]]> http://www.softaculous.com/board/index.php?tid=305&tpg=3#p6770
Quote From : tim.func September 20, 2011, 6:27 am
I've managed to install Softaculous on my Plesk 10 VPS, and I can access Softaculous as a root user, but there doesn't seem to be a way to add permission for my reseller accounts to access it as well, let alone my subscriptions/customers.

Any thoughts?
Hi,

A user with a domain will be able to install using Softaculous.
Please email us if you are not able to get this working.
We will check it and fix it if there is any issue.]]>
Tue, 20 Sep 2011 06:55:26 GMT http://www.softaculous.com/board/index.php?tid=305&tpg=3#p6770
<![CDATA[Softaculous for Plesk Linux and ISP System]]> http://www.softaculous.com/board/index.php?tid=305&tpg=3#p6769
Any thoughts?
]]>
Tue, 20 Sep 2011 06:27:12 GMT http://www.softaculous.com/board/index.php?tid=305&tpg=3#p6769
<![CDATA[Softaculous for Plesk Linux and ISP System]]> http://www.softaculous.com/board/index.php?tid=305&tpg=3#p4845
Quote From : polykrom February 6, 2011, 10:37 pm
It is not possible to enable posx from php.ini, you have to recompile php without --disable-posix

Hi,

There is a way.
You can just compile the posix.so extension and add it in php.ini

Regards,
ALons]]>
Mon, 07 Feb 2011 11:56:29 GMT http://www.softaculous.com/board/index.php?tid=305&tpg=3#p4845
<![CDATA[Softaculous for Plesk Linux and ISP System]]> http://www.softaculous.com/board/index.php?tid=305&tpg=2#p4843 Sun, 06 Feb 2011 22:37:01 GMT http://www.softaculous.com/board/index.php?tid=305&tpg=2#p4843 <![CDATA[Softaculous for Plesk Linux and ISP System]]> http://www.softaculous.com/board/index.php?tid=305&tpg=2#p3457
Sir, POSIX is required to switch to the necessary user level.
You can do that from the php.ini file.]]>
Sat, 03 Jul 2010 17:50:24 GMT http://www.softaculous.com/board/index.php?tid=305&tpg=2#p3457
<![CDATA[Softaculous for Plesk Linux and ISP System]]> http://www.softaculous.com/board/index.php?tid=305&tpg=2#p3455
still getting a error in the domain interface that says "POSIX MUST BE ENABLED"

]]>
Fri, 02 Jul 2010 20:10:11 GMT http://www.softaculous.com/board/index.php?tid=305&tpg=2#p3455
<![CDATA[Softaculous for Plesk Linux and ISP System]]> http://www.softaculous.com/board/index.php?tid=305&tpg=2#p2342
Quote From : dsaunier January 18, 2010, 6:28 pm
Hmm ok; this was the key.

"/usr/bin/php /usr/local/install_softaculous.php" made the miracle happen...

Thank you.


Hi, I mentioned that in my earlier post itself.

Regards,
Alons]]>
Tue, 19 Jan 2010 00:32:01 GMT http://www.softaculous.com/board/index.php?tid=305&tpg=2#p2342
<![CDATA[Softaculous for Plesk Linux and ISP System]]> http://www.softaculous.com/board/index.php?tid=305&tpg=2#p2340
"/usr/bin/php /usr/local/install_softaculous.php" made the miracle happen...

Thank you.

]]>
Mon, 18 Jan 2010 18:28:31 GMT http://www.softaculous.com/board/index.php?tid=305&tpg=2#p2340
<![CDATA[Softaculous for Plesk Linux and ISP System]]> http://www.softaculous.com/board/index.php?tid=305&tpg=2#p2339 Here is what I did:

D/L and install your install script. Helper gives

+----------------------------------------------+
| PHP Version      | 5.1.6                    |
| Operating System | Linux                    |
| Threaded PHP    | No                        |
| php.ini file    | /etc/php.ini              |
| Required Loader  | ioncube_loader_lin_5.1.so |
+----------------------------------------------+

but its first lines also say

"An ionCube encoded file has been loaded successfully. Encoded files should now function correctly.
If you have a problem with your PHP application, please contact the application provider."

I then checked the PHP version which indeed says 5.1.6, with

"Zend Extension 220051025"
"with the ionCube PHP Loader v3.3.7"

so Zend ioncube comes with Plesk apparently. Anyway I still followed your instructions and installed the latest loaders in /usr/local/ and updated my 2 php.ini files. Apache restarted.
Trying to install softaculous gives

"[root@myserver local]# /usr/local/psa/admin/bin/php /usr/local/install_softaculous.php
Failed loading /usr/local/ioncube/ioncube_loader_lin_5.1.so:  /usr/local/ioncube/ioncube_loader_lin_5.1.so: undefined symbol: zend_hash_destroy
Site error: the file <b>/usr/local/softaculous/enduser/main/functions.php</b> requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator."

and now the helper script outputs

"# php ioncube-loader-helper.php
PHP Warning:  Module 'ionCube Loader' already loaded in Unknown on line 0
The ionCube PHP Loader is disabled because of startup problems.
Could not open input file: ioncube-loader-helper.php"

so I removed my changes to php.ini files to try to install it without any change  :

"# /usr/local/psa/admin/bin/php /usr/local/install_softaculous.php
Site error: the file <b>/usr/local/softaculous/enduser/main/functions.php</b> requires the ionCube PHP Loader ioncube_loader_lin_5.2."

which does not make sense based on your instructions and what the helper script output.
Back to square one so I'm really lost now. A site requiring ioncube ran on this machine out of the box (even though the php.ini files do not reference a Zen loader).
I hope all this can help understand the issue, I'd like to try your application but most people with Plesk servers would probably have given up by now. FYI I could install a competitor's script in a few seconds even though it also requires ioncube.

Regards.]]>
Mon, 18 Jan 2010 18:27:11 GMT http://www.softaculous.com/board/index.php?tid=305&tpg=2#p2339
<![CDATA[Softaculous for Plesk Linux and ISP System]]> http://www.softaculous.com/board/index.php?tid=305&tpg=2#p2338
Quote From : basic January 18, 2010, 5:25 pm
Just to confirm -- YES, it is now working fine on our Plesk servers!

Thank you very much, Softaculous Support!

John

Welcome sir.]]>
Mon, 18 Jan 2010 17:55:07 GMT http://www.softaculous.com/board/index.php?tid=305&tpg=2#p2338