Welcome Guest. Please Login or Register  


You are here: Index > Softaculous Inc. > News and Announcements > Topic : Softaculous for Plesk Linux and ISP System

2


Threaded Mode | Print  

Softaculous for Plesk Linux and ISP System
dsaunier
Group: Member
Post Group: Newbie
Posts: 19
Status:
Hi
I read a lot of pages and tried to install on Plesk. I should not be far from succeeding but I do no understand the following: My directory is created, it contains all required loader files for my OS. When executing the Softaculous installer, I get

Failed loading /usr/local/ioncube/ioncube_loader_lin_5.1.so:  /usr/local/ioncube/ioncube_loader_lin_5.1.so: undefined symbol: _zend_hash_init
Site error: the file <b>/usr/local/softaculous/enduser/main/functions.php</b> requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator.[root]

while in fact I did do that as the roor user, and even updated the files's rights (chown) so they belong to root. (Oddly they did not when installed by wget and tar).

Any advice on how to finish this ?!

Regards.

Edit: As one of our sites on this machine has been using Ioncube for years, I tried to use the .so we have in place. The 2 Plesk php.ini files were edited to contain

zend_extension = /usr/lib/php/modules/php_ioncube_loader_lin_5.1.so

Files saved, Apache restarted, I still get

"Site error: the file <b>/usr/local/softaculous/enduser/main/functions.php</b> requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator."

whereas ioncube_loader_lin_5.2.so is apparently not the one our server uses, and even though I did install that file too, which is owned by root...

I tried the helper script again, it reads

#php ioncube-loader-helper.php
PHP Warning:  Module 'ionCube Loader' already loaded in Unknown on line 0
The ionCube PHP Loader is disabled because of startup problems.

so I'm a bit at a loss here...

The adventure goes on...For some reason the php.ini files did not contain any reference to the Zend encoder, and still one site using them runs fine. So I just commented out any reference to the extensions and restarted Apache.
The helper script now says

"An ionCube Loader is already installed and run-time loading is unnecessary.
Encoded files should load without problems."

but the installer says

"# /usr/local/psa/admin/bin/php /usr/local/install_softaculous.php
Site error: the file <b>/usr/local/softaculous/enduser/main/functions.php</b> requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator."

Help will be GREATLY appreciated...




Edited by dsaunier : January 16, 2010, 10:30 am
IP: --   

Softaculous for Plesk Linux and ISP System
alons
Group: Administrator
Post Group: Super Member
Posts: 2185
Status:
Hi,

Which version of plesk are you using ?

Regards,
Alons

-----------------------
For immediate support please email us at our Support email address. PMs sent to any Softaculous Team member or posting in the forums is not the official way to get support.

Remote Installer - AEFER
Softaculous Webuzo - It is Softaculous Standalone for Enterprises, SMB, Developers. Deploy it on Dedicated Servers, VPS, Virtual Appliances or the Cloud
Softaculous Virtualizor - The Next Generation VPS Panel
IP: --   

Softaculous for Plesk Linux and ISP System
dsaunier
Group: Member
Post Group: Newbie
Posts: 19
Status:
Hi

That machine runs Plesk 8.3.0. I have one running 8.6 and one under 9.0 bit those are production server so I have to test on the first machine before any other install.
Regards.
IP: --   

Softaculous for Plesk Linux and ISP System
basic
Group: NOC
Post Group: Newbie
Posts: 9
Status:
Just to clarify further:
One server runs Plesk 8.6 (some languages are needed here that Plesk stopped supporting in later releases), the other two servers run the very latest version, Plesk 9.3.0. A few days ago these two still run 9.2.3, and it was not possible to install Softaculous then either.
All three run CentOS.


John
IP: --   

Softaculous for Plesk Linux and ISP System
alons
Group: Administrator
Post Group: Super Member
Posts: 2185
Status:
Hi,

We have made some changes to make it work with Plesk 8.x.x
You will just need to delete the directory /usr/local/softaculous and reinstall using the normal Installation procedure:
http://www.softaculous.com/docs/install_plesk

But delete the directory and file before reinstalling:
/usr/local/softaculous
/usr/local/install_softaculous.php

Regards,
Alons


-----------------------
For immediate support please email us at our Support email address. PMs sent to any Softaculous Team member or posting in the forums is not the official way to get support.

Remote Installer - AEFER
Softaculous Webuzo - It is Softaculous Standalone for Enterprises, SMB, Developers. Deploy it on Dedicated Servers, VPS, Virtual Appliances or the Cloud
Softaculous Virtualizor - The Next Generation VPS Panel
IP: --   

Softaculous for Plesk Linux and ISP System
dsaunier
Group: Member
Post Group: Newbie
Posts: 19
Status:
Hi

deleted and reinstalled for me, but still

"Site error: the file <b>/usr/local/softaculous/enduser/main/functions.php</b> requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator."
IP: --   

Softaculous for Plesk Linux and ISP System
basic
Group: NOC
Post Group: Newbie
Posts: 9
Status:
Same for me. It is not working ... we will also reply in email (Support ticket) in a minute.

Regards,
John
IP: --   

Softaculous for Plesk Linux and ISP System
alons
Group: Administrator
Post Group: Super Member
Posts: 2185
Status:
Quote From : dsaunier January 18, 2010, 3:10 pm
Hi

deleted and reinstalled for me, but still

"Site error: the file <b>/usr/local/softaculous/enduser/main/functions.php</b> requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator."

While installing use this command:
/usr/bin/php /usr/local/install_softaculous.php

The docs have been updated.
But make sure you have ioncube loaded in /usr/bin/php

If you want please email support and they will install for you.

-----------------------
For immediate support please email us at our Support email address. PMs sent to any Softaculous Team member or posting in the forums is not the official way to get support.

Remote Installer - AEFER
Softaculous Webuzo - It is Softaculous Standalone for Enterprises, SMB, Developers. Deploy it on Dedicated Servers, VPS, Virtual Appliances or the Cloud
Softaculous Virtualizor - The Next Generation VPS Panel
IP: --   

Softaculous for Plesk Linux and ISP System
basic
Group: NOC
Post Group: Newbie
Posts: 9
Status:
Just to confirm -- YES, it is now working fine on our Plesk servers!

Thank you very much, Softaculous Support!

John
IP: --   

Softaculous for Plesk Linux and ISP System
alons
Group: Administrator
Post Group: Super Member
Posts: 2185
Status:
Quote From : basic January 18, 2010, 5:25 pm
Just to confirm -- YES, it is now working fine on our Plesk servers!

Thank you very much, Softaculous Support!

John

Welcome sir.

-----------------------
For immediate support please email us at our Support email address. PMs sent to any Softaculous Team member or posting in the forums is not the official way to get support.

Remote Installer - AEFER
Softaculous Webuzo - It is Softaculous Standalone for Enterprises, SMB, Developers. Deploy it on Dedicated Servers, VPS, Virtual Appliances or the Cloud
Softaculous Virtualizor - The Next Generation VPS Panel
IP: --   

Softaculous for Plesk Linux and ISP System
dsaunier
Group: Member
Post Group: Newbie
Posts: 19
Status:
I thought I'd give up Plesk 8.* so I tried on our latest server, running Plesk 9.3. That machine was installed a few weeks ago, nothing custom installed on it.
Here is what I did:

D/L and install your install script. Helper gives

+----------------------------------------------+
| PHP Version      | 5.1.6                    |
| Operating System | Linux                    |
| Threaded PHP    | No                        |
| php.ini file    | /etc/php.ini              |
| Required Loader  | ioncube_loader_lin_5.1.so |
+----------------------------------------------+

but its first lines also say

"An ionCube encoded file has been loaded successfully. Encoded files should now function correctly.
If you have a problem with your PHP application, please contact the application provider."

I then checked the PHP version which indeed says 5.1.6, with

"Zend Extension 220051025"
"with the ionCube PHP Loader v3.3.7"

so Zend ioncube comes with Plesk apparently. Anyway I still followed your instructions and installed the latest loaders in /usr/local/ and updated my 2 php.ini files. Apache restarted.
Trying to install softaculous gives

"[root@myserver local]# /usr/local/psa/admin/bin/php /usr/local/install_softaculous.php
Failed loading /usr/local/ioncube/ioncube_loader_lin_5.1.so:  /usr/local/ioncube/ioncube_loader_lin_5.1.so: undefined symbol: zend_hash_destroy
Site error: the file <b>/usr/local/softaculous/enduser/main/functions.php</b> requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator."

and now the helper script outputs

"# php ioncube-loader-helper.php
PHP Warning:  Module 'ionCube Loader' already loaded in Unknown on line 0
The ionCube PHP Loader is disabled because of startup problems.
Could not open input file: ioncube-loader-helper.php"

so I removed my changes to php.ini files to try to install it without any change  :

"# /usr/local/psa/admin/bin/php /usr/local/install_softaculous.php
Site error: the file <b>/usr/local/softaculous/enduser/main/functions.php</b> requires the ionCube PHP Loader ioncube_loader_lin_5.2."

which does not make sense based on your instructions and what the helper script output.
Back to square one so I'm really lost now. A site requiring ioncube ran on this machine out of the box (even though the php.ini files do not reference a Zen loader).
I hope all this can help understand the issue, I'd like to try your application but most people with Plesk servers would probably have given up by now. FYI I could install a competitor's script in a few seconds even though it also requires ioncube.

Regards.
IP: --   

Softaculous for Plesk Linux and ISP System
dsaunier
Group: Member
Post Group: Newbie
Posts: 19
Status:
Hmm ok; this was the key.

"/usr/bin/php /usr/local/install_softaculous.php" made the miracle happen...

Thank you.

IP: --   

Softaculous for Plesk Linux and ISP System
alons
Group: Administrator
Post Group: Super Member
Posts: 2185
Status:
Quote From : dsaunier January 18, 2010, 6:28 pm
Hmm ok; this was the key.

"/usr/bin/php /usr/local/install_softaculous.php" made the miracle happen...

Thank you.


Hi, I mentioned that in my earlier post itself.

Regards,
Alons

-----------------------
For immediate support please email us at our Support email address. PMs sent to any Softaculous Team member or posting in the forums is not the official way to get support.

Remote Installer - AEFER
Softaculous Webuzo - It is Softaculous Standalone for Enterprises, SMB, Developers. Deploy it on Dedicated Servers, VPS, Virtual Appliances or the Cloud
Softaculous Virtualizor - The Next Generation VPS Panel
IP: --   

Softaculous for Plesk Linux and ISP System
falwood
Group: Member
Post Group: Newbie
Posts: 1
Status:
Believe I did everything right.

still getting a error in the domain interface that says "POSIX MUST BE ENABLED"

IP: --   

Softaculous for Plesk Linux and ISP System
alons
Group: Administrator
Post Group: Super Member
Posts: 2185
Status:
Hi,

Sir, POSIX is required to switch to the necessary user level.
You can do that from the php.ini file.

-----------------------
For immediate support please email us at our Support email address. PMs sent to any Softaculous Team member or posting in the forums is not the official way to get support.

Remote Installer - AEFER
Softaculous Webuzo - It is Softaculous Standalone for Enterprises, SMB, Developers. Deploy it on Dedicated Servers, VPS, Virtual Appliances or the Cloud
Softaculous Virtualizor - The Next Generation VPS Panel
IP: --   

« Previous    Next »

Threaded Mode | Print  

2


Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is October 1, 2014, 10:30 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:1.682