Welcome Guest. Please Login or Register  


You are here: Index > Softaculous Auto Installer > Bugs > Topic : Soft_Install (installapi.php): Javascript library installs do not return "installed"



Threaded Mode | Print  

 Soft_Install (installapi.php): Javascript library installs do not return "installed", After installing a javascript library via Soft_Install API class, full page HTML is returned (4 Replies, Read 2892 times)
drichert
Group: Member
Post Group: Newbie
Posts: 10
Status:
Softaculous v4.0.7

After installing a JS library using the Soft_Instal API class (from installapi.php), the install function does not return "installed"; it returns full HTML for the selected library description page from the normal Softaculous web interface.

Example code:

PHP Code

 $new = new Soft_Install();                                                                                                                                                 
$new->login $url;                                                                                                                                                        
$new->data["softdomain"] = "test-domain.com";                                                                                                                        
$new->data["softdirectory"] = "mochi";                                                                                                                  
$res $new->install(157); // MochiKit  

var_dump($res); //=> string(29786) "<!DOCTYPE html PUBLIC "-//W3C//DTD XH... 

IP: --   

Soft_Install (installapi.php): Javascript library installs do not return "installed"
drichert
Group: Member
Post Group: Newbie
Posts: 10
Status:
Forgot to mention that the library *is* installed, the API function just isn't returning the expected success response.
IP: --   

Soft_Install (installapi.php): Javascript library installs do not return "installed"
drichert
Group: Member
Post Group: Newbie
Posts: 10
Status:
Another thing I forgot to mention: serialized PHP containing errors is not returned on what I assume to be failure. If I don't give a value for "softdomain" or "softdirectory", I still get the full description page HTML in response.
IP: --   

Soft_Install (installapi.php): Javascript library installs do not return "installed"
drichert
Group: Member
Post Group: Newbie
Posts: 10
Status:
I also noticed that the js library will only install if the "act" param is set to "software", but not when it's set to "js". Both cases still return full HTML of the description page.
IP: --   

Soft_Install (installapi.php): Javascript library installs do not return "installed"
Brijesh
Group: Softaculous Team
Post Group: Super Member
Posts: 2191
Status:
Hi,

Sir this issue was resolved in Softaculous 4.1.0

-----------------------
Facebook
Twitter
Vote for us
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is September 16, 2014, 5:06 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 10  |  Page Created In:0.224