Softaculous <![CDATA[99% CPU usage on KVM VPS, extremely slow boot]]>
error: Failed to create domain from /etc/libvirt/qemu/v100*.xml
error: Unable to create cgroup for v100*: No such file or directory
It seems that Arvind helped to solve this by advising this:
libvirtd stopped working so you need to do "service libvirtd restart" then you vpses again start working.

Here your vps was not starting because you have added cpu units 500, Minimum requirement is 1000.
In another words, if "Unable to create cgroup" kind of error appear, one may try:
1. opening VPS configuration (and VPS Plans) in Virtualizor and make sure CPU units are set to "1000" (not less) and CPU % set to "0" (in KVM VPS's, OpenVZ seems not to be affected)
2. command "service libvirtd restart"
Sat, 22 Jul 2017 15:15:59 GMT
<![CDATA[Update TikiWiki often]]>
I have noticed that tikiwiki very rarely gets updated in softaculous, despite the fact that that script is updated -with plenty of changes- every 6 months by the developers.

It seems that you only use the long term support version, which is updated every few years. I understand the advantages of having a long term support tikiwiki; but there are other websites that really need the latest developments of tikiwiki.

The fact is that the only disadvantage is that it is an enormous problem to update it, because it does not have any autoupdate function -like wordpress-, and having softaculous doing it automatically really helps.

So I really wanted to install it with softaculous, but the fact that the latest version in softaculous is 15.4, while the version 17 is already released, deters me from doing it.

Please change this. Thank you.]]>
Sat, 22 Jul 2017 13:53:19 GMT
<![CDATA[Python and WSGI: 50X error]]> General Support.
Please click the link below to visit the topic:]]>
Sat, 22 Jul 2017 13:11:37 GMT
<![CDATA[Python and WSGI: 50X error]]>
I read a couple of posts regarding running python scripts on AMPPS 3.7 (Windows 10). I made some adjustments in httpd.conf but still receive the error message when calling localhost/myapp:

A 50X error occurred
Sorry, the page you are looking for is currently unavailable.
Please try again later.

What I did so far:

1. I adjusted httpd.conf Virtualhost as follows:

<VirtualHost *:80>
<Directory "{$path}/www">
    Options FollowSymLinks Indexes
    AllowOverride All
    Order deny,allow
    allow from All
ServerName localhost
ServerAlias localhost *
ScriptAlias /cgi-bin/ "{$path}/www/cgi-bin"
DocumentRoot "{$path}/www"
ErrorLog "{$path}/apache/logs/error.log"
CustomLog "{$path}/apache/logs/access.log" combined

<Directory "{$path}/www/wsgi-scripts">
    Order allow,deny
    Allow from all

WSGIScriptAlias /myapp "{$path}/www/wsgi-scripts/myapp.wsgi"

2. I created a folder wsgi-scripts \Ampps\www\wsgi-scripts

3. I created a file myapp.wsgi containing

def application(environ, start_response):
    status = '200 OK'
    output = 'Hello World!'

    response_headers = [('Content-type', 'text/plain'),
                        ('Content-Length', str(len(output)))]
    start_response(status, response_headers)

    return [output]
Did I miss any steps?

I really appreciate your support and advise. Let me know if you need further information.

Kind regards
Sat, 22 Jul 2017 12:45:08 GMT
<![CDATA[Problems with Dataflame]]>
Quote From : lupacexi July 21, 2017, 12:10 pm
I use Dataflame in the UK for my hosting. Softaculous, accessed through cPanel, comes as standard.

I've tried today to access Softaculous through three different hosting packages I manage but in all cases I'm just getting a License Inactive message.

Is this likely to obe a Softaculous or Dataflame issue as it's preventing any work getting done on a site redevelop project.

Apologies for the inconvenience caused to you.
I request you to open a support ticket with us with your Softaculous license and public IP of your server, we shall check this for you as soon as possible.

You can open a support ticket with us here :

Let us know.]]>
Sat, 22 Jul 2017 06:14:27 GMT
<![CDATA[Login page does not work]]>
Quote From : wapumts July 21, 2017, 7:15 pm
Message later
The commands with putty:

rm -f /usr/local/webuzo/enduser/apps.php
/usr/local/emps/bin/php /usr/local/webuzo/cron.php
[root@myserver]# service webuzo restart
Stopping php-fpm: php-fpm is stopped
Stopping nginx: nginx is stopped
Starting php-fpm: [21-Jul-2017 21:11:17] ERROR: Unable to write to the PID file.: No space left on device (28)
[21-Jul-2017 21:11:17] ERROR: FPM initialization failed
Starting nginx: Done...
/etc/init.d/webuzo: line 37: echo: write error: No space left on device
[root@myserver ~]# nginx: [crit] pwrite() "/usr/local/emps/var/log/nginx/" failed (28: No space left on device)


As you can see above the disk space on your server is full hence none of the application and Webuzo service are working on your server. All the applications require some disk space and ram to run.

We suggest you contact your VPS provider and either ask them to manage your server and empty the disk space or increase the disk space of your server.

Please let us know if you need any further assistance. We will be happy to help you.
Sat, 22 Jul 2017 05:42:32 GMT
<![CDATA[Virtualizor works with Virtuozzo 7 or OpenVZ 7 ?]]> this), will that work or is that incompatible if you tried? Thx!
Fri, 21 Jul 2017 22:11:36 GMT
<![CDATA[Virtualizor works with Virtuozzo 7 or OpenVZ 7 ?]]>

is mentioned that:

"This guide will help you to install Virtualizor on OpenVZ 7"
"Requirements: Virtuozzo 7 OS (ISO can be downloaded ..."

From this comparison: it seems that there are 2 products. One is OpenVZ 7 and another is Virtuozzo 7.

From your description it appears like you are talking about both products, but then you are linking to an .iso image of OpenVZ 7 if i am not wrong. But the wiki article is entitled "Virtuozzo" which may be confusing.

So Virtualizor supports OpenVZ 7, not Virtuozzo?

Please can i try to install OpenVZ 7 not via .iso, but classic way:

yum localinstall
(that should import all meta information and YUM repositories)
yum install prlctl prl-disp-service vzkernel
(should install kernel and other packages)
This process is advised here


You also say in your above mentioned wiki article this: ""KVM module requires VT enabled". Does it mean i can enable multi virt. on that OpenVZ 7 installation to have VZ+KVM? Thank you
Fri, 21 Jul 2017 21:52:09 GMT
<![CDATA[Login page does not work]]> 4,0K    /var/crash
8,0K    /var/db
8,0K    /var/empty
4,0K    /var/games
73M    /var/lib
2,4G    /var/local
8,0K    /var/lock
2,0G    /var/log
0      /var/mail
1,4M    /var/named
4,0K    /var/nis
4,0K    /var/opt
4,0K    /var/preserve
0      /var/puppet
108K    /var/run
75M    /var/softaculous
2,4G    /var/spool
4,0K    /var/tmp
131M    /var/webuzo
4,0K    /var/yp
Fri, 21 Jul 2017 20:09:05 GMT
<![CDATA[Login page does not work]]> 6,1M    /bin
52M    /boot
4,0K    /cgroup
156K    /dev
29M    /etc
347M    /home
292M    /lib
19M    /lib64
16K    /lost+found
4,0K    /media
4,0K    /mnt
4,0K    /opt
du: impossibile accedere a `/proc/16783/task/16783/fd/4': No such file or directory
du: impossibile accedere a `/proc/16783/task/16783/fdinfo/4': No such file or directory
du: impossibile accedere a `/proc/16783/fd/4': No such file or directory
du: impossibile accedere a `/proc/16783/fdinfo/4': No such file or directory
0      /proc
896K    /root
8,0K    /run
12M    /sbin
4,0K    /selinux
4,0K    /srv
0      /sys
176K    /tmp
2,0G    /usr
7,0G    /var
Fri, 21 Jul 2017 20:06:13 GMT