Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > General Support > Topic : Apache won't start



Threaded Mode | Print  

 Apache won't start, Apache won't start for some reason. (10 Replies, Read 36727 times)
supanut2000
Group: Member
Post Group: Newbie
Posts: 1
Status:
It use to work fine, until it stops working. MySQL starts fine, but Apache won't start. Here's a CMD log when I run httpd.exe via Command Prompt.

C:\Program Files\Ampps\apache\bin>httpd
(OS 10013)An attempt was made to access a socket in a way forbidden by its acces
s permissions.  : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

C:\Program Files\Ampps\apache\bin>
Any idea on how to fix this?
IP: --   

Apache won't start
tidus
Group: AMPPS Team
Post Group: Super Member
Posts: 1118
Status:
Quote From : supanut2000 October 28, 2011, 3:06 am
It use to work fine, until it stops working. MySQL starts fine, but Apache won't start. Here's a CMD log when I run httpd.exe via Command Prompt.

C:\Program Files\Ampps\apache\bin>httpd
(OS 10013)An attempt was made to access a socket in a way forbidden by its acces
s permissions.  : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

C:\Program Files\Ampps\apache\bin>
Any idea on how to fix this?
Hi,

We have replied to your ticket.


-----------------------
Follow AMPPS on,
Twitter : https://twitter.com/AMPPS_Stack
Facebook :  http://www.facebook.com/softaculousampps
Google+ : https://plus.google.com/+AmppsStack
IP: --   

Apache won't start
tidus
Group: AMPPS Team
Post Group: Super Member
Posts: 1118
Status:
Hi,

Please let us know if you need any further information.

And for the people who face similar problem in future, the solution is disabling IIS as IIS uses port 80.


Edited by tidus : December 16, 2011, 4:57 am

-----------------------
Follow AMPPS on,
Twitter : https://twitter.com/AMPPS_Stack
Facebook :  http://www.facebook.com/softaculousampps
Google+ : https://plus.google.com/+AmppsStack
IP: --   

Apache won't start
frayler
Group: Member
Post Group: Newbie
Posts: 2
Status:
I have the same error below:
C:\Program Files\Ampps\apache\bin>httpd

(OS 10013)An attempt was made to access a socket in a way forbidden by its acces

s permissions.  : make_sock: could not bind to address 0.0.0.0:80

no listening sockets available, shutting down

Unable to open logs


I disabled all IIS services to no avail. Is there anything else I need to do or a complete removal of IIS 7 is require?
IP: --   

Apache won't start
tidus
Group: AMPPS Team
Post Group: Super Member
Posts: 1118
Status:
Quote From : frayler December 14, 2011, 9:31 pm
I have the same error below:
C:\Program Files\Ampps\apache\bin>httpd

(OS 10013)An attempt was made to access a socket in a way forbidden by its acces

s permissions.  : make_sock: could not bind to address 0.0.0.0:80

no listening sockets available, shutting down

Unable to open logs


I disabled all IIS services to no avail. Is there anything else I need to do or a complete removal of IIS 7 is require?
Hi you will have to uninstall IIS.

If you don't know who is listening port 80, type following command in command prompt

Code
C:\Users\Admin>netstat -aon | findstr 0.0:80
  TCP    0.0.0.0:80            0.0.0.0:0              LISTENING      1964
Last column displays the PID of the process.

Open Task Manager -> Process Tab -> View(Menu Bar) -> Select Column -> Check PID -> Ok

Search for PID listed from the command, you should get the corresponding process name listening port 80.



-----------------------
Follow AMPPS on,
Twitter : https://twitter.com/AMPPS_Stack
Facebook :  http://www.facebook.com/softaculousampps
Google+ : https://plus.google.com/+AmppsStack
IP: --   

Apache won't start
frayler
Group: Member
Post Group: Newbie
Posts: 2
Status:
Did a complete uninstall of IIS and continue to get the same error. PID 4 (System) is listed as listening on port 80, description is NT Kernel & System.
IP: --   

Apache won't start
tidus
Group: AMPPS Team
Post Group: Super Member
Posts: 1118
Status:
Quote From : frayler December 15, 2011, 6:49 pm
Did a complete uninstall of IIS and continue to get the same error. PID 4 (System) is listed as listening on port 80, description is NT Kernel & System.
try disabling Webclient and Web Deployment Agent Service from Services.


-----------------------
Follow AMPPS on,
Twitter : https://twitter.com/AMPPS_Stack
Facebook :  http://www.facebook.com/softaculousampps
Google+ : https://plus.google.com/+AmppsStack
IP: --   

Apache won't start
EcomEvo
Group: Member
Post Group: Newbie
Posts: 5
Status:
Hi!

I'm having this same problem.  IIS isn't installed and Web Client is disabled.  When I check the for which process is using port 80 it shows PID 3092, which is not is the process list even with processes from all users checked.

Any ideas?
IP: --   

Apache won't start
EcomEvo
Group: Member
Post Group: Newbie
Posts: 5
Status:
Nevermind.  Figured this out.

Apparently the default for Skype is to use port 80.  I unchecked that option in advanced settings and restarted Skype. Now Apache works.

Hope this helps someone else! :)
IP: --   

Apache won't start
EcomEvo
Group: Member
Post Group: Newbie
Posts: 5
Status:
OK, so I DID have this figured out, then I installed Windows 8. Now I'm having the same problem and this time Skype is not to blame. Can't find any installation of IIS or the Web Deployment Agent Service. Webclient is disabled.

Any other ideas as to what could be taking over port 80? :(
IP: --   

Apache won't start
EcomEvo
Group: Member
Post Group: Newbie
Posts: 5
Status:
Correction: IIS was installed!

It was being run under the name "World Wide Web Publishing Service" in Windows 8. Disabled that and AMPPS starts right up.
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is September 18, 2014, 5:45 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.469