Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > General Support > Topic : Blank pages after installing Ampps on Snow Leopard



Threaded Mode | Print  

 Blank pages after installing Ampps on Snow Leopard (3 Replies, Read 6373 times)
pcordova
Group: Member
Post Group: Newbie
Posts: 1
Status:
Hi,

After installing Ampps on Snow Leopard I just got blank pages.

The file install.php was present, so I ran the following command:

/Applications/AMPPS/php/bin/php -c /Applications/AMPPS/php/etc/php.ini /Applications/AMPPS/ampps/softaculous/enduser/install.php

Then, I get the following error message:

"Site error: the file <b>/Applications/AMPPS/ampps/softaculous/enduser/install.php</b> requires the ionCube PHP Loader ioncube_loader_dar_5.3.so to be installed by the site administrator."

Solution: in php-5.3.ini, in the ";ionCube Loader" section, you can see:

zend_extension = /Applications/AMPPS/php-5.3/lib/extensions/ioncube_loader_dar_5.3.so (without quotation marks)

just edit to the following (and save):

zend_extension = "/Applications/AMPPS/php-5.3/lib/extensions/ioncube_loader_dar_5.3.so" (with quotation marks)

again, run the following command:

/Applications/AMPPS/php/bin/php -c /Applications/AMPPS/php/etc/php.ini /Applications/AMPPS/ampps/softaculous/enduser/install.php

then restart apache and you should be done (it worked for me).
IP: --   

Blank pages after installing Ampps on Snow Leopard
tidus
Group: AMPPS Team
Post Group: Super Member
Posts: 1070
Status:
Hi,

We are still using the same line without quotes and it works,

Code
zend_extension = /Applications/AMPPS/php-5.3/lib/extensions/ioncube_loader_dar_5.3.so
You got an error first time because php.ini wasn't loaded i.e php.ini was not present in /Applications/AMPPS/php/etc/ folder.

-----------------------
Follow AMPPS on,
Twitter : https://twitter.com/AMPPS_Stack
Facebook :  http://www.facebook.com/softaculousampps
Google+ : https://plus.google.com/u/0/b/111580687033722614505/
IP: --   

Blank pages after installing Ampps ...
--marc
Group: Member
Post Group: Newbie
Posts: 7
Status:
Quote
We are still using the same line without quotes and it works,
... one would suspect the quote are not needed; however, when i had the same situation of blank screen and the recommended Terminal command failed with ...

Quote
Site error: the file <b>/Applications/AMPPS/ampps/softaculous/enduser/install.php</b> requires the ionCube PHP Loader ioncube_loader_dar_5.3.so to be installed
... i found that adding quotes to the php-5.3.ini line (as pcordova posted) resolved the issue.  :)
Code
zend_extension = "/Applications/AMPPS/php-5.3/lib/extensions/ioncube_loader_dar_5.3.so" (with quotation marks)
After adding the quotes, the Terminal command work with just a few warnings.
Code
$> /Applications/AMPPS/php/bin/php -c /Applications/AMPPS/php/etc/php.ini /Applications/AMPPS/ampps/softaculous/enduser/install.php
PHP Warning:  filemtime(): stat failed for /Applications/AMPPS/ampps/data/vichitra in /Applications/AMPPS/ampps/softaculous/enduser/softpanel.php on line 185
After added quote and running the Terminal command (even with the line 185 warning), the resulting http://localhost/ampps/ and http://localhost/ampps-admin/ were served OK after the terminal command.

My case was a initial install of AMPPS 1.9 on OS X 10.7.5. No changes had been made to the default configuration until the amps pages were blank.

Does the line 185 warning indicate that any addition actions will be needed?
IP: --   

Blank pages after installing Ampps on Snow Leopard
tidus
Group: AMPPS Team
Post Group: Super Member
Posts: 1070
Status:
Quote From : --marc October 11, 2012, 7:09 am
Quote
We are still using the same line without quotes and it works,
... one would suspect the quote are not needed; however, when i had the same situation of blank screen and the recommended Terminal command failed with ...

Quote
Site error: the file <b>/Applications/AMPPS/ampps/softaculous/enduser/install.php</b> requires the ionCube PHP Loader ioncube_loader_dar_5.3.so to be installed
... i found that adding quotes to the php-5.3.ini line (as pcordova posted) resolved the issue.  :)
Code
zend_extension = "/Applications/AMPPS/php-5.3/lib/extensions/ioncube_loader_dar_5.3.so" (with quotation marks)
After adding the quotes, the Terminal command work with just a few warnings.
Code
$> /Applications/AMPPS/php/bin/php -c /Applications/AMPPS/php/etc/php.ini /Applications/AMPPS/ampps/softaculous/enduser/install.php
PHP Warning:  filemtime(): stat failed for /Applications/AMPPS/ampps/data/vichitra in /Applications/AMPPS/ampps/softaculous/enduser/softpanel.php on line 185
After added quote and running the Terminal command (even with the line 185 warning), the resulting http://localhost/ampps/ and http://localhost/ampps-admin/ were served OK after the terminal command.
Hi,

Okay. We will test it on our test servers again and add the quotes in next version.

Quote

My case was a initial install of AMPPS 1.9 on OS X 10.7.5. No changes had been made to the default configuration until the amps pages were blank.

Does the line 185 warning indicate that any addition actions will be needed?
No. AMPPS should work fine. :)

Edited by tidus : October 11, 2012, 7:14 am

-----------------------
Follow AMPPS on,
Twitter : https://twitter.com/AMPPS_Stack
Facebook :  http://www.facebook.com/softaculousampps
Google+ : https://plus.google.com/u/0/b/111580687033722614505/
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is August 1, 2014, 12:04 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.205