Softaculous <![CDATA[Joomla 3.3x]]> Fri, 22 Aug 2014 01:07:06 GMT <![CDATA[Apache segmentation error]]> Fri, 22 Aug 2014 01:05:44 GMT <![CDATA[AMPPS used as a webserver hosted locally]]>
I would like to have a server for family and friends to start with, might possibly open it publicly later.  I know Softaculous sets everything up for local access, for local production use.  And I read or saw a youtube video about it where the author said it wouldn't be secure for exposure to the Internet.

So, I was just wondering how hard it would be to secure it for access from the Internet? Fairly easy to do? Or better to go about it some other way?  Thanks
Fri, 22 Aug 2014 01:05:17 GMT
<![CDATA[Scripts execute slowly in AMPPS, is that normal?]]>
I would think that these scripts like Word Press and WikiMedia would run very fast locally since they run fast most of the time on the Internet.
Fri, 22 Aug 2014 00:56:02 GMT
<![CDATA[Leverage browser caching]]> .htacess file.

This is an example of a configuration in one of my sites:

<IfModule mod_expires.c>
    ExpiresActive On 
    ExpiresByType text/html "access plus 1 seconds"
    ExpiresByType image/x-icon "access plus 2592000 seconds"
    ExpiresByType image/gif "access plus 2592000 seconds"
    ExpiresByType image/jpeg "access plus 2592000 seconds"
    ExpiresByType image/png "access plus 2592000 seconds"
    ExpiresByType application/font-woff "access plus 2592000 seconds"
    ExpiresByType application/ "access plus 2592000 seconds"
    ExpiresByType application/x-shockwave-flash "access plus 2592000 seconds"   
    ExpiresByType text/css "access plus 604800 seconds"
    ExpiresByType text/javascript "access plus 604800 seconds"
    ExpiresByType application/javascript "access plus 604800 seconds" 
    ExpiresByType application/x-javascript "access plus 604800 seconds" 
    ExpiresByType text/x-js "access plus 604800 seconds"
I hope it helps]]>
Thu, 21 Aug 2014 21:19:52 GMT
<![CDATA[Backup suggestions?]]> Thu, 21 Aug 2014 21:17:26 GMT <![CDATA[How to delete error logs]]>
Here it is the command I used to clean the log without closing the handle to apache.

echo > /usr/local/apps/apache/logfilename

maybe could help someone ]]>
Thu, 21 Aug 2014 21:16:17 GMT
<![CDATA[database name]]> I tried to make an exact copy of my WP install on my local machine.
I want to have everything named the same as possible, in order to make transferring the site from local to live server and back as easy as possible.
When doing a wordPress install from the "home" i tried naming my DB like so: mydatabas_db
This is not possible, since "only alphanumeric characters are allowed"
It would be very convenient (at least for me) when common characters like - and _ would be allowed.

Could this be done?

Thu, 21 Aug 2014 19:16:31 GMT
<![CDATA[Need help resolving this error]]>
This error occurs after a customer has completed the checkout process and submitted payment via credit card (paypal payments pro gateway). If i make the product free in WHMCS, the error does not occur.

Even with the error, the VPS is created successfully and my customer receives his login details.

Warning: Missing argument 3 for ModuleCallFunction(), called in /home/buckeyev/public_html/includes/modulefunctions.php on line 0 and defined in /home/buckeyev/public_html/includes/modulefunctions.php on line 0

Warning: Cannot modify header information - headers already sent by (output started at /home/buckeyev/public_html/includes/modulefunctions.php:0) in /home/buckeyev/public_html/includes/classes/WHMCS/Application.php on line 0]]>
Thu, 21 Aug 2014 18:32:20 GMT
<![CDATA[error: Timed out during operation: cannot acquire state change lock]]>
2014-08-21 17:21:50.001+0000: 23735: error :
qemuDomainObjBeginJobInternal:845 : Timed out during operation: cannot
acquire state chang

2014-08-21 17:26:17.949+0000: 25568: info : libvirt version: 0.10.2,
package: 29.el6_5.11 (CentOS BuildSystem ,07-31-18:52:08,

2014-08-21 17:43:18.000+0000: 27554: error : qemuDomainObjBeginJobInternal:845 : Timed out during operation: cannot acquire state change lock
2014-08-21 17:44:17.000+0000: 27553: warning : qemuDomainObjBeginJobInternal:840 : Cannot start job (modify, none) for domain 1009; current job is (modify, none) owned by (27612, 0)

Thu, 21 Aug 2014 18:03:12 GMT