Welcome Guest. Please Login or Register  


You are here: Index > Webuzo > Bugs > Topic : Wiki installs failing



Threaded Mode | Print  

 Wiki installs failing, Wiki installations claim they succeed but do not (7 Replies, Read 2589 times)
dartagnan
Group: Member
Post Group: Newbie
Posts: 17
Status:
I installed PmWiki. Got an installation-successful message. Went to the page. Nothing there. Went to the Admin log in. Nothing there. Waited three hours. Tried the page again. Still nothing there so I deleted the installation. Did a re-install. Same thing. Deleted the installation.

Tried DokuWiki. Same thing. Deleted DokuWiki. Tried MediaWiki. Same thing. Deleted MediaWiki.

Installed PmWiki using default directory. Same thing. Deleted installation.

As far as I can see, wiki installation is a big FAIL! I did not try WikkaWiki as I didn't like the look of the pages.

Bug??

IP: --   

Wiki installs failing
dartagnan
Group: Member
Post Group: Newbie
Posts: 17
Status:
Once again, multiple views, no help.

I tried to install PmWiki again this morning. I attach the "successful" install message. I also attach the page I see when I go to the link.

What is going on? The same thing has happened with every wiki I have tried to install through Webuzo.
IP: --   

Wiki installs failing
dartagnan
Group: Member
Post Group: Newbie
Posts: 17
Status:
I am starting over again with re-installing the OS. If I have problems this time, I am done with this crap.
IP: --   

Wiki installs failing
dartagnan
Group: Member
Post Group: Newbie
Posts: 17
Status:
I figured out the problem. Thanks for all the no-help, tech support.  :-(

Either the OS comes with Apache installed by default; or when Webuzo is installed, it installs Apache. I think the latter because if you install Webuzo on a clean system and then inspect 'All Installs,' Apache is one of the couple dozen listed.

Here is the problem. On Linux Apache serves content out of /var/www/html. When the @*#$776% Webuzo installs a program, it puts it in /home/username(yours)/public_html/app-name. For example, it installs PmWiki in /home/username/public_html/pmwiki.

You can't get to it. Apache won't serve it because it is looking in /var/www/html. You can't type the path in the URL line because, I'm thinking, an outside user (hello, Chrome, et al) is forbidden to access those directories.

If anyone knows a fix for this, please inform me. Otherwise, I AM DEFINITELY REPORTING THIS AS A BUG!
IP: --   

Wiki installs failing
dartagnan
Group: Member
Post Group: Newbie
Posts: 17
Status:
Once again, having to struggle to find the solution on my own.

For anyone experiencing what I was, Fix:Internal server error - Webuzohere is what I found to fix my issue.

In case the page opens to a different place later, the article to review is "Fix: Internal Server Error - Webuzo". To be plain, because I had to think about it a minute.
Quote
Step 1. Install Webuzo
Step 2. Remove apache on the local instance - in my case this was Centos 7
Step 3. Go to Webuzo panel -> All Installations
Step 4. Remove Apache
Step 5. Go to Installs (or Return to Overview)
Step 6. Install Apache from Webuzo
Step 7. May or may not need to do - restart the Apache service via 'service httpd restart'
tart

This fixed it for me. If you are having my problem, I hope this fixes it for you!

IP: --   

Wiki installs failing
nikhil.m
Group: Webuzo Team
Post Group: Working Member
Posts: 141
Status:
Hi dartagnan,

On the installation guide for Webuzo it's clearly mentioned that Webuzo needs to be installed on clean server and not with a pre installed LAMP stack.

The best way to avoid the internal server error, is to upload file via FTP using the default FTP account or SSH as Webuzo user, so in this way all the files created will have the correct permission.

Edited by nikhil.m : February 21, 2017, 6:25 am
IP: --   

Wiki installs failing
dartagnan
Group: Member
Post Group: Newbie
Posts: 17
Status:
Hi nikhil.m,

Thank you for your reply. I am going to say that the source of my problem and all my irritation is that I was going by a knowledge base article on the site that provides my ISP (VPS) service. Unfortunately, none of the information I have learned was imparted there.

The article made it sound as though you download the install script, run it, set up Webuzo and Bob's your uncle. I now know this is nowhere close to right.

I opened a ticket with their tech support and was told, successively, "it's your fault" and "you need to covert to managed VPS so we can help you with questions like this." That would be a minimum of triple what I am paying; I can't afford that. OR they could update their knowledge base article.

This has been extremely frustrating to say the least.
IP: --   

Wiki installs failing
nikhil.m
Group: Webuzo Team
Post Group: Working Member
Posts: 141
Status:
Quote
The article made it sound as though you download the install script, run it, set up Webuzo and Bob's your uncle. I now know this is nowhere close to right.
  :D

If you need any help regarding Webuzo, you can refer to the official documentation.

If you are not well versed with Linux environment, then considering a managed plan will be a smart option at least for a short period of time till you get well versed in Linux.
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is June 26, 2017, 8:44 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.771