Softaculous <![CDATA[[ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.user' doesn't exist]]>
I just recently installed Ampps onto my OSX machine. It worked perfectly the first time I set it up. My local site was great and no problems were found. However, when i stopped the servers and closed the program, and then later tried to reopen it; mySQL does not start. At all. It doesnt do anything. Amongst the error log, there was this:

[ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.user' doesn't exist

I have no idea what to do. I have spent the last 4 hours looking online, and browsing this very forum and have found people with similar situations but nothing seems to be working on my end.

I am entirely new to this, so if you do have a suggestion, could you please try and explain it step by step?

Huge thank you to anyone who helps!!!



2015-07-31 15:57:53 20941 [Warning] You need to use --log-bin to make --binlog-format work.
2015-07-31 15:57:53 20941 [Note] Plugin 'FEDERATED' is disabled.
/Applications/AMPPS/mysql/bin/mysqld: Table 'mysql.plugin' doesn't exist
2015-07-31 15:57:53 20941 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
2015-07-31 15:57:53 20941 [Note] InnoDB: Using atomics to ref count buffer pool pages
2015-07-31 15:57:53 20941 [Note] InnoDB: The InnoDB memory heap is disabled
2015-07-31 15:57:53 20941 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2015-07-31 15:57:53 20941 [Note] InnoDB: Memory barrier is not used
2015-07-31 15:57:53 20941 [Note] InnoDB: Compressed tables use zlib 1.2.3
2015-07-31 15:57:53 20941 [Note] InnoDB: Not using CPU crc32 instructions
2015-07-31 15:57:53 20941 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2015-07-31 15:57:53 20941 [Note] InnoDB: Completed initialization of buffer pool
2015-07-31 15:57:53 20941 [Note] InnoDB: Highest supported file format is Barracuda.
2015-07-31 15:57:53 20941 [Note] InnoDB: 128 rollback segment(s) are active.
2015-07-31 15:57:53 20941 [Note] InnoDB: Waiting for purge to start
2015-07-31 15:57:53 20941 [Note] InnoDB: 5.6.24 started; log sequence number 49180233
2015-07-31 15:57:53 20941 [Note] Server hostname (bind-address): '*'; port: 3306
2015-07-31 15:57:53 20941 [Note] IPv6 is available.
2015-07-31 15:57:53 20941 [Note]  - '::' resolves to '::';
2015-07-31 15:57:53 20941 [Note] Server socket created on IP: '::'.
2015-07-31 15:57:53 20941 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.user' doesn't exist]]>
Fri, 31 Jul 2015 14:04:33 GMT
<![CDATA[Oxwall 1.7.5]]>
We are extremely sorry for the delay in reply.
We have halted the upgrade of Oxwall from 1.7.4 to 1.7.5. There is some issue we are facing in upgrade and we are in touch with the Oxwall team for the same.
Once we have the issue resolved, we shall make it available at Softaculous.
We appreciate your patience.]]>
Fri, 31 Jul 2015 12:09:34 GMT
<![CDATA[Error Apache not Running]]>
We will have to check this issue on your server. Can you please open a support ticket here:

So that we can debug this issue further.]]>
Fri, 31 Jul 2015 11:54:40 GMT
<![CDATA[Magento Won't Install]]>
Could not make the query numbered : 17
MySQL Error No : 1059
MySQL Error : Identifier name 'UNQ_60450534796045053479API2_ACL_RULE_ROLE_ID_RESOURCE_ID_PRIVILEGE' is too long

Any idea how to fix this or get Magento to install?

I got the same error with the 1.9 and 1.7 versions]]>
Fri, 31 Jul 2015 07:34:54 GMT
<![CDATA[Error Apache not Running]]> why my webuzo can't running the apache system ?
Notify :
There was an error while performing the operation"
please help me

Thu, 30 Jul 2015 16:57:07 GMT
<![CDATA[Webuzo enduser login URL changing]]>

My ISP blocked 2002 port and Can't access webuzo end user panel.
Thu, 30 Jul 2015 15:09:10 GMT
<![CDATA[Upgrade custom script]]>
I have one question.

I want to make updates to a custom script. I need to change the name of the installation package depending on the version of the script.

For version 1.0.1 - package is to be called
For version 1.0.2 - package is to be called

Some functions I use to script does not use the standard application name? Excuse me immediately for my English.]]>
Thu, 30 Jul 2015 14:11:18 GMT
<![CDATA[Is there russian translation?]]> Thu, 30 Jul 2015 05:16:41 GMT <![CDATA[Autostart/service for MongoDB]]>]]>
Wed, 29 Jul 2015 17:00:17 GMT
<![CDATA[Problems to connect to MySQL via Perl]]>
we have a problem to connect from a cgi file to a MySQL database.

(With AMPPS 3.2 on a MAC OS X 10.10.4 Yosemite)

Our small test script is the following:

#!/Applications/AMPPS/perl/bin/perl -w

use strict;
use DBI;
use CGI::Carp qw(fatalsToBrowser);
use Digest::MD5 qw(md5_hex);
use CGI;

my $query=new CGI ;

my $dbh=DBNEW();
$dbh->disconnect ();

sub DBNEW 
    my $dsn = "DBI:mysql:database-name:database-host";
    my $dbh="";

    # Connect
    unless ( $dbh = DBI -> connect ("$dsn", "db-user", "dbpass" , {RaiseError=>1,PrintError=>0} ) ) {
        die "no connect: $DBI::errstr";   
    return ( $dbh );

And when we start this script in a browser, we get the following error notice:

Software error:

install_driver(mysql) failed: Can't load '/Applications/AMPPS/perl/lib/site_perl/5.20.2/darwin-2level/auto/DBD/mysql/mysql.bundle' for module DBD::mysql: dlopen(/Applications/AMPPS/perl/lib/site_perl/5.20.2/darwin-2level/auto/DBD/mysql/mysql.bundle, 1): Library not loaded: libmysqlclient.18.dylib
  Referenced from: /Applications/AMPPS/perl/lib/site_perl/5.20.2/darwin-2level/auto/DBD/mysql/mysql.bundle
  Reason: image not found at /Applications/AMPPS/perl/lib/5.20.2/darwin-2level/ line 197.
at (eval 7) line 3.
Compilation failed in require at (eval 7) line 3.
Perhaps a required shared library or dll isn't installed where expected
at /Applications/AMPPS/www/cgi-bin/test.cgi line 35.

Can you maybe see, what we are doing wrong? How can we solve the problem?

Thank you!


Wed, 29 Jul 2015 13:02:52 GMT