Welcome Guest. Please Login or Register  


You are here: Index > Softaculous Inc. > News and Announcements > Topic : WHMCS Auto Install Module

8


Threaded Mode | Print  

WHMCS Auto Install Module
Brijesh
Group: Softaculous Team
Post Group: Super Member
Posts: 3355
Status:
Hi Chris,

We have updated the encoded file to work with PHP 7.

Download the following Auto Installation Hook if you are using WHMCS on PHP 5.3.x to PHP 5.6.x :
http://files.softaculous.com/autoinstall.zip

Download the following Auto Installation Hook if you are using WHMCS on PHP 7.x :
http://files.softaculous.com/autoinstall56.zip

Download the following  Auto Installation Hook if you are using WHMCS on PHP 5.2.x :
http://files.softaculous.com/autoinstall52.zip

-----------------------
SiteMush Website Builder
Follow us on Twitter
IP: --   

WHMCS Auto Install Module
AtelierHosting
Group: Member
Post Group: Newbie
Posts: 3
Status:
Having major issues with this.

Have tried different versions of php too and still get the same results.

The complete backend of WHMCS breaks with a 500 error each time I add the softaculous file.

Any reason for this? Removing the file and everything works.

Cheers
IP: --   

WHMCS Auto Install Module
Brijesh
Group: Softaculous Team
Post Group: Super Member
Posts: 3355
Status:
Hi,

Sorry for the inconvenience caused.

Can you please open a support ticket with us with the WHMCS admin account details and the FTP details to WHMCS installation ?
https://www.softaculous.com/support/

We will check it asap.

-----------------------
SiteMush Website Builder
Follow us on Twitter
IP: --   

WHMCS Auto Install Module
Brijesh
Group: Softaculous Team
Post Group: Super Member
Posts: 3355
Status:
Quote From : AtelierHosting October 13, 2016, 10:41 am
Having major issues with this.

Have tried different versions of php too and still get the same results.

The complete backend of WHMCS breaks with a 500 error each time I add the softaculous file.

Any reason for this? Removing the file and everything works.

Cheers
Hi,

The file in downloads section of WHMCS auto install module for PHP 7 was incorrect causing the issue with WHMCS on PHP 7

I have re-uploaded the file. You can download the file (if you are using PHP 7.x) here :
http://files.softaculous.com/autoinstall56.zip

Sorry for the inconvenience caused.

Let us know if you still face the issue.

-----------------------
SiteMush Website Builder
Follow us on Twitter
IP: --   

WHMCS Auto Install Module
AtelierHosting
Group: Member
Post Group: Newbie
Posts: 3
Status:
Hi Brijesh,

That new file worked great. I have it setup to automatically assign the password so haven't specified the Admin Password as a custom field.

Have tested it and there is one issue I can find. It doesn't send the client the password if the password custom field is left for the script to run. If it does create the password, is there a way of sending the password to the account that's created, when WHMCS sends email?

Thanks
IP: --   

WHMCS Auto Install Module
Brijesh
Group: Softaculous Team
Post Group: Super Member
Posts: 3355
Status:
Hi,

The installation details are sent via email by Softaculous. This installation details will include the password as masked i.e. "****"

If you would like to receive the password in plain text you will need to enable the following setting in Softaculous Admin panel -> Settings "Email password in plain text" and save the settings.

If you are unable to find the email please check your SPAM folder.

Let us know if you face any issues.

-----------------------
SiteMush Website Builder
Follow us on Twitter
IP: --   

WHMCS Auto Install Module
AndreasP
Group: Member
Post Group: Newbie
Posts: 16
Status:
Hey

I am trying to get all the upgrades enabled during setup as well but I can not get it to work

I have this added right now

$GLOBALS['softaculous_conf']['disable_notify_update'] = 1; //Disable Update Notifications
$GLOBALS['softaculous_conf']['eu_auto_upgrade'] = 1; //Auto Upgrade
$GLOBALS['softaculous_conf']['auto_upgrade_plugins'] = 1; //Auto Upgrade WordPress Plugins
$GLOBALS['softaculous_conf']['auto_upgrade_themes'] = 1; //Auto Upgrade WordPress Themes

Am i missing something
IP: --   

WHMCS Auto Install Module
Brijesh
Group: Softaculous Team
Post Group: Super Member
Posts: 3355
Status:
Hi,

The key ['defaults'] was missing in your code. Please use the below in your softaculous_extra.php and it should work.

Code
$GLOBALS['softaculous_conf']['defaults']['disable_notify_update'] = 1; //Disable Update Notifications
$GLOBALS['softaculous_conf']['defaults']['eu_auto_upgrade'] = 1; //Auto Upgrade
$GLOBALS['softaculous_conf']['defaults']['auto_upgrade_plugins'] = 1; //Auto Upgrade WordPress Plugins
$GLOBALS['softaculous_conf']['defaults']['auto_upgrade_themes'] = 1; //Auto Upgrade WordPress Themes
Let us know if you still face the issue.


-----------------------
SiteMush Website Builder
Follow us on Twitter
IP: --   

WHMCS Auto Install Module
AndreasP
Group: Member
Post Group: Newbie
Posts: 16
Status:
That worked.  Thank you very much.

One last thing, sorry, on page 7 of this thread, you posted the following to disable the emails that get sent out when a script is insrtalled

$GLOBALS['softaculous_conf']['defaults']['noemail'] = '1';

But I am still getting the email sent
IP: --   

WHMCS Auto Install Module
Brijesh
Group: Softaculous Team
Post Group: Super Member
Posts: 3355
Status:
Hi,

The above line should disable emails for installation.

Can you please check if the email you received was for the account that was created or for any previous action ?

-----------------------
SiteMush Website Builder
Follow us on Twitter
IP: --   

WHMCS Auto Install Module
AtelierHosting
Group: Member
Post Group: Newbie
Posts: 3
Status:
Hi,

The password strength conflicts with my setup and get errors after the account is setup saying the strength didn't match my 75% limit.

Can this be changed so new accounts created will assign a password of at least a 75% strength? Where can I edit this?

Thanks
IP: --   

WHMCS Auto Install Module
Brijesh
Group: Softaculous Team
Post Group: Super Member
Posts: 3355
Status:
Hi,

Sorry for the delay.

You can enable using special characters in random generated passwords replacing the following line :
PHP Code

 $GLOBALS['softaculous_conf']['use_special_chars'] = 0

with
PHP Code

 $GLOBALS['softaculous_conf']['use_special_chars'] = 1

We have also made changes in our WHMCS module to allow configuring custom length for random admin password generated.

Please download the latest WHMCS module here :
http://www.softaculous.com/docs/WHMCS_Auto_Install_Module#Download_and_Upload

Upload the softaculous.php to your server and add the following line to your softaculous_extra.php to set custom length for random password :
PHP Code

 $GLOBALS['softaculous_conf']['rand_pass_length'] = 15// This will generated random password of 15 characters 



-----------------------
SiteMush Website Builder
Follow us on Twitter
IP: --   

« Previous    Next »

Threaded Mode | Print  

8


Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is February 28, 2017, 1:38 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:4.348