Welcome Guest. Please Login or Register  


You are here: Index > Softaculous Inc. > News and Announcements > Topic : AMPPS 2.2



Threaded Mode | Print  

 AMPPS 2.2 (8 Replies, Read 10120 times)
tidus
Group: AMPPS Team
Post Group: Super Member
Posts: 1064
Status:
Hi,

The Softaculous AMPPS Team has released AMPPS 2.2 and Softaculous AMPPS v2.5. This version of AMPPS adds the latest versions of PHP, MySQL, phpMyAdmin, etc. We have also added new features and fixed some bugs in AMPPS.

AMPPS is a WAMP (Windows) and MAMP (Macintosh) stack of Apache, MySQL, MongoDB, PHP, Perl & Python. AMPPS enables you to focus more on using applications rather than maintaining them on your desktops.

NOTE FOR WINDOWS USER: You will have to install Visual C++ Redistributable for Visual Studio 2012 for PHP 5.5

A complete list of changes:

1) The current version of AMPPS for Windows include:
Softaculous AMPPS 2.5(Softaculous 4.3.3)

Apache 2.4.6
PHP 5.5.6, PHP 5.4.22 and 5.3.27
PERL 5.10.1
Python 2.7.2 with mod_wsgi 3.4 module
MySQL 5.6.14
phpMyAdmin 4.0.9
SQLite Manager 1.2.4
MongoDB 2.4.5(Only 64-bit)
RockMongo 1.1.5
FileZilla FTP Server 0.9.41

The current version of AMPPS for Mac include:
Softaculous AMPPS 2.5(Softaculous 4.3.3)

Apache 2.4.6
PHP 5.5.6, PHP 5.4.22 and 5.3.27
PERL 5.14.1
Python 2.7.2 with mod_wsgi 3.4 module
MySQL 5.6.14
phpMyAdmin 4.0.9
SQLite Manager 1.2.4
MongoDB 2.4.5(Only 64-bit)
RockMongo 1.1.5
Pure-FTPd Server 1.0.35

2) AMPPS is now supported on Mavericks Mac OS X.

3) Xdebug libraries are pre-compiled for Ampps for Mac OS X and are placed in extension folder of respective PHP version. Windows user please follow this post.

4) Added option to sort the installations by Scripts, Domains or Time on the List installations page in Softaculous Enduser panel. Click here for guide.

5) The installation will be highlighted on the overview page of the script Softaculous enduser panel when the user returns after completing a task. For example : Recently Installed, Recently Upgraded, Recently Backed
up, etc.

Board Image

6) Installation URL will now be displayed on the Backups page while the installation is being backed up.

7) Added Pre and Post Import hooks. Click here for guide.

8) Admins can now add icons for your Custom script packages. Click here for guide.

9) List Disabled script installations : When a script is disabled by Softaculous or by server admin the existing installations of such script(s) will be displayed on All Installations page so that the user can remove the installation using Softaculous. Click here for guide.

10) Users can now edit Database Host from Edit Installations page in Softaculous Enduser panel.

11) Added an option for Custom script users to provide their demo URL. The URL can be added in the info.xml file of the custom script package in the <demo> tag.

12) Couchbase PHP Libraries have been added in Windows Package.

13) Bug Fix : If ONLY Custom scripts are enabled on the server Top Scripts were not loaded properly. This is now fixed.

14) Bug Fix : The Script Demos were not displayed in the iframe due to recent browser updates which did not allow to load content from Non SSL URLs. The demos will now be loaded from SSL URLs.

15) Bug Fix : Script Ratings was displayed on the Top Scripts page even if Ratings was disabled by Admin. This is now fixed.

16) Bug Fix : FTP Users were not added from Enduser Panel (on Mac). It is fixed.

17) Bug Fix : PHP MySQL Library had a version mismatch, warnings were displayed (on Mac). It is fixed.

Note: AMPPS won't support PHP 5.2 anymore.

We hope you enjoy the feature(s), we will be adding many more features in the upcoming versions.

Follow us on Twitter
Like us on Facebook
Follow us on Google+

Regards,
The Softaculous AMPPS Team

Edited by Moderator : November 22, 2013, 9:47 am

-----------------------
Follow AMPPS on,
Twitter : https://twitter.com/AMPPS_Stack
Facebook :  http://www.facebook.com/softaculousampps
Google+ : https://plus.google.com/u/0/b/111580687033722614505/
IP: --   

AMPPS 2.2
Kynao
Group: Member
Post Group: Elite Member
Posts: 429
Status:
Hi,

This is cool, thanks you.
I never understood release numbers :)

For example this thread name is AMPPS 2.2 but we talk AMPPS2.5 all long :).

Ampps download page http://www.ampps.com/downloads is 2.2 but once installed, if i go to my installation page http://localhost/ampps-admin/index.php?act=updates, i have 2.5 :)

Better that explanations, i'm suggesting clarification changes on release numbers, as it's really confusing actually.
IP: --   

AMPPS 2.2
ketan
Group: AMPPS Team
Post Group: Working Member
Posts: 206
Status:
Hi,

The version 2.2 is for the AMPPS stack(.i.e. the stack of Apache, MySQL, Php etc and the AMPPS Control Center).

The version 2.5 is for the Softaculous Ampps( i.e. the web interface) that is an addon feature in the AMPPS Stack. It is an auto installer used to install the scripts from its huge library. It is independent of the AMPPS Stack.

-----------------------
Follow AMPPS on,
Twitter
Facebook
Google+
IP: --   

AMPPS 2.2
Kynao
Group: Member
Post Group: Elite Member
Posts: 429
Status:
Thanks for the info.

If that can pleased you, i suggest either a different name for the web interface, i would have say without ampps :) but softaculous is also a product ... and a trademark :).

How do we call the web interface for Softaculous product :
Softaculous Softaculous ? :)

If we say "Softaculous", is it :
- the web interface
- the product
- or the trademark

? :)
IP: --   

AMPPS 2.2 ...
--marc
Group: Member
Post Group: Newbie
Posts: 7
Status:
The Mac OS X AMPSS 2.2 download ...
--> http://files.ampps.com/AMPPS-2.2.dmg

... has both conflicting and confusing version numbers.

1. Ampps.app has conflicting versions (from a Mac user point of view) ...
1.a. From the Finder, right click Ampps.app and select "Get Info" shows "Version: 2.1" with "Created: Monday, November 18, 2013" (see AmppsGetInfo.tiff)
1.b. From the Ampps application menu, select About ... and the About window shows "Version 2.2" with "Build on October 28 2013" (see AmppsAbout.tiff)

Did the Ampps.app info.plist miss being updated for the release???  Also, I think that the there is a way to put the build date in the info.plist as well.

2. Information for "Ampps.app" vs. "AMPPS Stack" vs. "Softaculous Ampps" versions is confusing per the information provided in the release notes.

It would be helpful if the list of changes in the release notes has a more complete list of the separate versioned product names with a hint of where to look for the respective version numbers. For example...


The current version of AMPPS for Mac include:
Ampps.app 2.1 see Finder "Get Info" <--- is 2.1 is indeed correct?  :??:
AMPPS Stack 2.2 see AMPPS application "About"
Softaculous AMPPS 2.5 (Softaculous 4.3.3) see "AMPPS Admin"
Apache 2.4.6
... snip ...
Pure-FTPd Server 1.0.35

IP: --   

AMPPS 2.2
Brijesh
Group: Softaculous Team
Post Group: Super Member
Posts: 2106
Status:
Quote
Ampps.app 2.1 see Finder "Get Info" <--- is 2.1 is indeed correct?  :??:

This was not updated by mistake in the binary. It will be updated in the next version. This should have been 2.2

The versions are explained here :
http://ampps.com/download

AMPPS 2.2 refers to the version of the application AMPPS.
Softaculous AMPPS 2.5 refers to the version of Softaculous within AMPPS. Currently this corresponds to the Softaculous version 4.3.3

We will try to make this more clear from the next version where Softaculous AMPPS 2.5 will be replaced with Softaculous 4.3.3 to avoid confusion.


-----------------------
Facebook
Twitter
Vote for us
IP: --   

AMPPS 2.2 -- SQLiteManager/PHP version issue
--marc
Group: Member
Post Group: Newbie
Posts: 7
Status:
The bug & fix for SQLiteManager/PHP version issue found in AMPPS 2.1 remains unfixed in AMPPS 2.2
--> http://www.softaculous.com/board/index.php?tid=4503



When the PHP Version is set to PHP 5.5, then clicking the 'SQlite Manager' at http://localhost/sqlite/ presents an error page which states:
Quote
"Strict Standards: Non-static method sqlite::getDbVersion() should not be called statically, assuming $this from incompatible context in /Applications/AMPPS/SQLiteManager/include/SQLiteAutoConnect.class.php on line 12"
This is apparently a known bug with a 1-line fix ...
  --> http://sourceforge.net/p/sqlitemanager/bugs/56/
PHP Code

 /* file to be fixed is AMPPS/SQLiteManager/include/sqlite.class.php */
  
function getDbVersion($fullPath){  /* line before fix */ 
  
after fix: public static function getDbVersion($fullPath){ /* line after fix */ 

Alternately, switch the PHP Version to PHP 5.3 and the error goes away.
IP: --   

AMPPS 2.2
clau
Group: Member
Post Group: Newbie
Posts: 5
Status:
Is there a way to manually add PHP 5.2 to this release? I need to test some old PHP sites.
IP: --   

AMPPS 2.2
tidus
Group: AMPPS Team
Post Group: Super Member
Posts: 1064
Status:
Quote From : clau January 6, 2014, 8:48 pm
Is there a way to manually add PHP 5.2 to this release? I need to test some old PHP sites.
Hi,

No.


-----------------------
Follow AMPPS on,
Twitter : https://twitter.com/AMPPS_Stack
Facebook :  http://www.facebook.com/softaculousampps
Google+ : https://plus.google.com/u/0/b/111580687033722614505/
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is July 22, 2014, 11:45 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 10  |  Page Created In:0.402