Scripts Version Requirements

From Softaculous Wiki
Jump to: navigation, search

Determine PHP Version requirements

  • You can determine the PHP version requirements from the $scripts variable. $scripts is available everywhere in Softaculous just globalize it to use it.
  • The PHP version requirements is stored in either php_min and php_max keys of the array $scripts.
  • php_min refers to the minimum PHP version required for the particular script. For eg : if php_min has the value 5.3 then the script requires minimum PHP 5.3.0
  • php_max refers to the maximum PHP version for the particular script. For eg : if php_max has the value 5.3 then the script works with the versions lower than PHP 5.3.0 i.e. the script works on PHP 5.2.x but not on 5.3
  • $scripts is a multidimensional array. So for eg if you need the PHP version requirements for the script Moodle. The value will stored in $scripts['98']['php_min'] or $scripts['98']['php_max']. Here 98 is the script id of the script Moodle.


List of scripts PHP version requirements

Please refer to the following page for updated list of PHP version requirements :
http://softaculous.com/softaculous/php_requirements