Welcome Guest. Please Login or Register  


You are here: Index > SitePad Website Builder > General Support > Topic : Create main blog page with links to posts



Threaded Mode | Print  

 Create main blog page with links to posts, And, how to have only one post per page appear? (5 Replies, Read 681 times)
HappySnappers
Group: Member
Post Group: Newbie
Posts: 18
Status:
Howdy Folks,

Just wondering how I can possibly make only 9 of my blog posts appear on a main blog page? I spent a lot of time and created a page called "Blog" and made it have a 3x3 grid appearance with summaries of the blog posts appearing, but somehow it now doesn't actually appear, instead, I get an annoying continuous page of blog posts appearing.

I want my blog post home page to ONLY have the 9 posts appearing at a time, so that visitors have to go through multiple pages with ONLY 9 posts appearing at a time, so it's not overwhelming for them, and I want my blog posts to appear ONLY 1 at a time, not as a huge mess of continuous posts.

In Settings I have changed "Blog Posts Show At Most" to 1, I now can't edit any of the posts apart from the third one! I keep getting an error message saying something about the post having no content section and to make sure the template is correct!  :??:

This has also changed my page called "Blog" which I spent a long time getting to appear correctly, with the 3x3 grid layout, so when I go to edit it, it gives me the same error message saying there is no content section and to make sure the template is correct, it also appears as a continuous page with all the posts appearing one after the other.

Any help and insights you folks might have would be appreciated, I have searched and read everything on the Wiki Support site, but there's nothing covering this sort of stuff there.

Do I have to recreate the "Blog" page? Or is there some other settings to reset somewhere? I have searched through all of the settings and the only one I have changed is the "Blog Posts Show At Most".
IP: --   

Create main blog page with links to posts
HappySnappers
Group: Member
Post Group: Newbie
Posts: 18
Status:
Okay, I got the main blog page back by copying it, deleting the current one and renaming the copy to "blog". That's a big relief!  :D

The ONLY blog post that appears is the third one! It doesn't matter which link you click on at the main blog page, you always get taken to a copy of the third post!

The third blog post is the ONLY one that doesn't have that warning about it having no content section too!

Please help!
IP: --   

Create main blog page with links to posts
HappySnappers
Group: Member
Post Group: Newbie
Posts: 18
Status:
Now, I can't edit ANY of the blog posts!

They all have this error message saying that there is no content section and to check the template!

In their place is the main blog page with the 3x3 grid!
IP: --   

Create main blog page with links to posts
HappySnappers
Group: Member
Post Group: Newbie
Posts: 18
Status:
Okay, now it's just really bizarre!

I deleted the blog posts in case the fault was with them and recreated a single blog post from scratch.

It won't appear in the editor, it comes up with the exact same error message as mentioned above, which says that this template has no content section for blog pages!

Please help, this is getting infuriating!
IP: --   

Create main blog page with links to posts
aakash_softac
Group: Softaculous Team
Post Group: Elite Member
Posts: 462
Status:
Hi,

Can you provide us with the screenshot regarding this issue?

Also, to show Blogs inside Blog Page you will need to select it as post page by going to SitePad > Settings > Reading > select static pages > Post Page as Blog


Edited by aakash_softac : December 19, 2017, 7:41 am

-----------------------
Aakash Gupta
SitePad Developer

Follow us for faster updates
Twitter: https://twitter.com/sitepad_editor
Facebook: https://facebook.com/SitePad
IP: --   

Create main blog page with links to posts
HappySnappers
Group: Member
Post Group: Newbie
Posts: 18
Status:
I think I worked out what was causing this problem!

I deleted the blog posts and recreated them all again, something I had already done 3 times, but this time, I DIDN'T rename them. I had been renaming them to 001, 002, 003, etc... in order of creating them.

This last time around, I left the automated page names and it seems to be working!

So far, so good!

You can check it out here at my Blog Page
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is November 22, 2019, 7:08 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.209