Welcome Guest. Please Login or Register  


You are here: Index > Webuzo > General Support > Topic : Downgrade Exim outside of Webuzo



Threaded Mode | Print  

 Downgrade Exim outside of Webuzo (8 Replies, Read 4484 times)
erile
Group: Member
Post Group: Working Newbie
Posts: 63
Status:
Hello,

In two VPS of mine, Webuzo upgraded Exim to 4.94 and I started to experience issues with error messages like "Tainted filename for search: '/etc/vmail/.../aliases" or "451 Temporary local problem".

Searching, I finally found a page talking about these issues since Exim 4.94 on CentOS (and maybe with some control panels only, but I'm not sure).

Apparently, awaiting a fix, the only solution seems to downgrade Exim to 4.93 for now. So, of course, I know that Webuzo (aka. Softaculous) doesn't handle any downgrade (maybe some day in the future;), but maybe you could answer to these two questions :

1) Can I downgrade outside of Webuzo without loosing my configuration nor breaking something against Webuzo? Or is it preferable to do it in two times : first, uninstall from Webuzo, then install of the previous version outside of Webuzo?

2) When I will be with Exim 4.93, I wouldn't like to be back to 4.94 because of the Webuzo's auto-update. Thus, is it possible to keep global auto-update, but block it for one application only (I mean until I know Exim fixed the issue)?

Let me know.
TIA

-----------------------
OpenVZ VPS, CentOS 7, Webuzo Premium / Desktop and full-stack dev w/ C, C++, Python, Perl, javascript...
IP: --   

Downgrade Exim outside of Webuzo
wolke
Group: NOC
Post Group: Elite Member
Posts: 413
Status:
I would not recommend downgrading before you tried this with a testserver.
But you can prevent upgrading packages on CentOS if you add an exclude directive into the yum.conf file which you can find at

Code
/etc/yum.conf

or
Code
/etc/yum/yum.conf


just add a line with
Code
exclude=exim*

and yum will ignore any update requests for all exim packages.

IP: --   

Downgrade Exim outside of Webuzo
erile
Group: Member
Post Group: Working Newbie
Posts: 63
Status:
Thanks, wolke. So, I understand that Webuzo relies entirely on yum. Well, I'll do this, hoping it will solve the issue. I have no other choice than downgrading since email are currently down and I didn't find any other solution after a lot of search.

A side question : is it (I guess not, but in case) possible to exclude a specific version? I mean, I will downgrade to Exim 4.93, then exclude Exim 4.94 only... And yum will automatically well update to Exim 4.95 when it will appear in a repo?

Also, I noticed a thing this last year (something about the Webuzo behavior, unrelated to my specific current issue with Exim) : I had a Dovecot issue after an update from 2.2 to 2.3 by Webuzo (ie. yum), then I fixed it (was just about SSL/TLS in conf, so solvable this time)... But later I installed a new VPS and I noticied that Webuzo didn't install this specific Dovecot version, but it installed Dovecot 2.2 instead... So, I concluded that Webuzo decided to skip Dovecot 2.3 (maybe because the team saw the same issue and decided to exclude it globally -- I mean in all servers managed by Webuzo all over the world). Thus, maybe it would worth to test Exim 4.94 and see if it would be relevant to exclude it globally the same way or not.


-----------------------
OpenVZ VPS, CentOS 7, Webuzo Premium / Desktop and full-stack dev w/ C, C++, Python, Perl, javascript...
IP: --   

Downgrade Exim outside of Webuzo
wolke
Group: NOC
Post Group: Elite Member
Posts: 413
Status:
Quote
A side question : is it (I guess not, but in case) possible to exclude a specific version? I mean, I will downgrade to Exim 4.93, then exclude Exim 4.94 only... And yum will automatically well update to Exim 4.95 when it will appear in a repo?


Yes, of couse. You can replace

Code
exclude=exim*

with the exact packagename or parts thereof. The "star" is just a placeholder, so all packages that starts with "exim" are excluded.
But excluded packages won´t update to whatever while blocked.

You can also use yum versionlock to block the currently installed version from being upgraded. Here is a good article about this:

https://www.cyberciti.biz/faq/centos-redhat-fedora-yum-lock-package-version-command/


Edited by wolke : July 13, 2020, 10:03 am
IP: --   

Downgrade Exim outside of Webuzo
erile
Group: Member
Post Group: Working Newbie
Posts: 63
Status:
Understood, thanks again ;)

Well, just an update since it may help someone else: this Exim 4.94 issue is largely discussed at https://forum.vestacp.com/viewtopic.php?f=12&t=19994 and has been reported on 2020-06-18 in the issue tracker at https://bugzilla.redhat.com/show_bug.cgi?id=1848283

On my part, I successfully downgraded using the commands below and my email system is working again. I also locked the exim update with the yum's versionlock plugin.

Code

wget https://ca1.dynanode.net/exim-4.93-3.el7.x86_64.rpm
rpm -Uvh --oldpackage exim-4.93-3.el7.x86_64.rpm
sudo yum install yum-versionlock
sudo yum versionlock exim


-----------------------
OpenVZ VPS, CentOS 7, Webuzo Premium / Desktop and full-stack dev w/ C, C++, Python, Perl, javascript...
IP: --   

Downgrade Exim outside of Webuzo
spydymn
Group: Member
Post Group: Newbie
Posts: 6
Status:
hello

i am also getting this 451 Temporary local problem error on my vps, all my domain emails give this error dont know when this happened but they were all working perfect for last 2 years now all give this error.
I been trying to figure this out for weeks searching and just ended here today is this error caused by Exim as in this thread?? any help would greatly appreciated

Thx
IP: --   

Downgrade Exim outside of Webuzo
spydymn
Group: Member
Post Group: Newbie
Posts: 6
Status:
ok tried code above and it seems to have worked, took me 3 times for to get downgrade to work to use versionlock.
no 451 errors anymore  but emails are very slow will see if clears up after a couple of days

Thx for posting this fix for now but hopefully we get this issue fixed properly to allow future updates
IP: --   

Downgrade Exim outside of Webuzo
erile
Group: Member
Post Group: Working Newbie
Posts: 63
Status:
Happy to see it helped you... Of course, hoping Exim will fix this issue in a next release some day!

-----------------------
OpenVZ VPS, CentOS 7, Webuzo Premium / Desktop and full-stack dev w/ C, C++, Python, Perl, javascript...
IP: --   

Downgrade Exim outside of Webuzo
spydymn
Group: Member
Post Group: Newbie
Posts: 6
Status:
seems i still having issues  after applying the fix above as i can receive emails now but cannot send emails, well says there sent but i never receive them.
i looked in email accounts in webuzo and all the emails i sent are sitting in mail queue
anyone any idea that could help
sorry for all questions as i only know some basic vps management

thx
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is June 17, 2021, 6:05 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:1.554