Welcome Guest. Please Login or Register  


You are here: Index > Softaculous Auto Installer > General Support > Topic : PHP Version Required error



Threaded Mode | Print  

 PHP Version Required error, It's happening when installing programs in cPanel newest release with EA4 MultiPHP (7 Replies, Read 1495 times)
SteiniPe
Group: Member
Post Group: Newbie
Posts: 2
Status:
Hello,

I am the technical supervisor for a webhosting company called OrangeWebsite. We run the latest cPanel with EA4 and MultiPHP 5.6 and 7.0, a client came to us today with

Posted on Monday 10th July at 21:12
Hi there!

Quote
Sorry, I am still having problems trying to install with Softaculous:

Required PHP version greater than equal to 5.6.0 AND found version is : 5.6

Maybe this needs to be applied: ..../docs/Hooks#Change_PHP_Version

Thanks,
B


Then I looked into the file to change, and changed the following

Quote
Editing file /usr/local/cpanel/whostmgr/docroot/cgi/softaculous/enduser/hooks/pre_install.php


from
function __pre_install(){
global $soft, $software, $globals;
// Do stuff here e.g. is as follows
$version = '5.6';
define('php_version' , $version);
if($soft == 26){ /* Do things only if its WordPress */ }
}

to
function __pre_install(){
global $soft, $software, $globals;
// Do stuff here e.g. is as follows
$version = '5.6.0';
define('php_version' , $version);
if($soft == 26){ /* Do things only if its WordPress */ }
}


That resolved the issue and I am running the latest Softaculous so to give the information

WHM 64.0 Build 30
EasyApache 4
MultiPHP 5.6 and 7.0
Softaculous Latest

Fixing the file fixed this issue, but we have so many other server nodes? I would much rather get a patch on this? because when I fix this, does this not get overwritten if we do a softaculous update?..

Anyway this is a bug as far as i can see.

IP: --   

PHP Version Required error
salman
Group: Softaculous Team
Post Group: Newbie
Posts: 21
Status:
Hi,

We tried to replicate this issue on our test server but we are unable to find such issues.

Can you please open a support ticket with us so we can check what causing the issue.

IP: --   

PHP Version Required error
salman
Group: Softaculous Team
Post Group: Newbie
Posts: 21
Status:
Hi,

As you mentioned that you had configured PHP version to 5.6 in pre_install.php hook, hence you are facing this issue.

We already have multiphp hook for EA4 enabled which handle the multiphp version detection:/usr/local/cpanel/whostmgr/docroot/cgi/softaculous/enduser/hooks/softaculous_filter.php

We use version_compare() to compare the php version and i have tested if we compare 5.6.0 with 5.6 it is giving 5.6 is lower than 5.6.0 and since you have configures php version in pre_install.php hook it is assuming the php version 5.6 and the script is required 5.6.0

Please make sure the multiphp hook is enable at 

And also please disable pre_install.php hook by renaming it to .txt and then try to install you should not face this issue.

Please let us know if you still face the issue.
/usr/local/cpanel/whostmgr/docroot/cgi/softaculous/enduser/hooks/softaculous_filter.php
IP: --   

PHP Version Required error
salman
Group: Softaculous Team
Post Group: Newbie
Posts: 21
Status:
Hi,



As you mentioned that you had configured PHP version to 5.6 in pre_install.php hook, hence you are facing this issue.



We already have multiphp hook for EA4 enabled which handle the
multiphp version
detection:/usr/local/cpanel/whostmgr/docroot/cgi/softaculous/enduser/hooks/softaculous_filter.php



We use version_compare() to compare the php version and i have
tested if we compare 5.6.0 with 5.6 it is giving 5.6 is lower than 5.6.0
and since you have configures php version in pre_install.php hook it is
assuming the php version 5.6 and the script is required 5.6.0



Please make sure the multiphp hook is enable at  /usr/local/cpanel/whostmgr/docroot/cgi/softaculous/enduser/hooks/softaculous_filter.php
   
   



And also please disable pre_install.php hook by renaming it to .txt and then try to install you should not face this issue.



Please let us know if you still face the issue.


IP: --   

PHP Version Required error
SteiniPe
Group: Member
Post Group: Newbie
Posts: 2
Status:
I remember this now, I had to enable this hook for a reason way back in the day, there was some reason for it, I wouldn't normally go and just edit this file unless I was specified to by a guide. There was some reason with this, however I think it's wrong to consider 5.6 be lesser than 5.6.0 because 5.6 can not in its meaning be less than 5.6.0 as 5.6.0 is the lowest of the branch version.

Anyway I now know what I do, I will disable this hook on all the nodes but I hope I won't have to do this again because It takes time to manually update all the nodes.
IP: --   

PHP Version Required error
salman
Group: Softaculous Team
Post Group: Newbie
Posts: 21
Status:
Hi,

The php function version_compare() itself gives that 5.6.0 is greater than 5.6, in mutiphp hook, and version detections is correctly handled for multiphp at
/usr/local/cpanel/whostmgr/docroot/cgi/softaculous/enduser/hooks/softaculous_filter.php
you will just need to disable the hook by renaming it to 
pre_install.php pre_install.txt and then try to install you should not
face the issue.

please let us know.
IP: --   

PHP Version Required error
gboyega
Group: Member
Post Group: Newbie
Posts: 1
Status:
Quote From : salman July 11, 2017, 9:27 am
Hi,

The php function version_compare() itself gives that 5.6.0 is greater than 5.6, in mutiphp hook, and version detections is correctly handled for multiphp at
/usr/local/cpanel/whostmgr/docroot/cgi/softaculous/enduser/hooks/softaculous_filter.php
you will just need to disable the hook by renaming it to 
pre_install.php pre_install.txt and then try to install you should not
face the issue.

please let us know.



I have serched all the files on my website and cannot see any file softaculous_filter.php.  I am using Cpanel Version 11 on a share server.  When i tried to upgrade Epesi software, I get similar error but dont know how to correct it. please help
IP: --   

PHP Version Required error
Brijesh
Group: Softaculous Team
Post Group: Super Member
Posts: 3914
Status:
Quote From : gboyega January 20, 2018, 4:51 pm

I have serched all the files on my website and cannot see any file softaculous_filter.php.  I am using Cpanel Version 11 on a share server.  When i tried to upgrade Epesi software, I get similar error but dont know how to correct it. please help

Hi,

This file is accessible only to root and since you are on shared hosting you might not have access to that file.

EPESI requires PHP 5.5+, please confirm if you are using PHP version greater than 5.5.0

If you still face the issue please open a support ticket with us so that we can check this issue for you :
https://www.softaculous.com/support/


-----------------------
SitePad Website Builder
Follow us on Twitter
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is June 22, 2018, 1:00 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.207