Softaculous https://www.softaculous.com/board/index.php? <![CDATA[Questions about Softaculous.]]> https://www.softaculous.com/board/index.php?tid=15053&tpg=1#p45422
So, I recently changed over to MDD Hosting for a couple of sites that I am developing via Wordpress. I wish I had done my homework as I am not a fan so far. I would much rather add themes and plug-ins via the dashboard.

I am very confused about adding themes and plug-ins. There seems to be limited themes available and there doesnt seem to be a way to add multiple themes and plug-ins. For the main site, I do keep it that way but for my test/development subdomains, I like to play with multiple themes/plugins.

I am having trouble finding good sources on this and I am tempted to just change web hosts because this seems like a foolish way to manage sites. The Wordpress dashboard is highly effective.

Do I have to do an FTP transfer to add the themes not available through softalucous? I really dont understand why they set it up this way.]]>
Tue, 26 Mar 2019 16:21:52 GMT https://www.softaculous.com/board/index.php?tid=15053&tpg=1#p45422
<![CDATA[Memcached not installed on PHP 7.2 Extensions]]> https://www.softaculous.com/board/index.php?tid=15044&tpg=1#p45421
# yum -y install autoconf
# yum -y install pkgconfig
NO DASH

I also came across this. Not sure if it's important to do the make test




Libraries have been installed in:
  /root/libmemcached-1.0.18/memcached-3.1.3/modules

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
  - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
    during execution
  - add LIBDIR to the `LD_RUN_PATH' environment variable
    during linking
  - use the `-Wl,--rpath -Wl,LIBDIR' linker flag
  - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------

Build complete.
Don't forget to run 'make test'.

Installing shared extensions:    /usr/local/apps/php72/lib/extensions/no-debug-non-zts-20170718/


This did not work.
cp /root/memcached-3.1.3/modules/memcached.so /usr/local/apps/php72/ext

So I change to the directory
cd memcached-3.1.3/modules
Then ran
#cp memcached.so /usr/local/apps/php72/ext

Hopefully, that was the right location

For #4 I get this error.

Starting php-fpm: [26-Mar-2019 12:17:42] ERROR: An another FPM instance seems to already listen on /usr/local/apps/php72/var/php72_9000.sock
[26-Mar-2019 12:17:42] ERROR: FPM initialization failed


]]>
Tue, 26 Mar 2019 12:35:25 GMT https://www.softaculous.com/board/index.php?tid=15044&tpg=1#p45421
<![CDATA[protocol broken with WordPress]]> https://www.softaculous.com/board/index.php?tid=15052&tpg=1#p45420 I use the laste version (php 5.6-7.0) and uploaded softaculous.php and softaculous_extra.php.

My aim is to automatically create a WordPress Install ons erver setup.

I did not create any custom fields in WHMCS because I don't want my user to decide.
I want my script to set credentieals, folders, etc...

The PROBLEM is the final install don't have protocol (none http// or http//www.).

It simply creates a wordpress install with domain.com (protocol empty). (See picture attached.

I tried :
$GLOBALS['softaculous_conf']['protocol'] = 'http-//www.';
$GLOBALS['softaculous_conf']['softproto'] = 'http-//www.';
$GLOBALS['softaculous_conf']['defaults']['protocol'] = 'http-//www.';
$GLOBALS['softaculous_conf']['defaults']['softproto'] = 'http-//www.';


It did not work. am i missing something with WordPress ?

(replace - per : in urls...)
]]>
Tue, 26 Mar 2019 12:02:35 GMT https://www.softaculous.com/board/index.php?tid=15052&tpg=1#p45420
<![CDATA[Memcached not installed on PHP 7.2 Extensions]]> https://www.softaculous.com/board/index.php?tid=15044&tpg=1#p45419
You can install and enable memcached in PHP73 as well.

Regarding the autoconf error you are getting:
I apologise that with the steps I gave you yesterday the following is to be added:
# yum -y install autoconf
# yum -y install pkg-config

Also if you want we can enable this for you. You need to open a support ticket from here:
https://www.softaculous.com/support/

Let us know.]]>
Tue, 26 Mar 2019 07:43:43 GMT https://www.softaculous.com/board/index.php?tid=15044&tpg=1#p45419
<![CDATA[Root Password Error]]> https://www.softaculous.com/board/index.php?tid=15041&tpg=1#p45418
I still can not test connect SSH]]>
Mon, 25 Mar 2019 18:20:57 GMT https://www.softaculous.com/board/index.php?tid=15041&tpg=1#p45418
<![CDATA[Memcached not installed on PHP 7.2 Extensions]]> https://www.softaculous.com/board/index.php?tid=15044&tpg=1#p45417
/usr/local/apps/php72/bin/phpize
Configuring for:
PHP Api Version:        20170718
Zend Module Api No:      20170718
Zend Extension Api No:  320170718
Cannot find autoconf. Please check your autoconf installation and the
$PHP_AUTOCONF environment variable. Then, rerun this script.


???]]>
Mon, 25 Mar 2019 17:44:48 GMT https://www.softaculous.com/board/index.php?tid=15044&tpg=1#p45417
<![CDATA[Root Password Error]]> https://www.softaculous.com/board/index.php?tid=15041&tpg=1#p45416
eth0:

DEVICE=eth0
HWADDR=1C:6F:65:CA:7F:60
IPV6INIT=no
ONBOOT=yes
BRIDGE=viifbr0
NAME=eth0

viifbr0:
DEVICE=viifbr0
TYPE=Bridge
BOOTPROTO=static
IPADDR=192.168.1.200
NETMASK=255.255.255.0
ONBOOT=yes
IPV6INIT=no
NAME=viifbr0

ip pool :

gateway = 192.168.1.201
netmask = 255.255.255.0
nameserver 1,2 = 8.8.8.8 , 8.8.4.4
first ip = 192.168.1.202
last ip = 192.168.1.210
Is Internal ip range? = checked
Internal IP Bridge : viifbr0

i set ip internal & public ip to VPS = 192.168.1.203

truly my internet ip is dynamic

ip 192.168.1.0/24 is my network ip range

i want use kvm in the private network


so this error  fixed "There was an error in setting the Root Password of the new VPS" but i get a new error "There was an error while starting the new VPS
setlocale: No such file or directory error: Failed to create domain from /etc/libvirt/qemu/v1004.xml error: internal error process exited while connecting to monitor: char device redirected to /dev/pts/1 2019-03-25T17:00:53.333251Z qemu-kvm: Failed to start VNC server on `PUPLICIP:1,password': socket bind failed: Cannot assign requested address 2019-03-25 17:00:53.399+0000: shutting down"



]]>
Mon, 25 Mar 2019 17:38:10 GMT https://www.softaculous.com/board/index.php?tid=15041&tpg=1#p45416
<![CDATA[How to search the right General Support?]]> https://www.softaculous.com/board/index.php?tid=15018&tpg=1#p45415
Thanks,
]]>
Mon, 25 Mar 2019 16:20:03 GMT https://www.softaculous.com/board/index.php?tid=15018&tpg=1#p45415
<![CDATA[Memcached not installed on PHP 7.2 Extensions]]> https://www.softaculous.com/board/index.php?tid=15044&tpg=1#p45414
Thanks for the response.]]>
Mon, 25 Mar 2019 15:27:14 GMT https://www.softaculous.com/board/index.php?tid=15044&tpg=1#p45414
<![CDATA[Memcached not installed on PHP 7.2 Extensions]]> https://www.softaculous.com/board/index.php?tid=15044&tpg=1#p45413
Sorry for delayed reply.

The memcached that you installed is not a PHP extension.

As well memcached extension has not been made available in Webuzo. It needs to be manually configured on your server. Please follow the given below steps for manually configuring the memcache.so in php72:
1. Execute the following commands in order given:
# yum install cyrus-sasl-devel
# cd
# wget https://launchpad.net/libmemcached/1.0/1.0.18/+download/libmemcached-1.0.18.tar.gz
# tar -zxvf libmemcached-1.0.18.tar.gz
# cd libmemcached-1.0.18
# ./configure
# make && make install
# wget http://pecl.php.net/get/memcached-3.1.3.tgz
# tar -zxf memcached-3.1.3.tgz
# cd memcached-3.1.3
# /usr/local/apps/php72/bin/phpize
# LDFLAGS="-L/usr/local/apps/lib" CPPFLAGS="-I/usr/local/apps/include" ./configure --with-php-config="/usr/local/apps/php72/bin/php-config" --with-zlib-dir="/usr/local/apps" --disable-memcached-sasl && make && make install
# cd
# cp /root/memcached-3.1.3/modules/memcached.so /usr/local/apps/php72/ext

2. Open the PHP 72 extra.ini file by executing the following command as root:
# vi /usr/local/apps/php72/etc/php.d/extra.ini

3. Add the following statement to the end of the file:
extension=memcached.so

4. Restart the PHP72 service from commandline as root:
# service php-fpm72 restart

Once done, you will find the memcached extension loaded in PHP 72 using following command:
# php -m | grep memcached

We'll try to provide memcached extension in Webuzo as soon as possible.

Let us know if you need any further information.]]>
Mon, 25 Mar 2019 13:51:23 GMT https://www.softaculous.com/board/index.php?tid=15044&tpg=1#p45413