Topic : Problems showing perl files

Posted By: mattia93 on January 12, 2018, 9:01 pm

I am a newbie and I'm trying to setting everything with ampps to work with perl files since that I'm studying web development.

If I run the server and go to localhost/cgi-bin/ I can see the file without any problem on my browser, so I guess my perl is working fine. I duplicated it and edited with Komodo and it still works good.

But if i try to create another perl file and put it inside the same cgi-bin it just give me a 500 internal server error (I am a newbie too with perl, so to avoid errors in this third file I just copied and pasted the exact same code inside the file, just changing the print with an "Hello world").

I am using a mac with high sierra 10.13.2 and AMPPS 3.8

Just a note (maybe important): during the installation I encountered some problems because the perl folder was not inside the installer at all. I mean, my ampps 3.8 didn't come with perl installed by default as I guessed it is supposed to be. So to get it I downloaded the php dev package, copied the perl folder from it and pasted into my ampps folder

I looked everywhere online, I have seen that somebody talk about permissions, but anyway I guess I'm not enough able to change them with the terminal :squi:

Posted By: mattia93 on January 12, 2018, 11:21 pm | Post: 1
Update: I solved the issue with the files created by me (and not only duplicated)

It was just a permission problem  ;-D

But I still don't know why there's no perl folder inside the 3.8 DMG installer package...

Powered By AEF 1.0.8 © 2007-2008 Electron Inc.