Welcome Guest. Please Login or Register  


You are here: Index > Softaculous Auto Installer > General Support > Topic : Cannot install apps anymore



Threaded Mode | Print  

 Cannot install apps anymore (5 Replies, Read 553 times)
armorharmer
Group: Member
Post Group: Newbie
Posts: 3
Status:
On a fresh ISPConfig install, when I setup Softaculous as I did before, now I got this error:

Quote
PHP Notice:  Array to string conversion in /usr/local/softaculous/enduser/main/functions.php on line 6501
PHP Notice:  Undefined variable: database_user_id in /usr/local/softaculous/enduser/softpanel.php on line 567
PHP Fatal error:  Uncaught SoapFault exception: [database_error] You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'AND 1' at line 1 DELETE FROM `web_database_user` WHERE database_user_id =  AND 1 in /usr/local/softaculous/enduser/softpanel.php:567
Stack trace:
#0 /usr/local/softaculous/enduser/softpanel.php(567): SoapClient->__call('sites_database_...', Array)
#1 /usr/local/softaculous/enduser/main/software.php(1559): softpanel->deldb('gall666', 'gall666')
#2 /usr/local/softaculous/enduser/main/software.php(1217): deldb()
#3 /usr/local/softaculous/enduser/inc.php(319): software()
#4 /var/softwww/load.php(141): unknown()
#5 {main}
  thrown in /usr/local/softaculous/enduser/softpanel.php on line 567
PHP Notice:  Use of undefined constant LOGLEVEL_INFO - assumed 'LOGLEVEL_INFO' in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 484


And Softcaculous itself is stucked at either Checking the submitted data or at copying files and folders at 95%...

IP: --   

Cannot install apps anymore
armorharmer
Group: Member
Post Group: Newbie
Posts: 3
Status:
I set minimum passowrd lenght to 12, and Softaculous sets DB user passowrd to 10, so that was the problem!
IP: --   

Cannot install apps anymore
priya_mittal
Group: Softaculous Team
Post Group: Newbie
Posts: 43
Status:
Hi,

We have made the changes in Softaculous to create the database password of length same as the password length set in ISPConfig panel if it is greater than 10.

If you want us to provide you with the patch, please let us know the PHP version of your server using the command: php -v

Also, provide us with your email id where we can send you the patch file.

Please feel free to contact us for further issues.
IP: --   

Cannot install apps anymore
armorharmer
Group: Member
Post Group: Newbie
Posts: 3
Status:
Hi, thank you for your quick answer!

The version is 7.0, since that's the version that ISPConfig is requiring.

Thanks!
IP: --   

Cannot install apps anymore
priya_mittal
Group: Softaculous Team
Post Group: Newbie
Posts: 43
Status:
Hi,

Thank you for your response.

I have emailed you the patch file with my email id priya@softaculous.com. Please replace the same at /usr/local/softaculous/enduser/softpanel.php on your server.

Now test and let us know if you still face the issue.
IP: --   

Cannot install apps anymore
salman
Group: Softaculous Team
Post Group: Newbie
Posts: 21
Status:
Hi,

We have released the Softaculous 4.9.8 which included this fix.
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is May 24, 2018, 10:05 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.191