Welcome Guest. Please Login or Register  


You are here: Index > Webuzo > Bugs > Topic : All pure-ftpd.conf files are ignored



Threaded Mode | Print  

 All pure-ftpd.conf files are ignored (2 Replies, Read 13002 times)
andreszs
Group: Member
Post Group: Newbie
Posts: 15
Status:
According to this post, pureftpd uses settings from: /usr/local/apps/pureftpd/etc/pure-ftpd.conf

but after editing:
Code
MaxClientsNumber 31


and restarting with either the Services page or the
Code
service pure-ftpd restart
command, the welcome message still shows the default (50) users:
Quote
Response:    220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response:    220-You are user number 1 of 50 allowed.
The other pure-ftpd.conf files below are ignored as well:
  • /usr/local/apps/pureftpd/etc/pure-ftpd.conf
  • /usr/local/webuzo/conf/webuzo/pure-ftpd.conf
  • /var/softaculous/apps/pureftpd/pure-ftpd.conf
Why are all these files ignored?
I'm trying to fix the GnuTLS error -110: The TLS connection was non-properly terminated error introduced after updating OpenSSL 1.0.2k with Webuzo, but it all pureftpd config files are ignored, this is simply impossible.I've opened a support ticket for the error 110 issue, but I'm trying to find a solution myself. Thank you.
IP: --   

All pure-ftpd.conf files are ignored
peopleinside
Group: Member
Post Group: Super Member
Posts: 1391
Status:

Open source, web and security passionate
Hi, for me pure FTP has a lot of issues on Webuzo. The Webuzo team is informed about all this issues because I'm reporting since long time.

recently I get again in touch with Webuzo support because if you set TLS 2 in pureFTP config after some day, weeks, etc you can see TLS 1 added at the end of the file so allowing unsecure connection.
I get also error simply uploading an hesk 3.0 folder and removing it get many FTP disconnections.

Avout the issue you are reporting... yes, you can edit pure FTP and try to restart but settings seems to be ignored.
WHY?

Have you tried from Webuzo panel to stop the FTP service than to refresh the services page?

Usually FRP service never get stopped so restarting is not helping. Also stop the service never help somtimes.

For resolve I need do the following SSH command:

pkill pure-ftpd

This will kill all pureFTP process. After that you can try to restart and see if your config file get effect.

service pure-ftpd start


Pure FTP seems to me to be very old, is not updated since 2019
If I made some seach on the web I can see also mozilla and other website is not providing cnfiguration for SSL they use to show ProFTPD

https://ssl-config.mozilla.org/

So I asked to the Webuzo team to look about the pureFTP not updated and try maybe to provide a different FRP like ProFTPD


-----------------------
PeopleInside  :angel:

Web, security, open source passionate.
IP: --   

All pure-ftpd.conf files are ignored
peopleinside
Group: Member
Post Group: Super Member
Posts: 1391
Status:

Open source, web and security passionate
If the pkill command did not work for you you can trykillall  pure-ftpd

-----------------------
PeopleInside  :angel:

Web, security, open source passionate.
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is October 16, 2021, 2:52 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 10  |  Page Created In:0.539