Welcome Guest. Please Login or Register  


You are here: Index > Webuzo > General Support > Topic : Memcached not installed on PHP 7.2 Extensions



Threaded Mode | Print  

 Memcached not installed on PHP 7.2 Extensions (12 Replies, Read 1851 times)
tegralens
Group: Member
Post Group: Newbie
Posts: 12
Status:
I can see memcached is installed but not part of the php extensions.  So how can this be added ?
IP: --   

Memcached not installed on PHP 7.2 Extensions
Dhanya
Group: Softaculous Team
Post Group: Working Member
Posts: 166
Status:
Hi,

Sorry for delayed reply.

The memcached that you installed is not a PHP extension.

As well memcached extension has not been made available in Webuzo. It needs to be manually configured on your server. Please follow the given below steps for manually configuring the memcache.so in php72:
1. Execute the following commands in order given:
# yum install cyrus-sasl-devel
# cd
# wget https://launchpad.net/libmemcached/1.0/1.0.18/+download/libmemcached-1.0.18.tar.gz
# tar -zxvf libmemcached-1.0.18.tar.gz
# cd libmemcached-1.0.18
# ./configure
# make && make install
# wget http://pecl.php.net/get/memcached-3.1.3.tgz
# tar -zxf memcached-3.1.3.tgz
# cd memcached-3.1.3
# /usr/local/apps/php72/bin/phpize
# LDFLAGS="-L/usr/local/apps/lib" CPPFLAGS="-I/usr/local/apps/include" ./configure --with-php-config="/usr/local/apps/php72/bin/php-config" --with-zlib-dir="/usr/local/apps" --disable-memcached-sasl && make && make install
# cd
# cp /root/memcached-3.1.3/modules/memcached.so /usr/local/apps/php72/ext

2. Open the PHP 72 extra.ini file by executing the following command as root:
# vi /usr/local/apps/php72/etc/php.d/extra.ini

3. Add the following statement to the end of the file:
extension=memcached.so

4. Restart the PHP72 service from commandline as root:
# service php-fpm72 restart

Once done, you will find the memcached extension loaded in PHP 72 using following command:
# php -m | grep memcached

We'll try to provide memcached extension in Webuzo as soon as possible.

Let us know if you need any further information.
IP: --   

Memcached not installed on PHP 7.2 Extensions
tegralens
Group: Member
Post Group: Newbie
Posts: 12
Status:
If it's for php 7.3 Do I just need to change the folder locations from php72 to php73 ?

Thanks for the response.
IP: --   

Memcached not installed on PHP 7.2 Extensions
tegralens
Group: Member
Post Group: Newbie
Posts: 12
Status:
I got this error. Is it normal and should I ignore it ?

/usr/local/apps/php72/bin/phpize
Configuring for:
PHP Api Version:        20170718
Zend Module Api No:      20170718
Zend Extension Api No:  320170718
Cannot find autoconf. Please check your autoconf installation and the
$PHP_AUTOCONF environment variable. Then, rerun this script.


???
IP: --   

Memcached not installed on PHP 7.2 Extensions
Dhanya
Group: Softaculous Team
Post Group: Working Member
Posts: 166
Status:
Hi,

You can install and enable memcached in PHP73 as well.

Regarding the autoconf error you are getting:
I apologise that with the steps I gave you yesterday the following is to be added:
# yum -y install autoconf
# yum -y install pkg-config

Also if you want we can enable this for you. You need to open a support ticket from here:
https://www.softaculous.com/support/

Let us know.
IP: --   

Memcached not installed on PHP 7.2 Extensions
tegralens
Group: Member
Post Group: Newbie
Posts: 12
Status:
This worked with a modification

# yum -y install autoconf
# yum -y install pkgconfig
NO DASH

I also came across this. Not sure if it's important to do the make test




Libraries have been installed in:
  /root/libmemcached-1.0.18/memcached-3.1.3/modules

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
  - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
    during execution
  - add LIBDIR to the `LD_RUN_PATH' environment variable
    during linking
  - use the `-Wl,--rpath -Wl,LIBDIR' linker flag
  - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------

Build complete.
Don't forget to run 'make test'.

Installing shared extensions:    /usr/local/apps/php72/lib/extensions/no-debug-non-zts-20170718/


This did not work.
cp /root/memcached-3.1.3/modules/memcached.so /usr/local/apps/php72/ext

So I change to the directory
cd memcached-3.1.3/modules
Then ran
#cp memcached.so /usr/local/apps/php72/ext

Hopefully, that was the right location

For #4 I get this error.

Starting php-fpm: [26-Mar-2019 12:17:42] ERROR: An another FPM instance seems to already listen on /usr/local/apps/php72/var/php72_9000.sock
[26-Mar-2019 12:17:42] ERROR: FPM initialization failed


IP: --   

Memcached not installed on PHP 7.2 Extensions
Dhanya
Group: Softaculous Team
Post Group: Working Member
Posts: 166
Status:
Hi,

For "ERROR: An another FPM instance seems to already listen on /usr/local/apps/php72/var/php72_9000.sock" error:
Kill the PHP-FPM manually and then restart the PHP-FPM service.

Let us know if you face any issues further.
IP: --   

Memcached not installed on PHP 7.2 Extensions
tegralens
Group: Member
Post Group: Newbie
Posts: 12
Status:
This doesn't do anything.

php -m | grep memcached

IP: --   

Memcached not installed on PHP 7.2 Extensions
Dhanya
Group: Softaculous Team
Post Group: Working Member
Posts: 166
Status:
Hi,

Assuming that default selected PHP version is PHP72, in order to check if the memcached is installed and enabled properly in PHP72 execute:
php -m | grep memcached

In order to check if memcached in installed in PHP 7X version execute:
/usr/local/apps/php7X/bin/php -m | grep memcached

Note: 7X - here X is 0, 1, 2 or 3 i.e PHP70/PHP71/PHP72/PHP73

Let us know if you have any further queries.
IP: --   

Memcached not installed on PHP 7.2 Extensions
tegralens
Group: Member
Post Group: Newbie
Posts: 12
Status:
When I ran this I got the below.

/usr/local/apps/php72/bin/php -m | grep memcached
memcached


Is that ok ?
IP: --   

Memcached not installed on PHP 7.2 Extensions
Dhanya
Group: Softaculous Team
Post Group: Working Member
Posts: 166
Status:
Hi,

Yes. It means that memcached module has been enabled in PHP72.

Let us know if you need any further assistance.
IP: --   

Memcached not installed on PHP 7.2 Extensions
tegralens
Group: Member
Post Group: Newbie
Posts: 12
Status:
for php73 do I do these steps below. Only ?


# /usr/local/apps/php73/bin/phpize
# LDFLAGS="-L/usr/local/apps/lib" CPPFLAGS="-I/usr/local/apps/include" ./configure --with-php-config="/usr/local/apps/php73/bin/php-config" --with-zlib-dir="/usr/local/apps" --disable-memcached-sasl && make && make install
# cd
# cp /root/memcached-3.1.3/modules/memcached.so /usr/local/apps/php73/ext

2. Open the PHP 73 extra.ini file by executing the following command as root:
# vi /usr/local/apps/php73/etc/php.d/extra.ini

3. Add the following statement to the end of the file:
extension=memcached.so

4. Restart the PHP73 service from commandline as root:
# service php-fpm73 restart
IP: --   

Memcached not installed on PHP 7.2 Extensions
Dhanya
Group: Softaculous Team
Post Group: Working Member
Posts: 166
Status:
Hi,

For enabling memcached in PHP73 you need to follow all the steps provided. Just need to replace php72 with php73.

Let us know if you have any further queries.
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is October 21, 2019, 10:03 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.954