Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > General Support > Topic : Apache suddenly doesn't start



Threaded Mode | Print  

 Apache suddenly doesn't start (5 Replies, Read 1437 times)
coldpumpkin
Group: Member
Post Group: Newbie
Posts: 2
Status:
Hello,

Running AMPPS 3.8 on Windows 10 x64.

When starting apache, it turns off a few seconds later. Yesterday it was working just fine.

Here's the log:

Code
[Sat Oct 13 22:10:49.684076 2018] [mpm_winnt:notice] [pid 11116:tid 824] AH00455: Apache/2.4.27 (Win32) OpenSSL/1.1.0f PHP/7.1.8 configured -- resuming normal operations
[Sat Oct 13 22:10:49.684076 2018] [mpm_winnt:notice] [pid 11116:tid 824] AH00456: Apache Lounge VC15 Server built: Jul  7 2017 11:43:51
[Sat Oct 13 22:10:49.684076 2018] [core:notice] [pid 11116:tid 824] AH00094: Command line: 'apache\\bin\\httpd.exe -d C:/Ampps/apache'
[Sat Oct 13 22:10:49.684076 2018] [mpm_winnt:notice] [pid 11116:tid 824] AH00418: Parent: Created child process 11644
[Sat Oct 13 22:10:54.793286 2018] [mpm_winnt:crit] [pid 11116:tid 824] AH00419: master_main: create child process failed. Exiting.

IP: --   

Apache suddenly doesn't start
Rishi_P
Group: AMPPS Team
Post Group: Elite Member
Posts: 317
Status:
Hi,

Did you update your Windows?
Temporary disable Ioncube Loader.

Change PHP version to 7.1 and Try this:

Open AMPPS panel --> PHP --> Configuration.

Search for the following line:
zend_extension="{$path}\php-7.1\ioncube_loader_win_7.1.dll"

Make it comment by adding ';' at the beginning of the line, like this:
;zend_extension="{$path}\php-7.1\ioncube_loader_win_7.1.dll"

Save the config and Restart Apache.

Let us know if you are still facing the same issue.
IP: --   

Apache suddenly doesn't start
bokeoke12
Group: Member
Post Group: Newbie
Posts: 2
Status:
I've the same issue since I installed the Windows update KB4462919. Does anyone have a solution?
IP: --   

Apache suddenly doesn't start
bokeoke12
Group: Member
Post Group: Newbie
Posts: 2
Status:
Quote From : Rishi_P October 16, 2018, 1:02 pm
Hi,

Did you update your Windows?
Temporary disable Ioncube Loader.

Change PHP version to 7.1 and Try this:

Open AMPPS panel --> PHP --> Configuration.

Search for the following line:
zend_extension="{$path}\php-7.1\ioncube_loader_win_7.1.dll"

Make it comment by adding ';' at the beginning of the line, like this:
;zend_extension="{$path}\php-7.1\ioncube_loader_win_7.1.dll"

Save the config and Restart Apache.

Let us know if you are still facing the same issue.


This works, thank you.
IP: --   

Apache suddenly doesn't start
coldpumpkin
Group: Member
Post Group: Newbie
Posts: 2
Status:
I also confirm it works. Thanks!
IP: --   

Apache suddenly doesn't start
xpincho
Group: Member
Post Group: Newbie
Posts: 1
Status:
Quote From : Rishi_P October 16, 2018, 1:02 pm
Hi,

Did you update your Windows?
Temporary disable Ioncube Loader.

Change PHP version to 7.1 and Try this:

Open AMPPS panel --> PHP --> Configuration.

Search for the following line:
zend_extension="{$path}\php-7.1\ioncube_loader_win_7.1.dll"

Make it comment by adding ';' at the beginning of the line, like this:
;zend_extension="{$path}\php-7.1\ioncube_loader_win_7.1.dll"

Save the config and Restart Apache.

Let us know if you are still facing the same issue.


Hi, I was facing the same problem, a few days ago, it wasnt starting, the same exact error, I didnt realize i updated windows about the same date... did what you said, and now it started fine, but
why the ioncubeloader is making the apache to stop, and more, what would be the correct solution, i mean, this solution of commenting the ioncubeloader solved the problem 'temporarily' but is limiting the functionality, there must be a solution that would make the apache able to load the ioncubeloader again normally... dont you think? thanks
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is December 13, 2018, 3:40 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.594