Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > General Support > Topic : Ampps and PHP 7

3


Threaded Mode | Print  

Ampps and PHP 7
PubDirLtd
Group: Member
Post Group: Working Newbie
Posts: 50
Status:

AMPPS 4.6.7 & PHP 5.6.9 on Win 7 Pro SP1 x64 4Gb server
Sorry, but no you haven't fixed it.

I have just installed 3.5 and all I get is 50x errors.

Looking for 3.5.1 soon I hope.

Terence.
IP: --   

Ampps and PHP 7
PubDirLtd
Group: Member
Post Group: Working Newbie
Posts: 50
Status:

AMPPS 4.6.7 & PHP 5.6.9 on Win 7 Pro SP1 x64 4Gb server
I managed to get it running only by giving up on getting PHP 7.x to run and returning mySQL, Apache and PHP to their default configurations, but now I see this when I try to upgrade a WordPress install..

"Required PHP version greater than equal to 5.2.4 AND found version is : Warning: PHP Startup: Unable to load dynamic library 'C:/Program Files (x86)/Ampps\php\ext\php_openssl.dll' - The operating system cannot run %1. in Unknown on line 05.6.17"
IP: --   

Ampps and PHP 7
Rishi_P
Group: AMPPS Team
Post Group: Elite Member
Posts: 317
Status:
Hi,

Please open support ticket here:
https://www.softaculous.com/support/
IP: --   

Ampps and PHP 7
php.tux
Group: Member
Post Group: Newbie
Posts: 6
Status:
Hey guys,

i installed Ampps v3.5 in openSuSe 13.1.
working fine.

But a will change th php version from 5.6 to 7.0.
OK. this is not problem.

The xdebug extension is NOT included for PHP 7.0.
Why?

Thx for answers
IP: --   

Ampps and PHP 7
php.tux
Group: Member
Post Group: Newbie
Posts: 6
Status:
i have self installed.

https://xdebug.org/docs/install
https://xdebug.org/docs/faq#api

:xd:
IP: --   

Ampps and PHP 7
KenScape
Group: Member
Post Group: Newbie
Posts: 5
Status:
php.tux: thx, that worked
IP: --   

Ampps and PHP 7
giambra
Group: Member
Post Group: Newbie
Posts: 1
Status:
Hi everybody,
I just installed Ampps  :D but.. I don't know how to configure the php.ini file  :??:
I have Ubuntu 15.04...
when I try to open the index.php file in my browser... suggest me to open it with a text editor  :-(
So... please... what can I do???
best reguards,
Stefano
IP: --   

Ampps and PHP 7
erickb
Group: Member
Post Group: Working Newbie
Posts: 78
Status:
when php7 is selected  it's impossible to start Apache
IP: --   

Ampps and PHP 7
erickb
Group: Member
Post Group: Working Newbie
Posts: 78
Status:
It doesn't work
will you fix that bug ?
impossible to use php7  Apache never start when php7 is on
IP: --   

Ampps and PHP 7
Rishi_P
Group: AMPPS Team
Post Group: Elite Member
Posts: 317
Status:
Hi,

This issue has been fixed.
If you are still facing the same issue then open support ticket here.

https://www.softaculous.com/support/
IP: --   

Ampps and PHP 7
Pussydestroyer
Group: Member
Post Group: Newbie
Posts: 1
Status:
Hey there; I am using a Mac and I've copied PHP 7.2.11 into the AMPPS folder, added the version to the php_versions file and restarted the Application. Now when I go from Control Center to PHP > Change PHP Version, the new added version won't show up. How to solve that? I am running Mac OSX Mojave
IP: --   

Ampps and PHP 7
Dalberon
Group: Member
Post Group: Newbie
Posts: 1
Status:
I have AMPPS 3.8 installed in Windows 10 professional.  PHP 7.1 came available for upgrade, but when I upgrade to it apache will not start. I thought I would try manually installing and using PHP 7.2, but the php_version file mentioned earlier in this thread is no longer present in version 3.8.

Everything works fine PHP 5.6 running, which is fine for the Propel ORM, but neither Symfony nor Laravel will work in it.  I've spent several hours trying to figure this out.
IP: --   

Ampps and PHP 7
liveaspankaj
Group: Member
Post Group: Newbie
Posts: 1
Status:
Thanks for the awesome software, its unbelievable that such a software is available and I am still using MAMP PRO on one of my machine. Was planing to buy another license when I bumped into AMPPS.

I am facing same issue as few others. I do not see php_versions and changing ampps/data/apps doesn't have any impact.

I would like to add PHP7.2 but not able to do it.
IP: --   

« Previous    Next »

Threaded Mode | Print  

3


Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is December 10, 2018, 6:34 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:1.084