Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > General Support > Topic : This site can’t be reached



Threaded Mode | Print  

 This site can’t be reached, Changed Apache port to avoid conflict & installed WordPress, but site unreachable. (6 Replies, Read 10588 times)
seezee
Group: Member
Post Group: Newbie
Posts: 4
Status:
System: OS X Yosemite
AMPPS: 4.6.7
PHP version: 5.6

Changes to Apache config: changed all port numbers to 8888 to avoid conflict w/ native Apache server

Installed WP at Applications-->AMPPS-->www-->mysite
Added domain mysite, enabled SSL

Go to localhost[port number]:8888/mysite, redirects to 127 DOT zero DOT zero DOT zero/mysite & all tested browsers say, "This site can’t be reached". Port number stripped on redirect.

Go to [htt ps://] localhost COLON 8888/mysite, browser throws "insecure" error. Overriding the warning results in 500 error.

Sorry about the mangled paths & URLs, but I'm new and not allowed to post links.
IP: --   

This site can’t be reached
Rishi_P
Group: AMPPS Team
Post Group: Elite Member
Posts: 317
Status:
Hi,

You also have to add port no. in your wordpress database.

Try this:

login to localhost:8888/phpmyadmin

Now go to your database and select wp_options

Add port number in your site url and home.

example:  change http://127.0.0.1:80/(your_website) to http://127.0.0.1:8888/(your_website).

We do not recommend you to change port number because every script from Softaculous panel will install on default port 80.

IP: --   

This site can’t be reached
seezee
Group: Member
Post Group: Newbie
Posts: 4
Status:
Quote From : Rishi_P July 30, 2016, 7:47 am
Hi,

You also have to add port no. in your wordpress database.

Try this:

login to localhost:8888/phpmyadmin

Now go to your database and select wp_options

Add port number in your site url and home.

example:  change http://127.0.0.1:80/(your_website) to http://127.0.0.1:8888/(your_website).

We do not recommend you to change port number because every script from Softaculous panel will install on default port 80.



I'll give that a shot. Any recommendation on either stopping the native OS X Apache server or changing its port so I can use 80 on AMPPS?
IP: --   

This site can’t be reached
Rishi_P
Group: AMPPS Team
Post Group: Elite Member
Posts: 317
Status:
Hi,

Open Terminal and run following commands:

sudo apachectl -k stop
sudo launchctl unload -w /System/Library/LaunchDaemons/org.apache.httpd.plist
IP: --   

This site can’t be reached
seezee
Group: Member
Post Group: Newbie
Posts: 4
Status:
OK, I tried both proposed solutions — I still got a refused connection after editing the database, even after restarting Apache & SQL. So I put the config files back to default & killed the native Apache server & restarted the AMPPS servers, still no joy. For some reason it appears AMPPS is still listening on port 8888; I can reach the http://localhost:8888/ampps/index.php?but not http://localhost/ampps/index.php?

What might be binding to that port? I'm positive the Apache config file is back to the default settings.
IP: --   

This site can’t be reached
seezee
Group: Member
Post Group: Newbie
Posts: 4
Status:
Never mind & thank you. I quit AMPPS, reopened it, and reopened the Apache config & saw that the port number had reverted. Edited it & all is working.
IP: --   

This site can’t be reached
cyton
Group: Member
Post Group: Newbie
Posts: 1
Status:
Board has been fixed for the tool and such issues for the people. The enhancement of the term and bestessay com is done for the sufficiency in the realm of the satisfaction of the clients to all fields of the world.
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is December 13, 2018, 4:07 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:1.784