Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > General Support > Topic : Install PHP-7.2

2


Threaded Mode | Print  

Install PHP-7.2
erickb
Group: Member
Post Group: Working Member
Posts: 102
Status:
Quote From : demanl July 17, 2019, 12:58 am
willing to pay for premium if I have to :)
same here , i find the free version too expensive :-)
IP: --   

Install PHP-7.2
swissdoode
Group: Member
Post Group: Newbie
Posts: 6
Status:
Well - the longer it takes, the more I think I'm gonna switch to MAMP…

Really too bad, I liked the way AMPPS works.
IP: --   

Install PHP-7.2
erickb
Group: Member
Post Group: Working Member
Posts: 102
Status:
i have already installed MAMP today
IP: --   

Install PHP-7.2
demanl
Group: Member
Post Group: Newbie
Posts: 5
Status:
holy cow...mamp for windows has php7.2....I'm trying that now. :)
IP: --   

Install PHP-7.2
erickb
Group: Member
Post Group: Working Member
Posts: 102
Status:
mamp has php7.3.1
IP: --   

Install PHP-7.2
demanl
Group: Member
Post Group: Newbie
Posts: 5
Status:
hello erickb,

mamp has php7.3......not the version for windows...only at 4.1....are you talking about the osx version ?
IP: --   

Install PHP-7.2
demanl
Group: Member
Post Group: Newbie
Posts: 5
Status:
damn,

too bad then....mamp responded with eta of mamp 5 for windows later this year or early next year....they win...they get my money :)
IP: --   

Install PHP-7.2
erickb
Group: Member
Post Group: Working Member
Posts: 102
Status:
yes I am on Mac

be careful because I have got some errors importing  databases  with datetime default  = 0

you have to create a MAMP/conf/my.cnf
with

[mysqld]
sql_mode = NO_ENGINE_SUBSTITUTION
IP: --   

Install PHP-7.2
usalabs
Group: Member
Post Group: Newbie
Posts: 3
Status:
My advice would be to dump AMPPS, as the devs have no intention of interacting with it's user base, and install WAMPServer, it has 5 PHP version to play with:-

5.6.40
7.0.33
7.1.26
7.2.14
7.3.1

And every version's ini file can be edited via a menu, there's no manual editing needed, even the PHP extensions can be checked/unchecked from a list of choices.

The only draw back, is that it doesn't have downloadable apps like AMPPS does, but it's simple to add a vhost and all using a browser based interface.
IP: --   

Install PHP-7.2
jrxpress
Group: Member
Post Group: Newbie
Posts: 4
Status:
exactly.. its sad that we had to let this great app go.. but I am already using MAMP Pro, for a while since the developers here has been ignoring us for a long time..
IP: --   

Install PHP-7.2
Kerfred
Group: Member
Post Group: Newbie
Posts: 3
Status:
I think this is definitively the end of AMPPS on MacOS.
MacOS 10.15 will drop the support of 32 bit applications. And it is scheduled for this week: https://www.zdnet.fr/pratique/comment-preparer-votre-mac-pour-macos-1015-catalina-39891669.htm

It is a shame that the Ampps team has left such a good software.
IP: --   

Install PHP-7.2
antztech
Group: Member
Post Group: Newbie
Posts: 5
Status:
To be honest I was trying the same and lost hope I made switchback to wampserver. I found ampps to be better for development but the lack of support for the current version of PHP forced my hands. I recommend a switch at this point no point in holding on to false hope.
IP: --   

Install PHP-7.2
usalabs
Group: Member
Post Group: Newbie
Posts: 3
Status:
Quote From : antztech October 31, 2019, 3:08 pm
To be honest I was trying the same and lost hope I made switchback to wampserver. I found ampps to be better for development but the lack of support for the current version of PHP forced my hands. I recommend a switch at this point no point in holding on to false hope.


I've dropped AMPPS altogether, and switched to wampserver, even though it doesn't have an install script for downloading and installing pre-defined apps, it's just a case of manually downloading the app, and manually installing it into wampserver, which is not for the inexperienced.

I only posted here, because as a member I have email notifications sent when someone posts.
IP: --   

Install PHP-7.3 VC15 Manually
4VL13N
Group: Member
Post Group: Newbie
Posts: 1
Status:
WARNING: This is untested, I am not a developer for AMPPS or Softalicious! I'm just a guy who gets along better with computers than humans. Follow these instructions at your own risk!
You will need to know your way around a good text editor to do some of this, and knowing how Apache and PHP configuration files work will be a definite plus. In the example I give, I'm installing PHP 7.3 VC15. If you're just going up to 7.2, adjust your folders/paths accordingly so you aren't confused later. Also, do not use the
Code
php.ini-development
file if you are in a production environment (if you don't know not to, then you shouldn't be in a production environment anyway).


I fired up ye trusty ole Process Monitor to figure out how the AAMPS front end switched PHP versions. It just runs
Code
php -c {path to appropriate PHP.ini}
to point Apache httpd to the new version. That should be sufficient to do the same for 7.2, or even 7.3.

Just go to the Windows VC15 x64 Thread Safe PHP download page, or run
Code
choco install php --package-parameters='"/ThreadSafe ""/InstallDir:C:\Ampps\php-7.3-ts-VC15"""'
if you have Chocolatey and you're on Windows. If you're on Mac OS, using Homebrew is probably going to be the move to make.

A couple of things:
  1. You need the "threadsafe" version of PHP
  2. You will probably need the 64-bit version unless you are on ancient (or very very small) hardware.
  3. You will need to duplicate the
    Code
    php.ini-development
    file
    and delete the
    Code
    -development
    part from the filename so you get
    Code
    php.ini
    . You will probably also need to modify it to accommodate changes that you, AAMPS, or installed apps, have made made to the one on your server. I used WinMerge to compare them and make the necessary adjustments. Really the big things to check are the extensions and the paths.
  4. You will also need to manually add some extensions. Specifically, XDebugXDebug and the IonCube LoaderIoncube loader (you don't technically need XDebug, but it might make AMPPS mad if you don't have it). It is important to download the ones that match the version of PHP you are installing exactly. Without IonCube, it's possible nothing will work since it "decodes" the obfuscated PHP the AMPPS front end runs on.
  5. Decompress the
    Code
    .dll
    file for XDebug to the
    Code
    ...\lib
    directory under the PHP folder you are using
    (mine is
    Code
    C:\Ampps\php-7.3.11-VC15\lib\
    ) and decompress the
    Code
    ioncube_loader_win_7.3.dll
    . Be sure to add the following lines to your
    Code
    php-7.3.ini
    Code
    ;IonCube Loader zend_extension="{$path}\php-7.3-VC15\ioncube_loader_win_7.1.dll" ;Xdebug zend_extension="{$path}\php-7.3-VC15\lib\php_xdebug.dll"
    just above the
    Code
    Dynamic Extensions
    section

After you have done all that, it should be a simple matter of running the following command in a terminal window:
Code
C:\Ampps\php-7.3-VC15\php.exe  -c C:\Ampps\php-7.3\php.ini C:\Ampps\ampps\softaculous\enduser\main\ampps\server_config.php web_server=apache php=php73 db_server=mysql




Now, having said all that, [b]I have not tested this
yet. It may not work, but it won't permanently break anything. You should be able to just go into AMPPS settings and click one of the other PHP (5.6/7.1) buttons and everything be back the way it was. You might also be able to hack one of these buttons to switch to 7.3, but I'll see about that later.

P.S.: I was trying to be helpful and link all of the downloads, but I'm new on this forum so no dice. Sorry, LMGTFY...
IP: --   

« Previous    Next »

Threaded Mode | Print  

2


Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is November 21, 2019, 8:48 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:3.226