Softaculous <![CDATA[Virtualizor 3.0.5 Launched Patch 3 & 4 (Stable)]]>
The Virtualizor Team has released Virtualizor 3.0.5 (Patch 3 & 4) (Stable)
In this version we have some bug fixes and improvements. Here is the complete change list:

========== Patch 3 ==========1 . [Bugfix] Bandwidth Graph was showing 0% for usage between 0% and 1%. This is fixed and will now show in decimal as well.

2. [Bugfix] While editing the burst RAM for VZO containers, it was not taking effect on containers. This is fixed.

3. [Bugfix] On List IPs page in Admin panel multi select operation was not performed correctly. This is fixed.

4. [Bugfix] Search was not working for List Servers on Admin panel if searched for the virtualization type like proxmox Qemu/LXC, Virtuozzo KVM/LXC/OpenVZ. This is fixed.

5. [Bugfix] While editing the Email Template from Admin Panel it was giving error as “You can not edit email template from slave server”. This is fixed.

6. [Bugfix] While deleting the Backup manually from Admin Panel it was not deleting the secondary disk backups (If any). This is fixed.

7. [Bugfix] IPv6 and IPv6 Subnet count was not deducted properly for cloud users. This is fixed.

8. [Bugfix] If file integrity check failed to determine the size at that time backup file was not getting deleted. Now it will delete the backup file.

9. [Bugfix] sfdisk utility was getting updated on OS update and due to that Virtualizor was not able to resize the VMs (This was happening on Ubuntu 16+ and CentOS 7+). This is fixed.

10. [Bugfix] Task log retention was not working. This is fixed.

11. [Bugfix] Format Primary Disk option was not showing up if the Master server is Openvz Or Master Only. This is fixed.

12. [Bugfix] Temporary backup files for VZO containers was not getting deleted. This is fixed.

13. [Bugfix] Only single backup information was provided in response for List Backup API call, even though there were multiple backups for the VMs. This is fixed.

14. [Bugfix] On Master setting page in Admin panel if any setting value contained a single quote (‘) then it was not working. This is fixed.

15. [Bugfix] Socket setting for CPU was not applied in CPU topology for Proxmox Qemu VM(s). This is fixed.

16. [Bugfix] IO Limit saved in backup plan was not applied for Backup restore operation. This is fixed.

17. [Task] Bandwidth graphs improved to understand it better on Admin panel -> Bandwidth page.

18. [Task] Bandwidth Graph Legends improved on admin panel dashboard.

19. [Task] Improved Migrate Master utility to avoid issues in VM management.

20. [Task] PHPMailer library is updated to latest version.
NOTE: For windows mailservers NTLM authentication will not work from this version. As PHPmailer has removed support for this.

21. [Task] Added List / Add SSH Keys API call in Admin SDK.
Here are the link for Admin API :

22. [Task] Added option to search by Ippool ID on IPranges page in Admin panel.

23. [Task] Sparse flag added for restore operation for thin storages.

24. [Task] Now Virtualizor will not create a VM while restoring to New VM. This will improve the restore process time by 50% and will save node IO.

25. [Feature] Added option to add SSH Key for a VM from Admin panel -> VPS Manage page.

26. [Feature] Server Selection Preference option added on Server group page and Master Setting for VM creation. By default first come first serve algorithm will be applied. If Server Group has the preference then it will be the first priority over Master setting preference.
Here is the guide for it :

27. [Feature] Added search option for Subuser of a Cloud user in SDK function users().
Here is the guide for it :

28. [Feature] Added Template creation for File base VM.

=========== Patch 4 ==========

29. [Bugfix] While adding VPS Plan for Proxmox LXC it was giving error as invalid disk bus driver. This is fixed.

30. [Task] Spanish Language translation updated.

31. [Task] Error handling improved while searching IP in firewall wizard.

32. [Task] PDNS server can not be added or managed from slave servers. Added restriction for that.

33. [Task] API functionality was not available for Import VMs wizard. Here is the guide for that :

For complete list of changes please visit the following link :

Please let us know if you face any issues / have any suggestion. We are available on Virtualizor live chat at

Virtualizor Team]]>
Mon, 18 Jan 2021 10:12:27 GMT
<![CDATA[Suitable disk parititon config]]> New to virtualizor and wanted to know good park config which can work with the below  dedi

Hetzner EX62Nvme
2x1Tb Nvme

When install this was the partition done
/PART swap swap 8G
/PART /boot ext3 512M
/PART /home ext4 100G
/PART /storage ext4 all

Tried to install Virtualizor with proxmox

When tried to initialize the VPS, it will give me an error
QEMU : File Convert Error There was an error while reinstalling the OS]]>
Sun, 17 Jan 2021 13:32:31 GMT
<![CDATA[using php in html doc]]> <?php
    echo "Hello Word";

I executed my code in  localhost/test.html    But the browser displays nothing.
I viewed source of the display and found that the browser had commented out the php code by doing this:

  echo "Hello world";
Sun, 17 Jan 2021 05:01:32 GMT
<![CDATA[Clarification of Softaculous installation location?]]>
I deleted my unzipped files & re-attempted the installation from the softaculous web page. That completed fine with two oddities.

PHP 5.5.9 was displayed (suggesting softaculous detected that version or requires it?)
ionCube Loader was not installed which is apparently a known issue (read about it before experiencing it).

ionCube website appears to require purchase/licensing, but prior to successfully installing something to try out (will I be successful or actually move installed packages to web hosting from local server 'simulation'? There was an ionCubeLoader link that bypassed the purchase/licensing but it appeared to be only for web hosting server installations. Is there a way to complete the softaculous installation, or do I even need the ionCube portion for a local installation?

Thank you]]>
Sun, 17 Jan 2021 01:42:55 GMT
<![CDATA[Clarification of Softaculous installation location?]]>
It checked for several PHP versions ranging from 5.x thru perhaps 7.1 or 7.2.

I had installed XAMPP with PHP 7.4 compatibility based on a host server I need to keep in mind for future 'live' installation.

The checks for version followed specific install paths, and none were as high as PHP 7.4.

Maybe minimum AND maximum requirements apply ;O) ]]>
Sat, 16 Jan 2021 21:12:48 GMT
<![CDATA[Cost per host + License or just License?]]>
This is solved.. I am trying a trial and it's working, no need for me to pay the host on top of. ]]>
Sat, 16 Jan 2021 19:00:43 GMT
<![CDATA[Error 500's]]>
How do I see the dependencies of these scripts?

Or an error log or what the issue is? I tried this form AEF, same deal error 500.

I assume it needs an older version of PHP or something is missing?

Sat, 16 Jan 2021 18:59:54 GMT
<![CDATA[Clarification of Softaculous installation location?]]> Sat, 16 Jan 2021 18:16:06 GMT <![CDATA[Clarification of Softaculous installation location?]]> Can't post a response as a an attachment only (empty message).
Try again.]]>
Sat, 16 Jan 2021 18:13:58 GMT
<![CDATA[Clarification of Softaculous installation location?]]>
I used Softaculous years ago as part of a web hosting package I no longer have. I found the server-side installation more productive (for me) than the Demo mode.

I am currently trying to set up local installations of XAMPP on both Windows 7 and Linux/Ubuntu (18.04?), eventually to set up piwigo.

A lot of steps and learning at each one. I have some challenges with piwigo direct installation on both OS platforms, so I thought I'd try the Softaculous installation.

I did download a Softaculous installation package. I assume but am not certain whether it belongs in a local PC environment (XAMPP localhost?) or is for installation on remote hosting servers that don't have it as a standard feature.

With all the installations I have been doing I may have overlooked installation instructions for Softaculous. But I think understanding the context of what environment it's intended for might be a more important question.

I am not sure what 'version' of the softaculous zip package was, but will attempt a screenshot upload of what was inside the unzipped package...that may make it obvious to someone what I downloaded.

Thank you  ]]>
Sat, 16 Jan 2021 18:10:36 GMT