Softaculous


Topic : Webuzo stops working after reboot


Posted By: em0ne on July 19, 2019, 7:19 am
Webuzo stops working on Ubuntu 18.04 after EVERY reboot.
It doesn't matter if I run it with the LAMP or LEMP stack.

It works again after "service webuzo restart".

Also my domain names can no longer reach the correct sites after reboot. I have no idea why.

Posted By: em0ne on July 19, 2019, 9:06 am | Post: 1
My websites can be reached again after I restart nginx.

Is there a way I can set my server to restart Webuzo and Nginx automatically after a reboot? Why is this not happening by default?

I haven't checked the ftpd server yet but I am guessing it might be also down..

Posted By: Dhanya on July 19, 2019, 12:10 pm | Post: 2
Hi,

You can try the following method for restarting the Webuzo service on reboot:
1. Rename the /etc/init.d/webuzo file on your server using the following command as root:
mv /etc/init.d/webuzo /etc/init.d/webuzo_bak

2. Edit the following file existing on your server:
/etc/systemd/system/webuzo.service

3. Replace the following in the opened file:
ExecStart=/etc/init.d/webuzo start
ExecStop=/etc/init.d/webuzo stop
ExecReload=/etc/init.d/webuzo restart

with:

ExecStart=/usr/local/webuzo/conf/webuzo/emps/emps start
ExecStop=/usr/local/webuzo/conf/webuzo/emps/emps stop
ExecReload=/usr/local/webuzo/conf/webuzo/emps/emps restart

4. Once done, save the file and then execute the following command as root:
systemctl enable webuzo

For restarting Nginx on Reboot you can try the following solution:
sudo systemctl unmask nginx.service
sudo systemctl enable nginx

Let us know if you still face the issue after rebooting the server.

Powered By AEF 1.0.8 © 2007-2008 Electron Inc.