Welcome Guest. Please Login or Register  


You are here: Index > Virtualizor - Virtual Server Control Panel > Suggestions > Topic : Update PHP !

2


Threaded Mode | Print  

Update PHP !
tcivhm
Group: Member
Post Group: Newbie
Posts: 4
Status:
After we reconfigured the ioncube-loader 5.3.so file and restarted the fpmctl service we got back to the blank page (no login shows up on port 4085)
in the php-fpm.log file we got the following error:
[27-Oct-2021 11:40:42] WARNING: [pool index] child 3036 said into stderr: "NOTICE: PHP message: PHP Fatal error:  The file /usr/local/virtualizor/main/functions.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later."
[27-Oct-2021 11:09:42] WARNING: [pool index] child 3036 said into stderr: " Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0"

IP: --   

Update PHP !
jevingala
Group: Virtualizor Team
Post Group: Super Member
Posts: 653
Status:
Hi,


You can open a support ticket so that we can access your server and manually update panel and EMPs.

https://softaculous.deskuss.com/open.php?topicId=2

-----------------------
Regards,
Virtualizor Team.
http://virtualizor.com/
IP: --   

Update PHP !
jevingala
Group: Virtualizor Team
Post Group: Super Member
Posts: 653
Status:
.

Edited by jevingala : October 27, 2021, 9:48 am

-----------------------
Regards,
Virtualizor Team.
http://virtualizor.com/
IP: --   

Update PHP !
chirag
Group: Virtualizor Team
Post Group: Elite Member
Posts: 396
Status:
Quote From : tcivhm October 27, 2021, 9:45 am
After we reconfigured the ioncube-loader 5.3.so file and restarted the fpmctl service we got back to the blank page (no login shows up on port 4085)
in the php-fpm.log file we got the following error:
[27-Oct-2021 11:40:42] WARNING: [pool index] child 3036 said into stderr: "NOTICE: PHP message: PHP Fatal error:  The file /usr/local/virtualizor/main/functions.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later."
[27-Oct-2021 11:09:42] WARNING: [pool index] child 3036 said into stderr: " Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0"


You changed the file which is included in virtualizor setup?If so then you might face issues.We have named it as 5.3 but its the latest version ioncube which works fine with the updated php version.
Please open support ticket so that we can check on your server asap.

-----------------------
Virtualizor - VPS Control Panel
Follow us on Facebook
IP: --   

Update PHP !
tcivhm
Group: Member
Post Group: Newbie
Posts: 4
Status:
Quote From : chirag October 27, 2021, 3:56 pm
Quote From : tcivhm October 27, 2021, 9:45 am
After we reconfigured the ioncube-loader 5.3.so file and restarted the fpmctl service we got back to the blank page (no login shows up on port 4085)
in the php-fpm.log file we got the following error:
[27-Oct-2021 11:40:42] WARNING: [pool index] child 3036 said into stderr: "NOTICE: PHP message: PHP Fatal error:  The file /usr/local/virtualizor/main/functions.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later."
[27-Oct-2021 11:09:42] WARNING: [pool index] child 3036 said into stderr: " Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0"


You changed the file which is included in virtualizor setup?If so then you might face issues.We have named it as 5.3 but its the latest version ioncube which works fine with the updated php version.
Please open support ticket so that we can check on your server asap.

No, no the system is a running System, which is running since over 500 days. I think the bug appears since the last virtualizor update.

I downloaded the latest pakage of ioncube loader files from their website und just copied the .so to the right directoy. (it was /usr/local/emps/lib/php or something like that i guess. There was already the ioncube loader 5.3.so file.

after that we just edited the active php.ini somewhere inside the emps folder. After the test failed, we changed everything back to "default"
IP: --   

Update PHP !
chirag
Group: Virtualizor Team
Post Group: Elite Member
Posts: 396
Status:
Hi,

Please open the ticket and we will check this on your server.

Let us know for further information.

-----------------------
Virtualizor - VPS Control Panel
Follow us on Facebook
IP: --   

Update PHP !
tcivhm
Group: Member
Post Group: Newbie
Posts: 4
Status:
Quote From : chirag October 29, 2021, 9:39 am
Hi,

Please open the ticket and we will check this on your server.

Let us know for further information.

Unfortunately we bought a lifetime license for this system and the support ran out a few months ago..
BUT, i was able to fix the problem. The PHP Scripts where not up to date (still encoded for ioncube loader 5.6) but php incl. ioncubeloader was updated to 7.1.

Luckily i got a running Server with the current version of everything, so i was able to replace all the php files and got the interface back up :)
IP: --   

« Previous    Next »

Threaded Mode | Print  

2


Jump To :


Users viewing this topic
8 guests, 0 users.


All times are GMT. The time now is December 4, 2021, 7:17 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:4.507