Welcome Guest. Please Login or Register  


You are here: Index > SitePad Website Builder > General Support > Topic : "Error establishing a database connection" Error



Threaded Mode | Print  

 "Error establishing a database connection" Error, Can't edit or visit sites anymore (2 Replies, Read 1728 times)
John_H2O
Group: Member
Post Group: Newbie
Posts: 4
Status:
Hello - I deleted the MySQL databases for my two SitePad sites because I did
not know they belonged to the sites.  Afterward I discovered that. 
After completing a database restore for both sites, despite that the
databases are restored and present again there is no way to edit or
visit the sites.  All attempts to visit the sites and edit them only
result in the "Error establishing a database connection" message.  How can I
reenable the database connection to the restored databases?  The sites
are hosted at a hosting service that uses cPanel with Softaculous.  That's a pretty serious limitation if it's impossible to connect to a database if it ever has to be restored for some reason, so I'm sure hoping there's a simple remedy. 
Thanks.
IP: --   

"Error establishing a database connection" Error
John_H2O
Group: Member
Post Group: Newbie
Posts: 4
Status:
Progress:
Okay, if anyone ever experiences this after losing a db with a SitePad site, this just worked for one of them:
You have to go back the MySQL databases area in cPanel and add the appropriate User to the db.  In this case, the User has the same name as the db.  After that, you get this crazy url for your site if you try to visit it:

https : // example . com /site-admin/install.php

At that point you may be thinking - still doesn't work.  But then you go back to the SitePad backup restore area and do a full restore for the site again.  The result was a success message:

"The backup was restored successfully."
The site now loads normally as before.
I will now try it for the other one and if there is any issue will mention it here.
                       



IP: --   

"Error establishing a database connection" Error
John_H2O
Group: Member
Post Group: Newbie
Posts: 4
Status:
Okay that worked with the second one too.
I granted the users "all privileges" for the DBs when adding them.
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
3 guests, 0 users.


All times are GMT. The time now is October 15, 2021, 11:42 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.256