Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > General Support > Topic : AMPPS 3.9 issues workarounds on macOS Catalina



Threaded Mode | Print  

 AMPPS 3.9 issues workarounds on macOS Catalina, workarounds for running AMPPS 3.9 and managing domaines (1 Replies, Read 382 times)
xtramo
Group: Member
Post Group: Newbie
Posts: 1
Status:
:xd:  :xd: The order of the issues may differ dependent on the user behaviour 
First Issue: trying to stop/start/restart Apache throws this error
Code

httpd (no pid file) not running

this error basically prevent you from stopping or restarting Apache from AMPPS UI,
cd to Apache bin folder and run the stop command to view the error.
Code
/Applications/Ampps/apache/bin

Code
sudo ./apachectl -k stop

Solution
to solve this error go to Apache bin folder and edit the file :
Code
/Applications/Ampps/apache/bin/apachectl


replace the line :
Code
ULIMIT_MAX_FILES="ulimit -S -n `ulimit -H -n`"

to this :
Code
ULIMIT_MAX_FILES=""


Second Issue : Domaine Management not working Or Apache not starting/stoping/restarting after a new domaine is added

this error is samply a syntax error when the file httpd-vhosts.conf is generated, so the solution is to fix the error every time you add some new domaine until an official fix is done.

running the command to stop the server throw something like :
Code
./apachectl: line 80: ulimit: open files: cannot modify limit: Invalid argument
AH00526: Syntax error on line 5 of /Applications/AMPPS/apache/conf/extra/httpd-vhosts.conf:
Cannot define multiple Listeners on the same IP:port


Solution

just delete the parts you dont need and keep the VirtualHost config
in my case I had to delete the hole SSL config  (not interested in running ssl on my local ;) )

deleted this
Code

###############################
######## Enable SSL ###########
<IfModule ssl_module>
Listen 443
AddType application/x-x509-ca-cert.crt
AddType application/x-pkcs7-crl.crl
SSLPassPhraseDialog  builtin
SSLSessionCacheTimeout  300
<IfModule socache_shmcb_module>
SSLSessionCache "shmcb:/Applications/Ampps/apache/logs/ssl_scache(512000)"
</IfModule>

Mutex default
</IfModule>
###############################

#### Localhost SSL Entries ####
<IfModule ssl_module>
<VirtualHost _default_:443>
<Directory "/Applications/Ampps/www">
    Options FollowSymLinks Indexes
    AllowOverride All
    Order deny,allow
    allow from All
</Directory>
ServerName localhost
ServerAlias localhost
ScriptAlias /cgi-bin/ "/Applications/Ampps/www/cgi-bin/"
DocumentRoot "/Applications/Ampps/www"
SSLEngine on
SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL
SSLCertificateFile "/Applications/Ampps/apache/conf/ssl_crt/server.crt"
SSLCertificateKeyFile "/Applications/Ampps/apache/conf/ssl_key/server.key"
ErrorLog "/Applications/Ampps/apache/logs/ssl_error.log"
TransferLog "/Applications/Ampps/apache/logs/ssl_access.log"
<FilesMatch "\.(cgi|shtml|phtml|php)$">
    SSLOptions +StdEnvVars
</FilesMatch>
<Directory "/cgi-bin/">
    SSLOptions +StdEnvVars
</Directory>
BrowserMatch ".*MSIE.*" \
        nokeepalive ssl-unclean-shutdown \
        downgrade-1.0 force-response-1.0
CustomLog "/Applications/Ampps/apache/logs/ssl_request.log" \
          "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"
</VirtualHost>
</IfModule>
##############################


Hope this helps someone  :xd:
IP: --   

AMPPS 3.9 issues workarounds on macOS Catalina
isuke
Group: Member
Post Group: Newbie
Posts: 1
Status:
I just login to say

!!!!!  THANKS YOU SO MUCH !!!!!!

BTW.
Actually I faced this issue on macOS Mojave 10.14.6

One more issue.
Settings won't work, if you click this icon fore.g mysql settings, nothing is happening.
And to fix this issue, is simply open ampps settings and set default text editor and save settings.
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is January 23, 2020, 10:56 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.123