Welcome Guest. Please Login or Register  


You are here: Index > Virtualizor - Virtual Server Control Panel > General Support > Topic : Problem creating containers



Threaded Mode | Print  

 Problem creating containers (2 Replies, Read 751 times)
j-m-host
Group: Member
Post Group: Newbie
Posts: 2
Status:
Hi,
I'm having issues creating openvz containers on virtualizor / openvz7. No matter what os I pick I get
Code
Failed to register the CT: PRL_ERR_VZCTL_OPERATION_FAILED (Details: Failed to read /vz/private/3ed73264-6029-4640-b1c0-3e59e635354a.private_temporary/root.hdd/DiskDescriptor.xml: Error in ploop_open_dd (di.c:363): Can't resolve /vz/private/3ed73264-6029-4640-b1c0-3e59e635354a.private_temporary/root.hdd/DiskDescriptor.xml: No such file or directoryCreation of Container private area failed
This is obviously a ploop issue. Adding VE_LAYOUT=simfs to /etc/vz/vz.conf changes nothing. Unchecking ploop under Master Settings also changes nothing. I'd much rather use simfs but it doesn't seem to honor any setting I've tried and I'd like to know why ploop is broken as well. The drive was formatted correctly...
Code
Filesystem                      Type    1K-blocks    Used Available Use% Mounted on
/dev/mapper/openvz_customer-root ext4      65924652 3956032  58596796  7% /
devtmpfs                        devtmpfs  16325968      0  16325968  0% /dev
tmpfs                            tmpfs    16338096      0  16338096  0% /dev/shm
tmpfs                            tmpfs    16338096    9868  16328228  1% /run
tmpfs                            tmpfs    16338096      0  16338096  0% /sys/fs/cgroup
tmpfs                            tmpfs      524288      4    524284  1% /tmp
/dev/sda2                        ext4        999320  122304    808204  14% /boot
/dev/mapper/openvz_customer-vz  ext4    878015288  812640 832578776  1% /vz
tmpfs                            tmpfs      3267620      0  3267620  0% /run/user/0

This is a fresh install of OpenVZ7 from the ISO. Does anyone have any idea why I am facing these issues?
IP: --   

Problem creating containers
j-m-host
Group: Member
Post Group: Newbie
Posts: 2
Status:
Ok after 2 days of trying everything I could, I figured it out.
1) You have to change VEFSTYPE to simfs in /etc/vz/vz.conf to use simfs. Virtualizor seems to ignore it's ploop setting on OVZ7 (which is not very user friendly...). But maybe this is for good reason as I just got errors about the OS template cache being in an invalid format when I tried to force simfs so nevermind.
2) The ploop error was caused by /tmp being mounted as a temporary file system that is too small to support the the disk image... and possibly the other hardening mount flags I had set. Removing the mount from fstab fixed the error.

Having fixed the ploop error and learning that simfs in OVZ7 doesn't support second level quota's, I guess I'll just stick with ploop and go heavy on the backups just in case.
Hope this helps someone down the line.
IP: --   

Problem creating containers
zudyra
Group: Member
Post Group: Newbie
Posts: 1
Status:
Soft Aculous is supporting us in all humble ways. Please tell me how can I thank you with help of https://icasinoreviews.info/1-dollar-deposit-casinos/ for all prospective challenges. I'm considering myself overjoyed due to use of this post.
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is June 26, 2019, 6:25 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.183