Welcome Guest. Please Login or Register  


You are here: Index > Virtualizor - Virtual Server Control Panel > General Support > Topic : libvirt issue: read vm that already deleted



Threaded Mode | Print  

 libvirt issue: read vm that already deleted, libvirt issue: read vm that already deleted (2 Replies, Read 613 times)
hendranata
Group: NOC
Post Group: Newbie
Posts: 23
Status:
helo
i have strange issue with one of my virtualizor server.
i am running centos 7 64bit + virtualizor with libvirt version is: 3.9.0

i check from /var/log/messages

PHP Code

 Apr  1 12:32:09 iix-server-3 libvirtd2019-04-01 05:32:09.971+00001502error virNetSocketReadWire:1808 End of file while reading dataInput/output error 



always got that message.. but seems that error message is normal since all my server virtualizor also got that message as well ..


but the strange issue is here..
when create new vps.. and delete that vps.
seems libvirt still try to open the existing VPS. (actually delete already).

and here is the sample error log:
PHP Code

 Apr  1 11:56:10 iix-server-3 libvirtd2019-04-01 04:56:10.890+00001517error qemuOpenFileAs:3234 Failed to open file '/dev/vg_hdd/vsv2281-dy2yjyd1yeylqwwp-ytw1brwl93bqvcuq'No such file or directory 



do u know why? until now i dont have any idea how to solved that


Edited by hendranata : April 1, 2019, 5:53 am
IP: --   

libvirt issue: read vm that already deleted
hendranata
Group: NOC
Post Group: Newbie
Posts: 23
Status:
also i check here : /var/lib/libvirt/qemu/

PHP Code

 [root@iix-server-3 qemu]# ls -la | grep 2281
drwxr-x---   2 qemu qemu  4096 Mar 14 21:51 domain-136-v2281 


exist there. actually already deleted
i still dont understand why.

i am trying to move that folder domain-136-v2281 to another folder..no luck the error message libvirt seems still looking for vm v2281 with error message .


i check using virsh command.

PHP Code

 [root@iix-server-3 qemu]# virsh dumpxml --domain v2281
<domain type='kvm'>
  <
name>v2281</name>
  <
uuid>801074de-656c-4bfb-abb0-0f8e9158849a</uuid>
  <
memory unit='KiB'>2572288</memory>
  <
currentMemory unit='KiB'>2572288</currentMemory>
  <
vcpu placement='static'>1</vcpu>
  <
cputune>
    <
shares>1024</shares>
  </
cputune



surprisingly ..they showing the xml.. hemm..
i check /etc/libvirt/qemu/... nothing v2281.xml there..


Edited by hendranata : April 1, 2019, 7:13 am
IP: --   

libvirt issue: read vm that already deleted
hendranata
Group: NOC
Post Group: Newbie
Posts: 23
Status:
if i turn off the vps first and next delete it, yes seems okay..
but if the vps is on and delete it, seems virtlib still looking that deleted vm.

a bit funny..

in this case, do i need to run:
virsh undefine --domain v2281 ??

appreciate anyone can help me
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is December 9, 2019, 10:25 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.130