Welcome Guest. Please Login or Register  


You are here: Index > SitePad Website Builder > General Support > Topic : SitePad stopped working in cPanel version 76



Threaded Mode | Print  

 SitePad stopped working in cPanel version 76, PHP Fatal error: The file /usr/local/sitepad/www/index.live.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later. (1 Replies, Read 1425 times)
cPJasonB
Group: Member
Post Group: Newbie
Posts: 1
Status:
cPanel version 76 uses PHP 7.1 and upon updating to version 76, users see the following error:
================================
Child failed to make LIVEAPI connection to cPanel
================================
Here is the full error from the log:
================================
PS1# tail -n0 -f /usr/local/cpanel/logs/error_log
PHP Fatal error:  The file /usr/local/sitepad/www/index.live.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.
Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0
[2018-10-26 $TIME +0000] die [Internal Death while parsing [live php] 23237] Child failed to make LIVEAPI connection to cPanel from: ./3rdparty/sitepad/index.live.php. at cpanel.pl line 4271.
at cpanel.pl line 4271.
    cpanel::cpanel::setup_external_engine() called at cpanel.pl line 801
    cpanel::cpanel::script("cpanel::cpanel", "./3rdparty/sitepad/index.live.php") called at cpanel.pl line 267


Child failed to make LIVEAPI connection to cPanel from: ./3rdparty/sitepad/index.live.php. at cpanel.pl line 4271.
[2018-10-26 $TIME +0000] warn [cpaneld] The subprocess ( (cpanel)) exited with an error: The subprocess reported error number 255 when it ended. at /usr/local/cpanel/Cpanel/Server/Handlers/SubProcess.pm line 251.
    Cpanel::Server::Handlers::SubProcess::_report_subprocess_errors(Cpanel::Server::Handlers::SubProcess=HASH(0x26abb18)) called at /usr/local/cpanel/Cpanel/Server/Handlers/SubProcess.pm line 109
    Cpanel::Server::Handlers::SubProcess::handler(Cpanel::Server::Handlers::SubProcess=HASH(0x26abb18), "subprocess_name", " (cpanel)", "subprocess_read_handle", GLOB(0x$numbers), "subprocess_write_handle", GLOB(0x$morenumbers), "subprocess_pid_to_reap", ...) called at cpsrvd.pl line 7012
    cpanel::cpsrvd::cpHandler("document", "./3rdparty/sitepad/index.live.php") called at cpsrvd.pl line 2683
    cpanel::cpsrvd::dodoc_cpaneld() called at cpsrvd.pl line 1817
    cpanel::cpsrvd::dodoc(HASH(0x$numbers)) called at cpsrvd.pl line 1569
    cpanel::cpsrvd::handle_one_connection(5) called at cpsrvd.pl line 989
    cpanel::cpsrvd::script() called at cpsrvd.pl line 336
================================
This relates to this post: /index.php?tid=14606&title=Encoding_issue_with_Softaculous_on_cPanel_76
But is for SitePad.
IP: --   

SitePad stopped working in cPanel version 76
aakash_softac
Group: Softaculous Team
Post Group: Elite Member
Posts: 314
Status:
Hi,

We had fixed this issue in SitePad 1.1.1 which was released a few days back. If you had disabled auto-update for SitePad this could be possible.

Re-installing SitePad should resolve the issue :
http://sitepad.com/wiki/Reinstall

Do let us know if you still face the issue.

-----------------------
Aakash Gupta
SitePad Developer

Follow us for faster updates
Twitter: https://twitter.com/sitepad_editor
Facebook: https://facebook.com/SitePad
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is December 12, 2018, 4:37 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.228