Welcome Guest. Please Login or Register  


You are here: Index > Virtualizor - Virtual Server Control Panel > General Support > Topic : Config and Routing of Subnet in Virtualizor



Threaded Mode | Print  

 Config and Routing of Subnet in Virtualizor, Config and Routing of Subnet in Virtualizor (6 Replies, Read 6522 times)
svenhege
Group: Member
Post Group: Newbie
Posts: 3
Status:
Hello!

We have an installtion of virtualizor 0n a Hetzner Server with KVM. We have with this server 3 single Ip´s and a /28 Subnet. The single ips are working when setting up a vm. The internet access does not work for the subnet. We have the subnet gw configured and the new VM gets the config which is ussually correct. The internet does not work!

Any suggestions?

Regards Sven
IP: --   

Config and Routing of Subnet in Virtualizor
jevingala
Group: Virtualizor Team
Post Group: Elite Member
Posts: 333
Status:
Hi,

Since you are facing issue to configure hetzner ip subnet you can check this guide and follow the instructions :

http://virtualizor.com/wiki/NAT

Please let us know if you still face any issues.



-----------------------
Regards,
Virtualizor Team.
http://virtualizor.com/
IP: --   

Config and Routing of Subnet in Virtualizor
thornz
Group: Member
Post Group: Newbie
Posts: 4
Status:
Hi, i got a Ded from hetzner i have done what this page is said http://www.virtualizor.com/wiki/NAT.

But my ips not reachable i cant access internet from my vms.

i have used one usable add ip gateway for my vms.

Here is the my config

/etc/sysconfig/network-scripts/ifcfg-viifbr0

DEVICE=viifbr0
BOOTPROTO=none
ONBOOT=yes
HWADDR=08:60:6E:46:FB:46
IPADDR=144.76.56.xx ---> main ip addres
NETMASK=255.255.255.224
SCOPE="peer 144.76.56.xx" ---> main gateway

/etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
BOOTPROTO=none
ONBOOT=yes
HWADDR=08:60:6E:46:FB:xx ---> main mac addres
BRIDGE=viifbr0

now we use the first usable ip as gateway for VMs

/etc/sysconfig/network-scripts/ifcfg-viifbr0:1

DEVICE=viifbr0:1
TYPE=Bridge
BOOTPROTO=static
IPADDR=136.243.212.xx ---> main usable additional ip
NETMASK=255.255.255.224
ONBOOT=yes
DELAY=0
STP=off

/etc/sysconfig/network-scripts/route-viifbr0

ADDRESS0=0.0.0.0
NETMASK0=0.0.0.0
GATEWAY0=144.76.56.xx ---> main ip gateway
IP: --   

Config and Routing of Subnet in Virtualizor
jevingala
Group: Virtualizor Team
Post Group: Elite Member
Posts: 333
Status:
Hi,

You don't need to do anything on server , just need to add ip pool on panel .
Incase of subnet ips you need to follow our guide.
And if you have separate ips then add the ip pool with the settings provided by your data center with mac address generated on their panel.
I assume you are using KVM Virtualizor.


-----------------------
Regards,
Virtualizor Team.
http://virtualizor.com/
IP: --   

Config and Routing of Subnet in Virtualizor
thornz
Group: Member
Post Group: Newbie
Posts: 4
Status:
i have fixed it by adding my subnet's first ip as gateway and removed manually created bridge. thank you
IP: --   

Config and Routing of Subnet in Virtualizor
quickbooks2018
Group: Member
Post Group: Working Newbie
Posts: 69
Status:
Quote From : thornz July 6, 2016, 7:13 am
i have fixed it by adding my subnet's first ip as gateway and removed manually created bridge. thank you


Dear Support,

I bought your Virtualizor Panel, I installed Virtualzor on Hertzner Server.

I have created the viifbr0 all is well, Created Centos VM but machine has no

internet connectivity, please guide

Regards
IP: --   

Config and Routing of Subnet in Virtualizor
zvictorp
Group: Member
Post Group: Newbie
Posts: 2
Status:
Quote From : quickbooks2018 February 7, 2018, 3:26 pm
Quote From : thornz July 6, 2016, 7:13 am
i have fixed it by adding my subnet's first ip as gateway and removed manually created bridge. thank you


Dear Support,

I bought your Virtualizor Panel, I installed Virtualzor on Hertzner Server.

I have created the viifbr0 all is well, Created Centos VM but machine has no

internet connectivity, please guide

Regards



I fixed the issue by adding

iptables -t nat -A POSTROUTING -o viifbr0 -j MASQUERADE
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is December 14, 2018, 9:55 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.796