Welcome Guest. Please Login or Register  


You are here: Index > Webuzo > General Support > Topic : Email Configuration



Threaded Mode | Print  

 Email Configuration, Email server configuration (13 Replies, Read 973 times)
jamestibbets
Group: Member
Post Group: Newbie
Posts: 7
Status:
How do I configure a working email server using Webuzo? The documentation is non-existent. I've stumbled my way through every other hurdle between me and moving from a shared host to a VPS, but the email is going to be a deal breaker.
IP: --   

Email Configuration
peopleinside
Group: Member
Post Group: Super Member
Posts: 1271
Status:
Hi, when you add a domain you have the relatice chek box for configure SPF and DKIM records. Be sure to have also a DMARC record. You can made search on Google about this three records if you need help.
Webuzo add the record if you are using the BING inside Webuzo. Maybe DMARC record is not added, please check. If the needed record are not present you need add manually.
You can test your email score and see what issue do you have on the website https://www.mail-tester.com/ ... you should have 3 free test every 24 hours.


-----------------------
PeopleInside  :angel:
Passionate Webuzo User
IP: --   

Email Configuration
jamestibbets
Group: Member
Post Group: Newbie
Posts: 7
Status:
That's the least of my worries. I can't even log into Rainloop because it can't connect to the server. I have Dovecot installed. How do I get an email server running?
IP: --   

Email Configuration
peopleinside
Group: Member
Post Group: Super Member
Posts: 1271
Status:
What issue or error do you see when try to login into rainloop?Do you have installed also Exim? Created an email address from Webuzo Panel?


-----------------------
PeopleInside  :angel:
Passionate Webuzo User
IP: --   

Email Configuration
jamestibbets
Group: Member
Post Group: Newbie
Posts: 7
Status:
I've got Exim installed and Dovecot installed. I set up an email address as per the official instructions. When I go to log into Rainloop from the admin panel the indicator spins for a long time and then says "Can't connect to server."
IP: --   

Email Configuration
peopleinside
Group: Member
Post Group: Super Member
Posts: 1271
Status:
This issue maybe should be checked by the Webuzo team.
Have you checked the DNS record for email?You need maybe wait tomorrow a Webuzo member will help you. If you are a premium user you can open a ticket. https://www.softaculous.com/support/ maybe they can assist you :)


-----------------------
PeopleInside  :angel:
Passionate Webuzo User
IP: --   

Email Configuration
jamestibbets
Group: Member
Post Group: Newbie
Posts: 7
Status:
They need much better documentation. I'm not going to become a premium member if I can't use the software effectively. I'm on a trial.
IP: --   

Email Configuration
Dhanya
Group: Softaculous Team
Post Group: Working Member
Posts: 167
Status:
Hi,

We are sorry for the inconvenience caused.

Please open a support ticket with us so that we can resolve your issue asap:
https://www.softaculous.com/support/

Edited by Dhanya : January 31, 2019, 7:24 am
IP: --   

Email Configuration
jamestibbets
Group: Member
Post Group: Newbie
Posts: 7
Status:
With the help of support I got it figured out! Open /usr/local/webuzo/enduser/webuzo/rainloop/data/_data_/_default_/domains/[domain_name].ini in your favorite text editor and replace:

imap_host = "993"

with:

imap_host = 143

imap_secure = "SSL"
with:
imap_secure = "None"
smtp_port = 465
with:
smtp_port = 25
and
smtp_secure = "SSL"
with:
smtp_secure = "None"
I hope that helps someone!  :xd:
IP: --   

Email Configuration
jamestibbets
Group: Member
Post Group: Newbie
Posts: 7
Status:
The above method disables encryption, which is not good. A simpler way to fix the problem (for CentOS 7 at least) is to open ports 465 and 993 on your server using the commands:

sudo firewall-cmd --permanent --add-port=465/tcp
sudo firewall-cmd --permanent --add-port=993/tcpsudo firewall-cmd --reload
This method keeps SSL encryption for your emails. Encryption is good.
IP: --   

Email Configuration
peopleinside
Group: Member
Post Group: Super Member
Posts: 1271
Status:
Quote From : jamestibbets February 1, 2019, 1:42 pm
The above method disables encryption, which is not good. A simpler way to fix the problem (for CentOS 7 at least) is to open ports 465 and 993 on your server using the commands:

sudo firewall-cmd --permanent --add-port=465/tcp
sudo firewall-cmd --permanent --add-port=993/tcpsudo firewall-cmd --reload
This method keeps SSL encryption for your emails. Encryption is good.

I believe you are right, i never suggest to use unencrypted email.Great solution... i was forget maybe the port can be closed on Centos. Hope your issue was resolved.
I always ask to Webuzo team to stay secure and keep software safe. They really suggested to use the settings you mentioned? I believe this is an error.


-----------------------
PeopleInside  :angel:
Passionate Webuzo User
IP: --   

Email Configuration
jamestibbets
Group: Member
Post Group: Newbie
Posts: 7
Status:
They need to add ports 465 and 993 to the list of ports you need to have open on the install instructions at:
https://www.webuzo.com/docs/installation/install#requirements
That was a frustrating bit of trouble that could have been avoided. Works better than cPanel now! Nicer price too!
IP: --   

Email Configuration
peopleinside
Group: Member
Post Group: Super Member
Posts: 1271
Status:
I am happy with Webuzo and when there is an issue they are always available to find a solution.

I am sure they will consider to add informations about opening port on the guide. You are free to choose the panel that's is more near your needs.
Thank you for posting in the forum :)



-----------------------
PeopleInside  :angel:
Passionate Webuzo User
IP: --   

Email Configuration
Dhanya
Group: Softaculous Team
Post Group: Working Member
Posts: 167
Status:
Hi,

Extremely sorry for the trouble caused.

We have updated the Install Documentation by adding ports 465 and 993 in the list of ports to be opened.

Thank you for notifying us.

Let us know if you face any issues further.
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is October 23, 2019, 4:30 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.346