Welcome Guest. Please Login or Register  


You are here: Index > Softaculous Auto Installer > General Support > Topic : Clarification of Softaculous installation location?



Threaded Mode | Print  

 Clarification of Softaculous installation location?, local or server side (5 Replies, Read 3823 times)
murrayatuptown
Group: Member
Post Group: Newbie
Posts: 5
Status:
Hello:

I used Softaculous years ago as part of a web hosting package I no longer have. I found the server-side installation more productive (for me) than the Demo mode.

I am currently trying to set up local installations of XAMPP on both Windows 7 and Linux/Ubuntu (18.04?), eventually to set up piwigo.

A lot of steps and learning at each one. I have some challenges with piwigo direct installation on both OS platforms, so I thought I'd try the Softaculous installation.

I did download a Softaculous installation package. I assume but am not certain whether it belongs in a local PC environment (XAMPP localhost?) or is for installation on remote hosting servers that don't have it as a standard feature.

With all the installations I have been doing I may have overlooked installation instructions for Softaculous. But I think understanding the context of what environment it's intended for might be a more important question.

I am not sure what 'version' of the softaculous zip package was, but will attempt a screenshot upload of what was inside the unzipped package...that may make it obvious to someone what I downloaded.

Thank you 

-----------------------
Murray
IP: --   

Clarification of Softaculous installation location?
murrayatuptown
Group: Member
Post Group: Newbie
Posts: 5
Status:
I didn't see error message on first .jpg  attachment failure.
Can't post a response as a an attachment only (empty message).
Try again.

-----------------------
Murray
IP: --   

Clarification of Softaculous installation location?
murrayatuptown
Group: Member
Post Group: Newbie
Posts: 5
Status:
Doesn't accept .JPG attachments? That's the error message I got

-----------------------
Murray
IP: --   

Clarification of Softaculous installation location?
murrayatuptown
Group: Member
Post Group: Newbie
Posts: 5
Status:
I found a conditional check in a PHP file I inspected (I think in the Softaculous package, but I am looking at three things in two operating systems, so I may have forgotten).

It checked for several PHP versions ranging from 5.x thru perhaps 7.1 or 7.2.

I had installed XAMPP with PHP 7.4 compatibility based on a host server I need to keep in mind for future 'live' installation.

The checks for version followed specific install paths, and none were as high as PHP 7.4.

Maybe minimum AND maximum requirements apply ;O)

-----------------------
Murray
IP: --   

Clarification of Softaculous PHP & ionCube
murrayatuptown
Group: Member
Post Group: Newbie
Posts: 5
Status:
Hello:

I deleted my unzipped softaculous.zip files & re-attempted the installation from the softaculous web page. That completed fine with two oddities.

PHP 5.5.9 was displayed (suggesting softaculous detected that version or requires it?)
ionCube Loader was not installed which is apparently a known issue (read about it before experiencing it).

ionCube website appears to require purchase/licensing, but prior to successfully installing something to try out (will I be successful or actually move installed packages to web hosting from local server 'simulation'? There was an ionCubeLoader link that bypassed the purchase/licensing but it appeared to be only for web hosting server installations. Is there a way to complete the softaculous installation, or do I even need the ionCube portion for a local installation?

Thank you

-----------------------
Murray
IP: --   

Clarification of Softaculous installation location?
Brijesh
Group: Softaculous Team
Post Group: Super Member
Posts: 4890
Status:
Hi,

Sorry for the delay in response.

Softaculous requires ionCube loader.

Ioncube Loader is different from Ioncube encoder (which is premium) that you saw on their site.

The ioncube encoder is premium which is not required for Softaculous to run.

You need Ioncube loader which is free, you can try to find how to install ioncube loader in XAMPP and then try to access Softaculous.

-----------------------
Loginizer - WordPress Security Plugin
Follow us on Twitter
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is February 27, 2021, 3:44 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.358