Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > Suggestions > Topic : Autostart/service for MongoDB



Threaded Mode | Print  

 Autostart/service for MongoDB (4 Replies, Read 22170 times)
asegura
Group: Member
Post Group: Newbie
Posts: 12
Status:
Just as Apache and MySQL can be autostarted on session startup or run as services, it would be great if MongoDB could too.

AMPPS is advertised as a stack of Apache, MySQL, MongoDB. It is strange that the latter is not treated the same as the first two. And MongoDB can easily be run as a service, BTW.
IP: --   

Autostart/service for MongoDB
asegura
Group: Member
Post Group: Newbie
Posts: 12
Status:
BTW, here is the documentation on how to configure MongoDB to run as a service:

http://docs.mongodb.org/manual/tutorial/install-mongodb-on-windows/
IP: --   

Autostart/service for MongoDB
asegura
Group: Member
Post Group: Newbie
Posts: 12
Status:
AMPPS 3.4 is released and still Mongo cannot be autostarted or run as a service.

I think Mongo should be treated just like MySQL and have an autostart option at the main Control Center window.
IP: --   

Autostart/service for MongoDB
allanonk4
Group: Member
Post Group: Newbie
Posts: 1
Status:
I installed softaculous ammps and was wondering this very thing. I was able to get this working doing the following:

1) stop mongo if it's started

2) Find your mongo.conf. It's most likely in <ammps-install-directory>\mongodb\mongo.conf

This has the paths that mongo is using for the dbpath and logpath parameters as well as the other options it needs. You need to replicate those on the command line to get it to run as a service in ammps style.

3) run cmd as admistrator, change directory to  <ammps-install-directory>\mongodb\bin
and run this command, replacing the parameters for what's in your mongo.conf

mongod  --install --dbpath="<config-dbpath>" --logpath="<config-logpath>" --port 27017 --logappend --directoryperdb --rest --journal

4) run services.msc

5) 4) If you get any errors when starting the service, open your log file and see what they are. It's probably some switch that needs to be added. In my case, not having --journal was causing mongo to stop. run mongod --remove to remove the service that you created and repeat step 3 with the new options

6) start mongo and set to automatic start up if it isn't already (it should be)

7) enjoy automatic startup of mongo, yay!
IP: --   

Autostart/service for MongoDB
abiella
Group: Member
Post Group: Newbie
Posts: 3
Status:
All the problems with ampps now are due mainly to it being run on 64bt systems.

Please provide a 64bit ampps to solve all these wahallaas and pallavaas.
Thanks
Deji Ab
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is October 21, 2017, 7:39 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.185