Welcome Guest. Please Login or Register  


You are here: Index > Webuzo > General Support > Topic : Multiple PHP Versions



Threaded Mode | Print  

 Multiple PHP Versions (5 Replies, Read 1294 times)
busychild
Group: Member
Post Group: Newbie
Posts: 1
Status:
Hi,

i would like to set the php version for each domain / vhost individually instead of defining a global one - there was a thread from 2014 which wasn't solved yet - is there any chance to get this working?

Thanks in advance and best regards

Florian
IP: --   

Multiple PHP Versions
webuzo_manager
Group: Webuzo Team
Post Group: Elite Member
Posts: 271
Status:
Hi busychild,

We have this feature in our To-Do list and will be implemented in a future release.

Currently, there is no manual way to achieve this.
IP: --   

Multiple PHP Versions
Richard
Group: Member
Post Group: Newbie
Posts: 5
Status:
Any insight on when this todo list is being implemented?
Because various hosting panels, especially Cpanel has the option to use multiple php versions.And it's hard if for example 5.6 is default and people start using php 7.0, 7.1 and 7.2 for their sites.
IP: --   

Multiple PHP Versions
Richard
Group: Member
Post Group: Newbie
Posts: 5
Status:
I just found some solution in this thread:https://www.softaculous.com/board/index.php?tid=6474&title=Required_PHP_version
But that is for Cloudlinux with CageFS, we don't use Cloudlinux, but do use Cpanel.
IP: --   

Multiple PHP Versions
Dhanya
Group: Softaculous Team
Post Group: Working Member
Posts: 185
Status:
Hi,

Quote From : Richard December 20, 2018, 4:45 pm
Any insight on when this todo list is being implemented?
Because various hosting panels, especially Cpanel has the option to use multiple php versions.And it's hard if for example 5.6 is default and people start using php 7.0, 7.1 and 7.2 for their sites.


Currently, we don't have MultiPHP feature. But we will try adding it in Future Webuzo versions.

Quote From : Richard December 20, 2018, 4:48 pm
I just found some solution in this thread:https://www.softaculous.com/board/index.php?tid=6474&title=Required_PHP_version
But that is for Cloudlinux with CageFS, we don't use Cloudlinux, but do use Cpanel.


The Softaculous Documentation page mentioned in the blog page is for Detecting the PHP selected in CageFS for a domain by configuring a pre_install and pre_upgrade hook given in Softaculous hooks folder. This is for Softaculous AutoInstaller to get the appropriate PHP version so as to install a script.

Let us know if you have any further queries.
IP: --   

Multiple PHP Versions
Richard
Group: Member
Post Group: Newbie
Posts: 5
Status:
Thank you.

Quote
But we will try adding it in Future Webuzo versions.
What is Webuzo? Is that a new name for Softaculous?
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is November 21, 2019, 5:34 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.219