Welcome Guest. Please Login or Register  


You are here: Index > Softaculous Auto Installer > General Support > Topic : Extension Error for Items Installed



Threaded Mode | Print  

 Extension Error for Items Installed, Getting an error for php extensions however they are already installed (1 Replies, Read 1794 times)
jisaac
Group: Member
Post Group: Newbie
Posts: 1
Status:
I am trying to install MODX on a VPS.

The following error shows:

Required PHP extension not found : gd
Required PHP extension not found : curl
Required PHP extension not found : zlib
Required PHP extension not found : SimpleXML
Required PHP extension not found : pdo_mysql
Required PHP extension not found : json

Each is installed, present, and enabled when looked at through phpinfo.

Where is Softaculous getting its apache info?
IP: --   

Extension Error for Items Installed
Brijesh
Group: Softaculous Team
Post Group: Super Member
Posts: 4494
Status:
Hi,

Sir which panel are you using ? Do you have multiple PHP binaries on the server i.e. are you using multiple PHP versions ? If yes then by default Softaculous checks the extensions in the default PHP binary and you can change this by defining the path to your binary in the pre install hook :
http://www.softaculous.com/docs/Hooks#pre_install

Code
global $softpanel;
$softpanel->ephp_bin = '/PATH/TO/PHP';


-----------------------
SitePad Website Builder
Follow us on Twitter
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is April 8, 2020, 2:06 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.134