Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > Bugs > Topic : AMPPS 3.6 on Ubuntu 16.10 - Unusable - Gray, Broken GUI



Threaded Mode | Print  

 AMPPS 3.6 on Ubuntu 16.10 - Unusable - Gray, Broken GUI (12 Replies, Read 20239 times)
hunkthrust
Group: Member
Post Group: Newbie
Posts: 3
Status:
Hey guys.

I wanted to report that it seems like the great looking new UI you released with version 3.6 doesn't work in Ubuntu 16.10 (at least).

Following the installation instructions, which has always worked for me in the past, I get the following error after running sudo /usr/local/ampps/Ampps:

Code
QLayout: Attempting to add QLayout "" to Ampps "Ampps", which already has a layout
[phpversion::checkversion] : "5.3"
[phpversion::checkversion] : "5.3"
[phpversion::checkversion] : "5.3"
[phpversion::checkversion] : "5.3"
Could not open input file: /usr/local/ampps/ampps/softaculous/enduser/install.php
[phpversion::checkversion] : "5.3"
[phpversion::checkversion] : "5.3"
[Ampps::exec] "/usr/local/ampps/apache/bin/httpd-k start"
X Error: BadAccess (attempt to access private resource denied) 10
  Extension:    130 (MIT-SHM)
  Minor opcode: 1 (X_ShmAttach)
  Resource id:  0x143
X Error: BadShmSeg (invalid shared segment parameter) 128
  Extension:    130 (MIT-SHM)
  Minor opcode: 5 (X_ShmCreatePixmap)
  Resource id:  0xd4
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x300001f
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x300001f
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x300001f
The GUI pops up and the tray icon is added to the tray but the window is gray and is unusable, as you can see by the screenshots I've attached.

Things I've tried:
  • Running gksudo /usr/local/ampps/Ampps - Same outcome, but no errors are output in the terminal.
  • Downgrading from qt5 to qt4
  • sudo QT_X11_NO_MITSHM=1 /usr/local/ampps/Ampps - found some posts outlining a similar issue, but this did not help either.


It seems like an error with QT to me. I'm going to try to find a previous version to install.

I'd really like to use the newest minor of your great software. Please let me know if I can help debug this issue with you!
IP: --   

AMPPS 3.6 on Ubuntu 16.10 - Unusable - Gray, Broken GUI
hunkthrust
Group: Member
Post Group: Newbie
Posts: 3
Status:
Attachments:
IP: --   

AMPPS 3.6 on Ubuntu 16.10 - Unusable - Gray, Broken GUI
GriZZli
Group: Member
Post Group: Newbie
Posts: 2
Status:
Any progress with the issue? Have the same problem on Debian 9_x64 with Ampps 3.7-x86-64
IP: --   

AMPPS 3.6 on Ubuntu 16.10 - Unusable - Gray, Broken GUI
hunkthrust
Group: Member
Post Group: Newbie
Posts: 3
Status:
I haven't checked in about 2 months, but I was unable to even figure out where, exactly, the error was stemming from. I'm shocked that more people aren't experiencing this issue.
IP: --   

AMPPS 3.6 on Ubuntu 16.10 - Unusable - Gray, Broken GUI
nonchiedercilaparola
Group: Member
Post Group: Newbie
Posts: 11
Status:
ubuntu 17.4 + ampps 3.7 same problem:

Code
[phpversion::checkversion] : "5.5"
[phpversion::checkversion] : "5.5"
QLayout: Attempting to add QLayout "" to Ampps "Ampps", which already has a layout
[phpversion::checkversion] : "5.5"
[phpversion::checkversion] : "5.5"
[phpversion::checkversion] : "5.5"
[Ampps::exec] "/usr/local/ampps/apache/bin/httpd-k start"
QSslSocket: cannot resolve SSLv2_client_method
QSslSocket: cannot resolve SSLv2_server_method
X Error: BadAccess (attempt to access private resource denied) 10
  Extension:    130 (MIT-SHM)
  Minor opcode: 1 (X_ShmAttach)
  Resource id:  0x13d
X Error: BadShmSeg (invalid shared segment parameter) 128
  Extension:    130 (MIT-SHM)
  Minor opcode: 5 (X_ShmCreatePixmap)
  Resource id:  0x4600029
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x460002a
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x460002a
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x460002a
after that i type ctrl+c to escape.
IP: --   

AMPPS 3.6 on Ubuntu 16.10 - Unusable - Gray, Broken GUI
nonchiedercilaparola
Group: Member
Post Group: Newbie
Posts: 11
Status:
i try to re-installed and i notice this text:

Code
...............................................................
Applying Permissions...
Configuring Pure-FTPd...
Configuring PHP...
Configuring Softaculous...
Copying library files...
[b]cp: l'obiettivo '/usr/lib64/' non è una directory[/b]Setting Permission to Cgi-Bin
Creating Symmlink...
Installing as a service...
Configuring mongodb.so...
Done

IP: --   

AMPPS 3.6 on Ubuntu 16.10 - Unusable - Gray, Broken GUI
nonchiedercilaparola
Group: Member
Post Group: Newbie
Posts: 11
Status:
cp: l'obiettivo '/usr/lib64/' non è una directory
IP: --   

AMPPS 3.6 on Ubuntu 16.10 - Unusable - Gray, Broken GUI
newwhitebear
Group: Member
Post Group: Newbie
Posts: 7
Status:
medesimo problema con ubuntu 16.04 lts a 64bit. Creata la directory non è cambiato nulla. il comando sudo va in crash. Mi suggerisce di creare delle entrate vuote ma dove non si sa.
IP: --   

AMPPS 3.6 on Ubuntu 16.10 - Unusable - Gray, Broken GUI
nonchiedercilaparola
Group: Member
Post Group: Newbie
Posts: 11
Status:
X forza di causa maggiore sono dovuto passare da osx a ubuntu (il mio macbook ha il procio e mobo andate) e anche se mi consente di utilizzare una macchina di bassa qualità come una scheggia il resto è tutto davvero frustrante!!! ad ogni problema ci sono o una miriade di soluzioni per versioni diverse o nessuna soluzione perchè il problema è solo personale!!

Mannaggia un vero peccato, come ho qualche soldino spero di tornare a osx, sarà più chiuso ma non c'è proprio paragone.

p.s. è come ammattirsi a trovare un live streaming decente con commento in italiano o pagare per una lista iptv...tempo risparmiato impareggiabile!!! (scusate l'ot)
IP: --   

AMPPS 3.6 on Ubuntu 16.10 - Unusable - Gray, Broken GUI
newwhitebear
Group: Member
Post Group: Newbie
Posts: 7
Status:
o.t. sono passato a ubuntu perché stanco di win10, lento e in continua manutenzione. Dopo due anni un bilancio positivo. Tutto quello che usavo in win ce l'ho qui. Un po' più complicato installazione e manutenzione ma poi diventa naturale. E' la prima volta che un applicativo mi mette a piedi, si fa per dire. L'omologo xampps l'ho installato senza problemi e dove voglio io. Funziona perfettamente. Vorrei eliminarlo - ad ogni aggiornamento del sistema compaiono tre worning legati a Ampps, al momento solo fastidiosi.
IP: --   

AMPPS 3.6 on Ubuntu 16.10 - Unusable - Gray, Broken GUI
varelajp
Group: Member
Post Group: Newbie
Posts: 2
Status:
Hi!

Environment variable QT_X11_NO_MITSHM is not set.
Runtime solutions:
1. sudo QT_X11_NO_MITSHM=1 ./usr/local/ampps/Ampps.run
2. sudo export QT_X11_NO_MITSHM=1
    sudo ./usr/local/ampps/Ampps.run

Permanent Solution:
1. Add export QT_X11_NO_MITSHM=1 to /etc/environment (or to your environment file based on your Linux distro).
IP: --   

AMPPS 3.6 on Ubuntu 16.10 - Unusable - Gray, Broken GUI
nonchiedercilaparola
Group: Member
Post Group: Newbie
Posts: 11
Status:
Quote From : varelajp August 11, 2017, 9:08 am
Hi!

Environment variable QT_X11_NO_MITSHM is not set.
Runtime solutions:
1. sudo QT_X11_NO_MITSHM=1 ./usr/local/ampps/Ampps.run
2. sudo export QT_X11_NO_MITSHM=1
    sudo ./usr/local/ampps/Ampps.run

Permanent Solution:
1. Add export QT_X11_NO_MITSHM=1 to /etc/environment (or to your environment file based on your Linux distro).
during installation i get this advice:
"cp: l'obiettivo '/usr/lib64/' non è una directory (cp: the target 'usr/lib64/' isn't a folder"

what's the problem of this error copy comand?
"
IP: --   

AMPPS 3.6 on Ubuntu 16.10 - Unusable - Gray, Broken GUI
nonchiedercilaparola
Group: Member
Post Group: Newbie
Posts: 11
Status:
However thanks for trick, with environment variable changes now ampps start.
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is August 22, 2017, 5:12 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.266