Welcome Guest. Please Login or Register  


You are here: Index > Virtualizor - Virtual Server Control Panel > General Support > Topic : End-user API



Threaded Mode | Print  

 End-user API, How can I use end-user api correctly? (1 Replies, Read 1244 times)
johnny_dev
Group: Member
Post Group: Newbie
Posts: 3
Status:
I use creating VM api with this post request
curl -k -X POST -d "addvs=1&virt=proxk&rootpass=test123&hostname=tester&space=20&ram=1024&swap=1024&bandwidth=0&uid=1&cpu=1024&cores=2&ips=1&vnc=1&osid=100001&sgid=1&iso="CentOS-7-x86_64-Minimal-1804.iso" L "https://hostname:4083/index.phpact=create&api=json&apikey=key&apipass=pass"

Output:

"newvs":{"uid":1,"sgid":1,"rootpass":"test123","hostname":"tester","rdp":0,"type":"proxk","space":20,"ram":1024,"burst":0,"swapram":1024,"bandwidth":0,"cores":2,"num_ipv4":1,"num_ipv6":0,"num_ipv6_subnet":0,"vnc":1,"vncpass":"t4nq5akk","shadow":0,"iso":"","boot":"cda","band_suspend":"0","tuntap":0,"osreinstall_limit":0,"mg":[1],"osid":100001,"node_select":1,"server_group":1,"num_ips":1,"num_ips6":0,"num_ips6_subnet":0,"addvps":1,"topology_sockets":0,"topology_cores":0,"topology_threads":0,"vpsid":"13","ips":["27.254.94.175"],"ips6":[],"ipv6_subnet":[]},"res_limit":{"num_vs":"2","num_users":"5","space":"50","ram":"10240","bandwidth":"0","num_ipv4":"255","num_ipv6_subnet":"0","num_ipv6":"0","num_cores":"0","cores":"4"},"virts":{"openvz":"openvz","xen":"xen","xenhvm":"xenhvm","kvm":"kvm","xcp":"xcp","xcphvm":"xcphvm","lxc":"lxc","proxo":"proxo","proxk":"proxk","proxl":"proxl","vzk":"vzk","vzo":"vzo"},"enable_nic":0,"virt_lang":{"openvz":"OpenVZ","xen":"Xen","xenhvm":"Xen HVM","kvm":"KVM","xcp":"XCP","xcphvm":"XCP HVM","lxc":"LXC","proxo":"Proxmox OpenVz","proxk":"Proxmox QEMU","proxl":"Proxmox LXC","vzk":"Virtuozzo KVM","vzo":"Virtuozzo OpenVZ"},"webuzo_apps":null,"time_taken":"4.350"}

=========================================================================

VM is working good but iso was not set. how can I set iso for VM to boot OS correctly?
IP: --   

End-user API
ali@virtualizor.com
Group: Member
Post Group: Newbie
Posts: 1
Status:
You need to pass in the isos UUID as a post parameter which you can get from the enduser panel by navigating to ISO tab which lists all the isos downloaded by the enduser.
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is December 10, 2018, 8:22 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.356