Welcome Guest. Please Login or Register  


You are here: Index > Webuzo > General Support > Topic : HTTPd Not Starting Automatically because Other HTTPd Starting - how to change?



Threaded Mode | Print  

 HTTPd Not Starting Automatically because Other HTTPd Starting - how to change? (4 Replies, Read 291 times)
mike1261
Group: Member
Post Group: Newbie
Posts: 4
Status:
I think my CentOS 7 VPS had a previous installation of Apache or something on it.

When I reboot the server, Webuzo Admin Panel says Apache is not started, and won't start it.

Because there is already a service named "httpd" using Port 80, serving up the default Apache pages.

If I sudo systemctl stop httpd.service, then go to the Webuzo Admin panel and start the Apache service, we're back in business.

But because the Webuzo HTTPd and the default auto-starting HTTPd are both called "httpd" I don't really know what to do to correct this issue and have the Webuzo HTTPd be the one that auto-starts.

Any advice would be much appreciated. Thanks!
IP: --   

HTTPd Not Starting Automatically because Other HTTPd Starting - how to change?
mike1261
Group: Member
Post Group: Newbie
Posts: 4
Status:
Update:

The service that is auto-starting is:
/usr/sbin/httpd

The Webuzo HTTPd that I need to have start, is:
/usr/local/apps/apache/bin/httpd

How do I specify which HTTPd needs to start at startup and get rid of the wrong one?

Thanks!
IP: --   

HTTPd Not Starting Automatically because Other HTTPd Starting - how to change?
mike1261
Group: Member
Post Group: Newbie
Posts: 4
Status:
Another Update:

systemctl disable httpd.service

This killed the Incorrect HTTPd apparently, and Webuzo's HTTPd kicked in.

How it knows the difference I do not know - but I'm guessing it's more luck than anything.

I feel like I did this before as well and it reverted... But maybe not.
IP: --   

HTTPd Not Starting Automatically because Other HTTPd Starting - how to change?
mike1261
Group: Member
Post Group: Newbie
Posts: 4
Status:
Another Update:

Rebooted server and it's reverted back to starting /usr/sbin/httpd instead of /usr/local/apps/apache/bin/httpd

Sorry for the play by play lol.

Going to have to fix this issue properly, so back to advice being appreciated :-)
IP: --   

HTTPd Not Starting Automatically because Other HTTPd Starting - how to change?
Dhanya
Group: Softaculous Team
Post Group: Working Member
Posts: 184
Status:
Hi,

When installing Webuzo, the installer checks for already existing Apache, MySQL and PHP installation if any before starting installing Webuzo. If found, an error is raised by the installer. If not found then installer continues with the installation process and by default installs Apache 2.2, MySQL 5.5 and PHP 7.3 on the user's server.

>>But because the Webuzo HTTPd and the default auto-starting HTTPd are both called "httpd" I don't really know what to do to correct this issue and have the Webuzo HTTPd be the one that auto-starts.
Apache installed by Webuzo does have a symlink as follows which links to Apache binary i.e /usr/local/apps/apache/bin/httpd:
/usr/sbin/httpd

If you didn't find the symlink then it might be possible that Apache was installed on your server and was not completely removed from your server.

You may execute the following command as root in order to start Apache automatically on your server:
chkconfig httpd off
chkconfig httpd on

Once done, check if the Apache restarts automatically on your server after reboot.

Let us know if you face any issues further.
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is November 17, 2019, 9:56 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.192