Welcome Guest. Please Login or Register  


You are here: Index > Virtualizor - Virtual Server Control Panel > Suggestions > Topic : Update PHP !

1


Threaded Mode | Print  

 Update PHP ! (21 Replies, Read 58753 times)
wolke
Group: NOC
Post Group: Elite Member
Posts: 422
Status:
Since a long time PHP 5.6 is EOL and does not receive any further updates, not even security updates.
It´s time to update the emps stack to a modern version of php.This need to be done by virtualizor. (because of code checking, re-encrypt files with ioncube and so on)
IP: --   

Update PHP !
chirag
Group: Virtualizor Team
Post Group: Elite Member
Posts: 396
Status:
Hi,

Sir yes, we are makign chnages in the core so that it can work on latest PHP version.
It will be out soon.

-----------------------
Virtualizor - VPS Control Panel
Follow us on Facebook
IP: --   

Update PHP !
wolke
Group: NOC
Post Group: Elite Member
Posts: 422
Status:
Thx, that´s really good news!
IP: --   

Update PHP !
wolke
Group: NOC
Post Group: Elite Member
Posts: 422
Status:
Half year later, "soon" is over.  :angel:
IP: --   

Update PHP !
chirag
Group: Virtualizor Team
Post Group: Elite Member
Posts: 396
Status:
Hi,

Sir we have committed the mysql related chnages and it will be there in 3.0.4

Once it is out we can update the EMPS to latest verison of PHP.

So you can say that the wait is about to finish.
Sorry for the delay in process.


-----------------------
Virtualizor - VPS Control Panel
Follow us on Facebook
IP: --   

Update PHP !
JanDragon
Group: Member
Post Group: Newbie
Posts: 1
Status:
Hey.

The update is now released but when do you plan now to update PHP and other 3rd Party Software like MySQL? I would really prefer it to use updated software and not already long time outdated one.

Thanks
JanDragon
IP: --   

Update PHP !
chirag
Group: Virtualizor Team
Post Group: Elite Member
Posts: 396
Status:
Hi,

Sir with last update we have released the compatibility with latest php.
We will be updating the php and mysql soon.

-----------------------
Virtualizor - VPS Control Panel
Follow us on Facebook
IP: --   

Update PHP !
dialhost
Group: NOC
Post Group: Newbie
Posts: 1
Status:
This is very worrying.
The version of php 5.6 already had its end of life in January 2019n and are you still planning the change ?

Virtualizor is a great tool, but it needs to update itself more frequently and optimize its performance.
IP: --   

Update PHP !
chirag
Group: Virtualizor Team
Post Group: Elite Member
Posts: 396
Status:
Hi,

Sir sorry for the inconvenience caused.
But we were doing chnages in core to update to php 7.
3.0.6 has compatibility with php7 and we are testing on php7 environment for this new version.
It will be out by the end of this month.

-----------------------
Virtualizor - VPS Control Panel
Follow us on Facebook
IP: --   

Update PHP !
access2it
Group: Member
Post Group: Newbie
Posts: 2
Status:
We are a few months further and is still no update available on this?
IP: --   

Update PHP !
chirag
Group: Virtualizor Team
Post Group: Elite Member
Posts: 396
Status:
Hi,

Sir New version of EMPS you will get by the end of this month.

We have tested it and all is working fine.
Updates will come if your version is on 3.0.6+
For older versions new emps update will not be provided.

Let us know for further information.

-----------------------
Virtualizor - VPS Control Panel
Follow us on Facebook
IP: --   

Update PHP !
chirag
Group: Virtualizor Team
Post Group: Elite Member
Posts: 396
Status:
Hi,

Sir PHP 7.4 is out now.

-----------------------
Virtualizor - VPS Control Panel
Follow us on Facebook
IP: --   

Update PHP !
access2it
Group: Member
Post Group: Newbie
Posts: 2
Status:
Quote From : chirag September 15, 2021, 3:12 am
Hi,

Sir PHP 7.4 is out now.


Where can I do the update?
Is there any procedure?
IP: --   

Update PHP !
jevingala
Group: Virtualizor Team
Post Group: Super Member
Posts: 653
Status:
Hi,

You can view the updated version of php on Configuration->Server info page.
If its not updated yet, then you can wait for the cron to execute.
You can view emps upgrade cron time in cron file :

cat /etc/cron.d/virtualizor

Or you can use the command manually to update to new EMPs on your servers :

(check version)
cat /usr/local/emps/version (must be 4.0)

/usr/local/emps/bin/php /usr/local/virtualizor/scripts/emps.php upgrade

(check updated version)
cat /usr/local/emps/version (should be 4.1)



-----------------------
Regards,
Virtualizor Team.
http://virtualizor.com/
IP: --   

Update PHP !
tcivhm
Group: Member
Post Group: Newbie
Posts: 4
Status:
Hello Guys,
we got the Problem, that your Admin Interface on Port 4085 is blank. a simple white-page. After checking the logs we find out, that we got problems with the ioncube loader. we tried to run an virtualisor upgrade via ssh, but it does't work for sure..
/temp/ioncube# /usr/local/emps/bin/php /usr/local/virtualizor/scripts/emps.php upgrade
PHP Fatal error:  The file /usr/local/virtualizor/scripts/emps.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.
Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0
root@h2873823:~/temp/ioncube# cat /usr/local/emps/version
4.1

we checket the php.ini. where the ioncube loader 5.3.so is loaded.

any ideas? (i already copied the ionloader 5.6 to the same location of the 5.3.so file and changed the version in php.ini file. but after a restart we got the following error:
root@h2873823:~/temp/ioncube# /usr/local/emps/bin/fpmctl restart
$Stopping php-fpm: Done...
$Starting php-fpm: Failed loading /usr/local/emps/lib/php/ioncube_loader_lin_5.6.so:  /usr/local/emps/lib/php/ioncube_loader_lin_5.6.so: undefined symbol: zend_block_interruptions

IP: --   

« Previous    Next »

Threaded Mode | Print  

1


Jump To :


Users viewing this topic
27 guests, 0 users.


All times are GMT. The time now is December 2, 2021, 1:34 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:1.309