Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > Bugs > Topic : AMPPS cannot be opened on OS/X Yosemite

2


Threaded Mode | Print  

AMPPS cannot be opened on OS/X Yosemite
noisemaker
Group: Member
Post Group: Newbie
Posts: 1
Status:
I had the same problem with 2.8 on Yosemite 10.10.1. I deleted it and installed 2.7 and so far it appears to be working. Thank you for sharing the download link!
IP: --   

AMPPS cannot be opened on OS/X Yosemite
y2001
Group: Member
Post Group: Newbie
Posts: 2
Status:
strange, no comment / reply / answer so far from Softaculous. They still offer the buggy 2.8 dmg for Yosemite. It seems as they are not interested in solving this issue. Ok, it is for free but support is non existent. And that is definitely not serious.
Any alternatives around - except MAMP (pro)?
IP: --   

AMPPS cannot be opened on OS/X Yosemite
TraXX
Group: Member
Post Group: Newbie
Posts: 6
Status:
Same problem here after upgrading to 2.8 from 2.4.

It seems that is searching for the QT library that is not present on our systems.
I hope they will fix it soon.
IP: --   

AMPPS cannot be opened on OS/X Yosemite
angrymonkey
Group: Member
Post Group: Newbie
Posts: 1
Status:
Same here...hope the developer fix soon.  :-(
IP: --   

AMPPS cannot be opened on OS/X Yosemite
nicored
Group: Member
Post Group: Newbie
Posts: 1
Status:
Well, it says that qt can't be found, so there's a workaround to get it to work on your machine:

#1) mkdir /usr/local/Qt-<Version number>
#2) ln -s /Applications/AMPPS/Ampps/Contents/Frameworks /usr/local/Qt-<Version number>/lib
#3) Run AMPPS and it works

:P
IP: --   

AMPPS cannot be opened on OS/X Yosemite
abdulk
Group: Member
Post Group: Newbie
Posts: 3
Status:
I have the exact same error / issue. It's clear the current 2.8 Mac package is broken.

With all due respect and appreciation for the free software, I really must ask.. how does a final release software get posted for download without first performing the most rudimentary test of installing it to make sure it even works?

Furthermore, how is it that this post is now 11 days old and there's been zero response from Softaculous?  And this is not even the first time.

I was a huge fan and advocate of AMPPS; I recommended it to every dev I talked to. But with this chronic behavior of releasing untested, broken software I will be migrating to MAMP Pro. I'll gladly pay for a product that works.

Consider offering a commercial version of AMPPS that will receive some support and attention.. As a dev working on 6-figure projects my personal support time for AMPPS has become too expensive..
IP: --   

AMPPS cannot be opened on OS/X Yosemite
BobDeBexar
Group: Member
Post Group: Newbie
Posts: 2
Status:
I just read about AMPPS and was all excited to us it on my Mac as a dev environment. I installed 2.8 and had the same issue as everyone else on this thread.

Not to stick up for Softaculous but I've read that a lot of software has been "broken" by Yosemite. Because of the short time to release (which users lover) the developers of various software were not able to test extensively. The software that is working is mostly by luck. Personally, I haven't had issues with any other software on my Mac but I don't think anything else relies on QT.

I'll go ahead and use AMPPS 2.7 until Softaculous gives us a fix. Thanks to all the helpful folks on this thread.

With all that said though, it would be nice if Softaculous would at least acknowledge the issue.

Cheers.
IP: --   

AMPPS cannot be opened on OS/X Yosemite
abdulk
Group: Member
Post Group: Newbie
Posts: 3
Status:
FYI, I opened a support ticket last week and Softaculous acknowledged the issue and said they're working on it. They recommended to use 2.7.

I asked for an ETA for a 2.8 fix, but they didn't respond back.
IP: --   

AMPPS cannot be opened on OS/X Yosemite
d3mncln3r
Group: Member
Post Group: Newbie
Posts: 1
Status:
Curious about this as well. I tried the above fix by nicored, but it did not work for 2.8 (/Ampps/Contents/.../ did not exist. However I downgraded to 2.7 and it is working.
IP: --   

AMPPS cannot be opened on OS/X Yosemite
brianivie
Group: Member
Post Group: Newbie
Posts: 2
Status:
I tweaked the fix suggested by nicored and it worked (at least AMPPS came up... I'm still new enough that I haven't tested much yet):

sudo ln -s /Applications/AMPPS/Ampps.app/Contents/Frameworks/ /usr/local/Qt-4.8.4/lib

Please note the Ampps.app change to the folder.
IP: --   

AMPPS cannot be opened on OS/X Yosemite
brianivie
Group: Member
Post Group: Newbie
Posts: 2
Status:
One more thing, on MAC OS Yosemite the MAC Apache is running by default.  In order to run AMPPS you first need to stop the default Apache:

Code
sudo apachectl stop
IP: --   

AMPPS cannot be opened on OS/X Yosemite
carlituxman
Group: Member
Post Group: Newbie
Posts: 2
Status:
the patch
sudo ln -s /Applications/AMPPS/Ampps.app/Contents/Frameworks/ /usr/local/Qt-4.8.4/lib

works for me!

great!!!
IP: --   

AMPPS cannot be opened on OS/X Yosemite
Taylex
Group: Member
Post Group: Newbie
Posts: 4
Status:
2.9 is out. I downloaded it and no errors but Apache would not start. I used the "Restore Default Configuration" button under "Apache" in the application and Apache fired right up.

Keeping my fingers crossed that everything else just works.
IP: --   

AMPPS cannot be opened on OS/X Yosemite
mluria
Group: Member
Post Group: Newbie
Posts: 3
Status:
I see that AMMPS 3.0 is out.  Has anyone tried this on Yosemite?
IP: --   

AMPPS cannot be opened on OS/X Yosemite
doron
Group: Member
Post Group: Newbie
Posts: 3
Status:
Just upgraded to AMPPS 3.0 on Yosemite and apache is still not starting :(
tried all the terminal scripts but apache is not starting

This is ridiculous, why isn't Softaculous fixing this, it's been more than a year that this bug is going on.. Guess it's time to ditch AMPPS now.
IP: --   

« Previous    Next »

Threaded Mode | Print  

2


Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is October 18, 2019, 3:46 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.695