Welcome Guest. Please Login or Register  


You are here: Index > Webuzo > General Support > Topic : Error 500



Threaded Mode | Print  

 Error 500 (7 Replies, Read 9905 times)
torcams
Group: Member
Post Group: Newbie
Posts: 15
Status:
Hi guys

I am a new user of webuzo and VPS self managed hosting.

I tried to add a domain an install wordpress on it, i have 4 VPS servers and they all act the same. On a new install with no customization done to the servers i get error 500 on homepage. I can access specific files, like if i have a txt file i can read it.

I applied the permission via ssh, the chown command I found on this forum but nothing changed. All wordpress files and folders are 755 now.

Suphp is activated, when i disable it i get a The connection was reset message instead.

I need help if someone is nice enough to give me a hand.
IP: --   

Error 500
torcams
Group: Member
Post Group: Newbie
Posts: 15
Status:
I tried these solutions too http://www.webuzo.com/blog/how-to/fix-internal-server-error-webuzo-2690.html

Same problem

This is what the error log shows me:

[Tue Jul 01 22:03:34 2014] [error] [client  x.xx.xxx.224] SoftException in Application.cpp:573: Directory "/home/server18/public_html" is writeable by others
[Tue Jul 01 22:03:34 2014] [error] [client x.xx.xxx.224] Premature end of script headers: index.php


My install files are on the root of the server
IP: --   

Error 500
valley
Group: Webuzo Team
Post Group: Super Member
Posts: 1644
Status:
The directory /home/server18/public_html should have the permissions 0755 instead of 0777.

-----------------------
Webuzo : Single User Control Panel
Join Webuzo :
Facebook
Twitter

IP: --   

Error 500
torcams
Group: Member
Post Group: Newbie
Posts: 15
Status:
I am writing here since i cannot upload any screenshots on the ticket opened. The one server you fix works, others don't even though they have 755 permission to the public_html

This is the command I used

chmod 755 /home/server19/public_html

And it did not fix the 500 error on any of my other 3 servers. You must be doing something different because changing the permissions via ssh,my way, doesn't solve the problem.

Thank you again, you are a great bunch of people
IP: --   

Error 500
valley
Group: Webuzo Team
Post Group: Super Member
Posts: 1644
Status:
The command should have been

chmod 755 /home/server11/public_html


instead of
chmod 755 /home/server11/public_html


Check the error logs to learn more of the issue.
Path to logs
/usr/local/apps/apache/logs/


-----------------------
Webuzo : Single User Control Panel
Join Webuzo :
Facebook
Twitter

IP: --   

Error 500
torcams
Group: Member
Post Group: Newbie
Posts: 15
Status:
This is the same command :)

"The command should have been



chmod 755 /home/server11/public_html





instead of

chmod 755 /home/server11/public_html"

Do you know how can I access /usr/local/apps/apache/logs/ except ssh? Is there any way to view it from ftp or file manager?

Problem solved

Public_html must be 755

Always remove and install apache again after you install webuzo, it wil lsave you for some headacheas.

Go to the control panel > apps > web server > apache > remove and reinstall

Reboot your vps and you are done.

Thanks guys, my problem was that i did not restart vps/apache after I installedi t again.
IP: --   

Error 500
valley
Group: Webuzo Team
Post Group: Super Member
Posts: 1644
Status:
Quote
Do you know how can I access /usr/local/apps/apache/logs/ except ssh? Is there any way to view it from ftp or file manager?


SSH is the only way for now.

Quote
Always remove and install apache again after you install webuzo, it wil lsave you for some headacheas.


This is not a recommended method as it can lead to other problems as well.
Rather focus on fixing the permission issues when you upload the files/dir.
It will help you a lot.

Quote
Reboot your vps and you are done.

A reboot is not required. Simply restart the Apache service from Webuzo Enduser Panel >> Services Menu

or from the terminal as follows
Root > service httpd restart

Hope it helps :)


-----------------------
Webuzo : Single User Control Panel
Join Webuzo :
Facebook
Twitter

IP: --   

Error 500
torcams
Group: Member
Post Group: Newbie
Posts: 15
Status:
Good stuff

Thank you very much!
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is July 30, 2021, 11:25 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 10  |  Page Created In:3.978