Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > General Support > Topic : Install PHP-7.2



Threaded Mode | Print  

 Install PHP-7.2 (9 Replies, Read 7614 times)
swissdoode
Group: Member
Post Group: Newbie
Posts: 5
Status:
I need to install PHP 7.2 on my local machine to run the latest Version of typo3.

I downloaded the package from liip.ch, put it in the AMPPS-folder and manually changed the httpd.conf file from Apache.

But when I restart Apache, it still shows PHP 7.1.8 in the phpinfo as if my self installed PHP-Version wouldn't even exist.

Any ideas?

@Softaculous - when will PHP 7.2 be available as an official install? I think I'm not the only one who needs it ;)
IP: --   

Install PHP-7.2
swissdoode
Group: Member
Post Group: Newbie
Posts: 5
Status:
I'm one step further (sorta).

Now AMPPS tries to start with the new PHP, but then I get an error saying:

Code
httpd: Syntax error on line 159 of /Applications/AMPPS/apache/conf/httpd.conf: Cannot load /usr/local/opt/php/lib/httpd/modules/libphp7.so into server: dlopen(/usr/local/opt/php/lib/httpd/modules/libphp7.so, 10): no suitable image found.  Did find:\n\t/usr/local/opt/php/lib/httpd/modules/libphp7.so: mach-o, but wrong architecture\n\t/usr/local/Cellar/php/7.2.7/lib/httpd/modules/libphp7.so: mach-o, but wrong architecture


Any ideas?
IP: --   

Install PHP-7.2
jrxpress
Group: Member
Post Group: Newbie
Posts: 3
Status:
yes.. I would love to see PHP 7.2 also available as default into AMPPS !!! any news ?
IP: --   

Install PHP-7.2
Kerfred
Group: Member
Post Group: Newbie
Posts: 1
Status:
Any news about the 7.2 or 7.3 update?
IP: --   

Install PHP-7.2
sg4dsiao
Group: Member
Post Group: Newbie
Posts: 5
Status:
Joomla need php 7.1 to run. and AMPPS only allowed Php 5.6
IP: --   

Install PHP-7.2
jrxpress
Group: Member
Post Group: Newbie
Posts: 3
Status:
its been a long time of holding to have PHP 7.2 and 7.3 available with AMPPS ..

I tried everything I could, but since the code is encrypted I wasn't able to get it installed !!

Please give us a light in the end of the Tunnel to get it running ;-)
IP: --   

Install PHP-7.2
mentosice
Group: Member
Post Group: Newbie
Posts: 1
Status:
FireFly III need php 7.2 can we get an update or tuto how to update i haven't had luck trying to add manually
IP: --   

Install PHP-7.2
sg4dsiao
Group: Member
Post Group: Newbie
Posts: 5
Status:
We have detected that your server is using PHP 5.6.31 which is obsolete and no longer receives official security updates by its developers. The Joomla! Project recommends upgrading your site to PHP 7.1 or later which will receive security updates at least until 2019-12-01. Please ask your host to make PHP 7.1 or a later version the default version for your site
IP: --   

Install PHP-7.2
princeofnaxos
Group: Member
Post Group: Newbie
Posts: 8
Status:
This question has been asked many times before, along with real Apache 2.4 (supporting "Require all granted") and other stuff.
But the developer(s) keep really quiet....
IP: --   

Install PHP-7.2
jamesc
Group: Member
Post Group: Working Newbie
Posts: 51
Status:
Need this too
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is March 20, 2019, 9:33 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:3.110