Welcome Guest. Please Login or Register  


You are here: Index > Softaculous Auto Installer > Bugs > Topic : Open Web Analytics shows "failed to open stream"



Threaded Mode | Print  

 Open Web Analytics shows "failed to open stream", A bug appears on OWA when installed from Softaculous (6 Replies, Read 664 times)
need
Group: Member
Post Group: Newbie
Posts: 3
Status:
I installed Open Web Analytics 1.6.8 with Softaculous about 2 days ago and installed the suggested code from its panel on a test page. But it didn't count my visits.

The HTML/JS code didn't show any errors to hint what was wrong. As soon as I added PHP code, it started showing:

Code

Warning: require_once(/home/exampleusername/public_html/path/to/owa/vendor/autoload.php): failed to open stream: No such file or directory in /home/exampleusername/public_html/path/to/owa/modules/base/classes/browscap.php on line 20

Fatal error: require_once(): Failed opening required '/home/exampleusername/public_html/path/to/owa/vendor/autoload.php' (include_path='.:/opt/cpanel/ea-php72/root/usr/share/pear') in /home/exampleusername/public_html/path/to/owa/modules/base/classes/browscap.php on line 20


The OWA GitHub releases page explicitly suggests that using Composer is necessary:

Quote

NOTE: As of this release you must install and run Composer to download dependencies when checking out code from GitHub. ...


But the Softaculous install didn't have "vendor/autoload.php", so it didn't work. I copied a "vendor" directory from a release version I downloaded, and it still showed some error. So I deleted my old site entry from OWA panel and then re-added it. Then added the new code on both HTML and PHP page and it worked!

So I think having the "vendor" directory is necessary for it to work.
IP: --   

Open Web Analytics shows "failed to open stream"
Brijesh
Group: Softaculous Team
Post Group: Super Member
Posts: 4627
Status:
Hi,

Thank you for reporting the issue.

We are checking this on our servers and will make the required changes.

-----------------------
Loginizer WordPress Security Plugin
Follow us on Twitter
IP: --   

Open Web Analytics shows "failed to open stream"
punit
Group: Softaculous Team
Post Group: Working Member
Posts: 147
Status:
Hi,


We have added vendor folder in Open Web Analytics 1.6.8 and tested scenario. Its working now.

Thank you for reporting this to us. Please run Softaculous cron to get latest package of Open Web Analytics.

Let us know if you have any query.

-----------------------
Regards
Punit Varia
Script Packaging Head
IP: --   

Open Web Analytics shows "failed to open stream"
need
Group: Member
Post Group: Newbie
Posts: 3
Status:
Quote From : punit May 8, 2020, 9:56 am
Hi,
Thank you for reporting this to us. Please run Softaculous cron to get latest package of Open Web Analytics.


I don't have any cron jobs in my cpanel. How can I run it?

It was a test installation. So I removed and installed it again but it didn't work.

I'm on a shared host. Is there any way to delete Softaculous cache to make it look for updates?
IP: --   

Open Web Analytics shows "failed to open stream"
punit
Group: Softaculous Team
Post Group: Working Member
Posts: 147
Status:
Hi,


CRON should have been run by now. If still have not got latest package then ask your host to run following command to get latest package :

/usr/local/cpanel/3rdparty/bin/php /usr/local/cpanel/whostmgr/docroot/cgi/softaculous/cron.php

-----------------------
Regards
Punit Varia
Script Packaging Head
IP: --   

Open Web Analytics shows "failed to open stream"
need
Group: Member
Post Group: Newbie
Posts: 3
Status:
Quote From : punit May 9, 2020, 3:55 am
Hi,


CRON should have been run by now. If still have not got latest package then ask your host to run following command to get latest package :

/usr/local/cpanel/3rdparty/bin/php /usr/local/cpanel/whostmgr/docroot/cgi/softaculous/cron.php


I contacted the host. They say that this is not possible for some reason. No worries. A new update for 1.6.9 was just pushed and the "vendor" directory just got created. The error on the PHP page also stopped showing.

It seems the issue is solved. Thanks.
IP: --   

Open Web Analytics shows "failed to open stream"
Brijesh
Group: Softaculous Team
Post Group: Super Member
Posts: 4627
Status:
Hi,

Glad to know your issue was resolved.

-----------------------
Loginizer WordPress Security Plugin
Follow us on Twitter
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is July 4, 2020, 9:39 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:2.053