Welcome Guest. Please Login or Register  


You are here: Index > Webuzo > Bugs > Topic : Exim not working!!

1


Threaded Mode | Print  

 Exim not working!! (37 Replies, Read 58759 times)
codesight
Group: Member
Post Group: Working Newbie
Posts: 55
Status:
First of: this is the third time I really try to get this crippled version of a MTA working. Since you don't support any other MTA & I'd like to use something that works well with the rest of webuzo - I'm stuck on this.

Second of: stop asking me for root credentials! I'm not going to let anbody I don't know, play on my server. Despite that I'm an IT Professional and I'm capable of making things run quite well IF the stuff follows the rules -  fact is, this thing you call a MTA isn't following anything.

SO - what I'd like you to do right now. Is to answer me the following questions:

1) Why the hell does YOUR Squirrel Webmail not work with YOUR Dovecot?
Infact I had to reconfigure squirrel and use port 993 cause YOUR Dovecot-packet doesn't seem to fetch the "disable_plaintext_auth = no"-Option!

BTW. This isn't the first installation I had exakt that problem with - so please show some professionalism and don't try to tell me this would be a misconfigured server setup kind of problem. I use always CentOS x64 - basic server setup.

2) YOUR MTA-like Exim-Packed doesn't at all - at least in a professional environment (behind firewall, etc) - except sending mails to itself.
The bad thing about that is, that nobody is able to debug that crippled MTA by themselves, 'cause no one knows where the rest of it is gone.

I suggest you do that thing you got paid for (by buying that license) and try to assist by making suggestions and/or explain where the rest of exim is.

Or you could et least for once make a clear call and tell us if an standard packet of exim would work with the webuzo gui (services f. e.)

3) A lot of threads are cut of by you like "send us a support message" or "send us your details" or something like that, instead of actually helping people to help themselves. This exactly the thing which pisses me really off.

You have made a quite well product and every product has its bugs. But there is very little support for your product on the internet - because YOU DON'T ANSWER QUESTIONS!!!



Edited by Moderator : October 22, 2013, 2:07 pm

-----------------------
Don't you dare to ask for root details!
IP: --   

Exim really f...ed up!!
valley
Group: Webuzo Team
Post Group: Super Member
Posts: 1644
Status:
Quote
First of: this is the third time I really try to get this crippled version of a MTA working. Since you don't support any other MTA & I'd like to use something that works well with the rest of webuzo - I'm stuck on this.

Sir we apologize for the inconvenience caused. Exim is the default MTA at the moment. It is installed using "yum" and installation resides at the default location as on CentOS, including the configuration file.

Quote
Second of: stop asking me for root credentials! I'm not going to let anbody I don't know, play on my server.
 
Alright Sir, do not provide us the root credentials. Provide us the steps to replicate the error and we shall debug and resolve it accordingly.

Quote
Despite that I'm an IT Professional and I'm capable of making things run quite well IF the stuff follows the rules -  fact is, this thing you call a MTA isn't following anything.

We wish to learn why the default MTA Exim is not following anything on your server specifically.

Quote
1) Why the hell does YOUR Squirrel Webmail not work with YOUR Dovecot?

OUR Squirrel Webmail does work with OUR Dovecot. We have tested it on many a servers and we have other clients using it as well.

Quote
Infact I had to reconfigure squirrel and use port 993 cause YOUR Dovecot-packet doesn't seem to fetch the "disable_plaintext_auth = no"-Option!

Did these changes work for you ? Or still stuck ?

Quote
BTW. This isn't the first installation I had exakt that problem with - so please show some professionalism and don't try to tell me this would be a misconfigured server setup kind of problem. I use always CentOS x64 - basic server setup.

Could you please provide the steps to replicate this issue on our test servers or any server we can have root access of, so that we can debug the issue and resolve i accordingly.

Quote
2) YOUR MTA-like Exim-Packed doesn't at all - at least in a professional environment (behind firewall, etc) - except sending mails to itself.

Sir could you please elaborate this ?

Quote
The bad thing about that is, that nobody is able to debug that crippled MTA by themselves, 'cause no one knows where the rest of it is gone.

Sir the Exim configuration file is located at the default installation i.e /etc/exim
If the users understand the exim configurations well and the working of the Exim MTA, they will certainly be able to debug the issues.
The Exim Binary goes through the configuration itself for paths, permissions and so on.

Quote
I suggest you do that thing you got paid for (by buying that license)

What exactly do you mean by this ?

Quote
and try to assist by making suggestions 

Sir we can certainly make suggestions, but will they really be fruitful if they are haywire ?

Quote
and/or explain where the rest of exim is.
Or you could et least for once make a clear call and tell us if an standard packet of exim would work with the webuzo gui (services f. e.)

Code
yum install exim

This is how exim is installed on Webuzo server. The configuration file is altered, you can compare it with the default installation and watch for changed paths and so on.

Quote
3) A lot of threads are cut of by you like "send us a support message" or "send us your details" or something like that, instead of actually helping people to help themselves. This exactly the thing which pisses me really off.

We request for details / support tickets if the issues the users are facing is a different one. We would willingly serve the solution if it is a commonly caused issue and fix it by default in the following version of Webuzo. Apologize if this is not followed in some cases.

Quote
You have made a quite well product and every product has its bugs. But there is very little support for your product on the internet - because YOU DON'T ANSWER QUESTIONS!!!

We are headed towards documenting everything well enough and shall make sure all of the questions are answered then and there.

Hope the answers were satisfactory. Thanks for the suggestions. We would surely consider every bit of it.

You can reach us on Skype to help us assist you faster and better.
Username : webuzo

P.S : Please do not use abusive words.

Edited by valley : October 22, 2013, 6:47 pm

-----------------------
Webuzo : Single User Control Panel
Join Webuzo :
Facebook
Twitter

IP: --   

Exim really f...ed up!!
codesight
Group: Member
Post Group: Working Newbie
Posts: 55
Status:
Quote From : valley October 22, 2013, 6:46 pm
Sir we apologize for the inconvenience caused. Exim is the default MTA at the moment. It is installed using "yum" and installation resides at the default location as on CentOS, including the configuration file.

Of cource Yum is used. But Yum uses the Softaculous-repo. Why use different repo than official centos-repo if the package would be the same? Makes no sense to me - because of that I'm assume the package from your repo is different from official repo.

Quote From : valley October 22, 2013, 6:46 pm
Provide us the steps to replicate the error and we shall debug and resolve it accordingly.

Easy.

1. Set up an virtual machine behind a Firewall. The firewall has an external interface (red) and an internal interface (green). Outgoing traffic is all free incoming traffic is filtered on port basis.
2. Install CentOS 6.4 on that VM via netinstall-ISO and the mirror: http://centos.schlundtech.de/6/os/x86_64
3. Install VMWare-Tools on the VM.
4. After that setup webuzo according to http://www.webuzo.com/wiki/Install (full install)
5. Install exim and dovecot via webuzo gui.
6. create an mail-account

That's it. First you will receive an error on trying to login via squirrel.
On a local client (f. e. Outlook) you have this situation:

IMAP-Login: Yes
POP3-Login: Yes
IMAP-Receive: No
POP3-Receive: Yes
SMTP-Send (to extern): No
SMTP-Send (to intern): Yes
SMTP-Auth: No

Quote
We wish to learn why the default MTA Exim is not following anything on your server specifically.


Quote
OUR Squirrel Webmail does work with OUR Dovecot. We have tested it on many a servers and we have other clients using it as well.

Sure, if you log onto their servers and set den IMAP-Port in squirrel-config files to 993 or modify which causes the ssl force it will work. But the point is you didn't mention such a behaviour anywhere and out of the box is something different, too.

The only difference between a simple click-and-go-installation and mine is my firewall in front. But this situation is not concerning the firewall since webserver & dovecot are on the same server.
So it has to be a settings-thing. Since I didn't touch ANY Config file as the problem occured I wonder if there is another "out of the box" than out of the box.

Quote
Did these changes work for you ? Or still stuck ?

This is a workaround - no solution. I don't want to use SSL since the certificates are self-signed wich bothers every local mailclient. I want to use standard ports 143 and 110 with local clients which is not possible, if dovecot forces the use of ssl on plain auth.

Quote
Could you please provide the steps to replicate this issue on our test servers or any server we can have root access of, so that we can debug the issue and resolve i accordingly.

I'll see what i can do.

Quote
Sir could you please elaborate this ?

The environment or the errors?

Quote
I suggest you do that thing you got paid for (by buying that license)

What exactly do you mean by this ?

Quote
and try to assist by making suggestions 

Sir we can certainly make suggestions, but will they really be fruitful if they are haywire ?

Quote
The configuration file is altered, you can compare it with the default installation and watch for changed paths and so on.

Now we finally get to the point. This is the only defference between the package in your repo and the original one? Assuming you are trying to say so I can finally have a deep look into this.

Quote
We request for details / support tickets if the issues the users are facing is a different one. We would willingly serve the solution if it is a commonly caused issue and fix it by default in the following version of Webuzo. Apologize if this is not followed in some cases.

Reasonable but people like me try always to fix problem by ourselves. People like me read a lot of stuff and get their knowledge of the regarding systems, environments by reading about hundrets of different situations and problems. This is what boards and forums are for.
People like me try to combine several suitable situations and see which is the most logical fit for our special problem.
This kind of learning this is very intensive and time-consuming but in most cases you really get to know stuff.

Maybe you can see why i get all frustratet, if there is only one board regarding webuzo and most threads end after 2 posts.
Especially the custom configurations are the most important stuff you can find in a forum.

Quote
We are headed towards documenting everything well enough and shall make sure all of the questions are answered then and there.

The difference between doing stuff in webuzo and doing stuff on an ordinary centos (whats happening under the gui is ment) is the important stuff.

Quote
Hope the answers were satisfactory. Thanks for the suggestions. We would surely consider every bit of it.

Sorry if I got a little bit rough. Knowledge is important to me and not beeing able to find suitable input around the world wide web drives me nuts.

-----------------------
Don't you dare to ask for root details!
IP: --   

Exim really f...ed up!!
valley
Group: Webuzo Team
Post Group: Super Member
Posts: 1644
Status:
Quote From : codesight October 22, 2013, 8:41 pm

Of cource Yum is used. But Yum uses the Softaculous-repo. Why use different repo than official centos-repo if the package would be the same? Makes no sense to me - because of that I'm assume the package from your repo is different from official repo.

Sir if the default repo is used, we will have to maintain different configurations for different versions (CentOS/Exim). Hence we have a common repo for all.

Quote From : codesight October 22, 2013, 8:41 pm
Easy.

Thanks for providing the steps, we shall follow them and replicate the issues.
If at all we face problems setting it up, we shall notify you for the same.


Quote From : codesight October 22, 2013, 8:41 pm

The only difference between a simple click-and-go-installation and mine is my firewall in front. But this situation is not concerning the firewall since webserver & dovecot are on the same server.
So it has to be a settings-thing. Since I didn't touch ANY Config file as the problem occured I wonder if there is another "out of the box" than out of the box.

Well now that you know the yum install is from the Softaculous repo and I have already told you where the configuration file resides. We shall replicate and the issue and setup a similar test environment. Let us know if you require any other information to debug the issue at your end.

Quote
This is a workaround - no solution. I don't want to use SSL since the certificates are self-signed wich bothers every local mailclient. I want to use standard ports 143 and 110 with local clients which is not possible, if dovecot forces the use of ssl on plain auth.

We shall re-configure the mail server to make this work. Apologize for the inconvenience.

Quote From : codesight October 22, 2013, 8:41 pm
I'll see what i can do.

We can provide you a CentOS machine and you can setup the environment to help us quickly replicate, debug and resolve your issue.

Quote From : codesight October 22, 2013, 8:41 pm
Now we finally get to the point. This is the only defference between the package in your repo and the original one? Assuming you are trying to say so I can finally have a deep look into this..

As for the configuration file located at /etc/exim this is the difference. As for the installation from the repo, we haven't customized it and the official version is served commonly to all users.
If at all the version if faulty, we would certainly replace it.

Quote From : codesight October 22, 2013, 8:41 pm
Reasonable but people like me try always to fix problem by ourselves. People like me read a lot of stuff and get their knowledge of the regarding systems, environments by reading about hundrets of different situations and problems. This is what boards and forums are for.
People like me try to combine several suitable situations and see which is the most logical fit for our special problem.
This kind of learning this is very intensive and time-consuming but in most cases you really get to know stuff.

We shall make sure the queries are answered on the board itself whenever possible.

Quote
Maybe you can see why i get all frustratet, if there is only one board regarding webuzo and most threads end after 2 posts.
Especially the custom configurations are the most important stuff you can find in a forum.

Noted.

Quote
The difference between doing stuff in webuzo and doing stuff on an ordinary centos (whats happening under the gui is ment) is the important stuff.

We would willingly share information. The paths to the configuration are provided earlier. The configuration describes the Exim functionality further.
We would be glad for suggestions to optimize Exim for better performance.

Quote
Sorry if I got a little bit rough. Knowledge is important to me and not beeing able to find suitable input around the world wide web drives me nuts.

True That. We shall have it documented. Suggestions for the same are most welcome.


-----------------------
Webuzo : Single User Control Panel
Join Webuzo :
Facebook
Twitter

IP: --   

Exim not working!!
codesight
Group: Member
Post Group: Working Newbie
Posts: 55
Status:
Quote
Well now that you know the yum install is from the Softaculous repo and I have already told you where the configuration file resides. We shall replicate and the issue and setup a similar test environment. Let us know if you require any other information to debug the issue at your end.


Well I've made a little progress in this and fixed one configuration issue. As I explained, my firewall has an external interface with a public IP-Address. My MX-Records show this address. In order to that any nslookup made by exim will respond with that public IP-Address.

The actually problem in this is, that the routers section in exims config file the dnslookup set as first check. As a matter of fact this checkup gets a respond, so exim won't try any other check which means exim won't  check the vmail and local transport possibility.
As a result of this exim sends emails always back to the public ip instead of delivering locally. It ends a loop.

The solution is to put vmail_deliver and localuser at the beginning of routers section and make sure that dnslookup is called last.

Therefore the situation is this:
IMAP (login in webmail): YES
IMAP (receive in webmail): YES
IMAP (login in local client): YES
IMAP (receive in local client): YES
POP (login in local client): YES
POP (receive in local client): YES
SMTP (send in webmail): YES
SMTP (send in local client): NO (Error is: 550 relay not permitted)

I'm trying to workaround the last problem by using a SMTP-Proxy on my firewall. At the moment I get a 550 there to because webuzo dovecot doesn't accept digest-md5 in order to use dovecot-imap as auth-server.
I assume this would be easier than trying to convince exim to use smtp-auth.

Quote
I want to use standard ports 143 and 110 with local clients which is not possible, if dovecot forces the use of ssl on plain auth.

No progress in this so far. Any suggestions?

Quote
We can provide you a CentOS machine and you can setup the environment to help us quickly replicate, debug and resolve your issue.

This would be the fastest possibility. Just send me the connection details.

-----------------------
Don't you dare to ask for root details!
IP: --   

Exim not working!!
codesight
Group: Member
Post Group: Working Newbie
Posts: 55
Status:
Just a little update:

The dovecot-config ha a bug which causes the ssl-requirement:

/etc/doveconf/cond./10-auth.conf says:
Code
# SSL/TLS support: yes, no, required. <doc/wiki/SSL.txt>
ssl = yes


This is not supposed in this file anymore! The file /etc/doveconf/cond./10-ssl.conf says:
Code
# SSL/TLS support: yes, no, required. <doc/wiki/SSL.txt>
# disable plain pop3 and imap, allowed are only pop3+TLS, pop3s, imap+TLS and imaps
# plain imap and pop3 are still allowed for local connections
ssl = required

This is what causes the enforcement.

Please remove the upper code from config and set the second code to no. Then squirrel and any oder webmail will work as it is supposed to.

-----------------------
Don't you dare to ask for root details!
IP: --   

Exim not working!!
codesight
Group: Member
Post Group: Working Newbie
Posts: 55
Status:
Big Update:

Now I got the last problem fixed!

/etc/dovecot/conf.d/10-auth.conf says:
Code
auth_mechanisms = plain


Change it to:
Code
auth_mechanisms = plain login



Add to /etc/exim/exim.conf in "AUTHENTICATION CONFIGURATION":
Code
dovecot_login:
  driver = dovecot
  public_name = LOGIN
  server_socket = /var/run/dovecot/auth-userdb
  server_set_id = $auth1

dovecot_plain:
  driver = dovecot
  public_name = PLAIN
  server_socket = /var/run/dovecot/auth-userdb
  server_set_id = $auth1


Now imap, pop and smtp work quite well from webmail and local client.

How about u pay me for solving problems and fixing bug  :D
Just kidding  :angel:

-----------------------
Don't you dare to ask for root details!
IP: --   

Exim not working!!
valley
Group: Webuzo Team
Post Group: Super Member
Posts: 1644
Status:
Quote

The actually problem in this is, that the routers section in exims config file the dnslookup set as first check. As a matter of fact this checkup gets a respond, so exim won't try any other check which means exim won't  check the vmail and local transport possibility.
As a result of this exim sends emails always back to the public ip instead of delivering locally. It ends a loop.

The solution is to put vmail_deliver and localuser at the beginning of routers section and make sure that dnslookup is called last.



Thanks for the solution. We shall implement this and have it tested and released by default for all of our clients.

Quote

Quote

I want to use standard ports 143 and 110 with local clients which is
not possible, if dovecot forces the use of ssl on plain auth.

No progress in this so far. Any suggestions?

Sir it should work with the standard IMAP/POP3 ports. As for the SMTP PORT 25 it has a different behavior.

Quote
Big Update:

Now I got the last problem fixed!

This relates to the error "Error is: 550 relay not permitted" and is already fixed.
Patch for the same is only available for CentOS 6.x which install Exim 4.72 and hence it is not officially released.
The fix won't work for Exim 4.63 which is installed on CentOS 5.x
We shall have it fixed as well ASAP.

Thanks for sharing the solutions. These will be of great help to everyone.


Edited by valley : October 24, 2013, 6:01 am

-----------------------
Webuzo : Single User Control Panel
Join Webuzo :
Facebook
Twitter

IP: --   

Exim not working!!
codesight
Group: Member
Post Group: Working Newbie
Posts: 55
Status:
[quote]
I want to use standard ports 143 and 110 with local clients which is
not possible, if dovecot forces the use of ssl on plain auth.
[/quote]
No progress in this so far. Any suggestions?
[/quote]
The reason for this was a faulty devocot configuration provided by softaculous repo as I mentioned in one of the updates in this thread.

[quote]This relates to the error "Error is: 550 relay not permitted" and is already fixed.
Patch for the same is only available for CentOS 6.x which install Exim 4.72 and hence it is not officially released.
The fix won't work for Exim 4.63 which is installed on CentOS 5.x
We shall have it fixed as well ASAP.[/quote]

Wrong! This has nothing to do with a bug in exim, besides that I use Exim 4.72 and CentOS 6.4 as you should know by now.
As I explained, Exim (as ervery other MTA too) needs any authentification in any way. Otherwise it would be an open relay.
You can easily use dovecot for authentication to exim, which a similar way to what the webmail does.
I also explained in this thread how you can setup the authentification from external via dovecot to exim.

I will send you the changed files, so you can compare and understand what the matter is.

-----------------------
Don't you dare to ask for root details!
IP: --   

Exim not working!!
valley
Group: Webuzo Team
Post Group: Super Member
Posts: 1644
Status:
Quote

The reason for this was a faulty devocot configuration provided by softaculous repo as I mentioned in one of the updates in this thread.

Alright, we shall confirm the same and update you about it.


Quote

Wrong! This has nothing to do with a bug in exim, besides that I use Exim 4.72 and CentOS 6.4 as you should know by now.

I also explained in this thread how you can setup the authentification from external via dovecot to exim.


Can you test exactly the same files on CentOS 5.x which install Exim 4.63 ?
It's not a bug with Exim, just that the fix that you shared is applicable for Exim 4.7x and not 4.6x. Correct me if I am wrong.

Quote

As I explained, Exim (as ervery other MTA too) needs any authentification in any way. Otherwise it would be an open relay.

You can easily use dovecot for authentication to exim, which a similar way to what the webmail does.

Completely agree to that.

Quote

I will send you the changed files, so you can compare and understand what the matter is.

Thanks. This would greatly simplify the things.


-----------------------
Webuzo : Single User Control Panel
Join Webuzo :
Facebook
Twitter

IP: --   

Exim not working!!
codesight
Group: Member
Post Group: Working Newbie
Posts: 55
Status:
Quote From : valley October 25, 2013, 5:51 am

Can you test exactly the same files on CentOS 5.x which install Exim 4.63 ?
It's not a bug with Exim, just that the fix that you shared is applicable for Exim 4.7x and not 4.6x. Correct me if I am wrong.

Ok, then I assume I got u wrong on this. Due to a lack of time I don't think I will be able to test this on CentOS 5.x. You could be right.

But I just send you the changed files to developers-address. This should lighten  things up.

Quote

Quote

I will send you the changed files, so you can compare and understand what the matter is.

Thanks. This would greatly simplify the things.


Just did.

-----------------------
Don't you dare to ask for root details!
IP: --   

Exim not working!!
valley
Group: Webuzo Team
Post Group: Super Member
Posts: 1644
Status:
Quote From : codesight October 25, 2013, 1:07 pm

But I just send you the changed files to developers-address. This should lighten  things up.


Great!!! We shall have it reviewed and implemented by default in Webuzo.


-----------------------
Webuzo : Single User Control Panel
Join Webuzo :
Facebook
Twitter

IP: --   

Exim not working!!
radionad
Group: Member
Post Group: Newbie
Posts: 10
Status:
I did the instructions but squirrelmail receive messages but not send them, actually transfer them to the sent message but the recipient does not receive the message.
Do you have any idea why.
IP: --   

Exim not working!!
valley
Group: Webuzo Team
Post Group: Super Member
Posts: 1644
Status:
Quote
I did the instructions but squirrelmail receive messages but not send them, actually transfer them to the sent message but the recipient does not receive the message.
Do you have any idea why.


Give the Exim Service a Restart
Code

Root > service exim restart


-----------------------
Webuzo : Single User Control Panel
Join Webuzo :
Facebook
Twitter

IP: --   

Exim not working!!
radionad
Group: Member
Post Group: Newbie
Posts: 10
Status:
I tried but still the same thing.
IP: --   

« Previous    Next »

Threaded Mode | Print  

1


Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is October 14, 2019, 1:56 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:1.105